about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-06-28 22:27:01 -0400
committerGitHub <noreply@github.com>2018-06-28 22:27:01 -0400
commitc7c34f126192b2a35979a092c6b6b395a372db19 (patch)
treedc61fc213d78bce1d54a214a68148aef51c6ec7e /pkgs/tools
parentfde2e021007869e9908e65fb7c5988bdd37c3b2c (diff)
parentcb2921c8390f27947980f71e0149bf1d5e75a92e (diff)
downloadnixlib-c7c34f126192b2a35979a092c6b6b395a372db19.tar
nixlib-c7c34f126192b2a35979a092c6b6b395a372db19.tar.gz
nixlib-c7c34f126192b2a35979a092c6b6b395a372db19.tar.bz2
nixlib-c7c34f126192b2a35979a092c6b6b395a372db19.tar.lz
nixlib-c7c34f126192b2a35979a092c6b6b395a372db19.tar.xz
nixlib-c7c34f126192b2a35979a092c6b6b395a372db19.tar.zst
nixlib-c7c34f126192b2a35979a092c6b6b395a372db19.zip
Merge pull request #42638 from Ralith/vulkan
Vulkan updates
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/vulkan-tools/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/tools/graphics/vulkan-tools/default.nix b/pkgs/tools/graphics/vulkan-tools/default.nix
new file mode 100644
index 000000000000..4e4f5a5db4a6
--- /dev/null
+++ b/pkgs/tools/graphics/vulkan-tools/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchFromGitHub, cmake, python3, vulkan-loader,
+  glslang, pkgconfig, x11, libxcb, libXrandr, wayland }:
+
+stdenv.mkDerivation rec {
+  name = "vulkan-tools-${version}";
+  version = "1.1.77.0";
+
+  src = fetchFromGitHub {
+    owner = "KhronosGroup";
+    repo = "Vulkan-Tools";
+    rev = "sdk-${version}";
+    sha256 = "1c827n0xz8d7ydqpjchd58as943acyi182a0p4aq3bdsaxlmmpkg";
+  };
+
+  nativeBuildInputs = [ pkgconfig ];
+  buildInputs = [ cmake python3 vulkan-loader x11 libxcb libXrandr wayland ];
+  enableParallelBuilding = true;
+
+  cmakeFlags = [ "-DBUILD_ICD=OFF" "-DGLSLANG_INSTALL_DIR=${glslang}" ];
+
+  meta = with stdenv.lib; {
+    description = "LunarG Vulkan loader";
+    homepage    = "http://www.lunarg.com";
+    platforms   = platforms.linux;
+    license     = licenses.asl20;
+    maintainers = [ maintainers.ralith ];
+  };
+}