about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorDoron Behar <doron.behar@gmail.com>2023-09-28 08:45:06 +0000
committerGitHub <noreply@github.com>2023-09-28 08:45:06 +0000
commitc6f7654c08e7a94d94753afc54d9584fb3974999 (patch)
tree1a9a9162d4faf3450bf8bf01822fdaae0e1e07d5 /pkgs/tools
parent8de702af9037adff65060f2bb4151736d8bc30ba (diff)
parent913a580e08a3f0695b4c54cf838e4520227809ac (diff)
downloadnixlib-c6f7654c08e7a94d94753afc54d9584fb3974999.tar
nixlib-c6f7654c08e7a94d94753afc54d9584fb3974999.tar.gz
nixlib-c6f7654c08e7a94d94753afc54d9584fb3974999.tar.bz2
nixlib-c6f7654c08e7a94d94753afc54d9584fb3974999.tar.lz
nixlib-c6f7654c08e7a94d94753afc54d9584fb3974999.tar.xz
nixlib-c6f7654c08e7a94d94753afc54d9584fb3974999.tar.zst
nixlib-c6f7654c08e7a94d94753afc54d9584fb3974999.zip
Merge pull request #257379 from dotlambda/ical2orgpy-0.5
ical2orgpy: 0.4.0 -> 0.5
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/ical2orgpy/default.nix36
1 files changed, 23 insertions, 13 deletions
diff --git a/pkgs/tools/misc/ical2orgpy/default.nix b/pkgs/tools/misc/ical2orgpy/default.nix
index e5515c3d0149..e9397e14430f 100644
--- a/pkgs/tools/misc/ical2orgpy/default.nix
+++ b/pkgs/tools/misc/ical2orgpy/default.nix
@@ -1,17 +1,22 @@
-{ lib, python3Packages, fetchPypi, ... }:
+{ lib
+, python3
+, fetchFromGitHub
+}:
 
-python3Packages.buildPythonPackage rec {
+python3.pkgs.buildPythonApplication rec {
   pname = "ical2orgpy";
-  version = "0.4.0";
+  version = "0.5";
 
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "sha256-7/kWW1oTSJXPJtN02uIDrFdNJ9ExKRUa3tUNA0oJSoc=";
-  };
+  format = "setuptools";
 
-  disabled = python3Packages.pythonOlder "3.9";
+  src = fetchFromGitHub {
+    owner = "ical2org-py";
+    repo = "ical2org.py";
+    rev = version;
+    hash = "sha256-vBi1WYXMuDFS/PnwFQ/fqN5+gIvtylXidfZklyd6LcI=";
+  };
 
-  propagatedBuildInputs = with python3Packages; [
+  propagatedBuildInputs = with python3.pkgs; [
     click
     future
     icalendar
@@ -19,13 +24,18 @@ python3Packages.buildPythonPackage rec {
     tzlocal
     recurring-ical-events
   ];
-  checkInputs = with python3Packages; [ freezegun pytest pyyaml ];
-  nativeBuildInputs = [ python3Packages.pbr ];
+
+  nativeCheckInputs = with python3.pkgs; [
+    freezegun
+    pytestCheckHook
+    pyyaml
+  ];
 
   meta = with lib; {
-    description = "Converting ICAL file into org-mode format.";
+    changelog = "https://github.com/ical2org-py/ical2org.py/blob/${src.rev}/CHANGELOG.rst";
+    description = "Converting ICAL file into org-mode format";
     homepage = "https://github.com/ical2org-py/ical2org.py";
-    license = licenses.gpl3;
+    license = licenses.gpl3Only;
     maintainers = with maintainers; [ StillerHarpo ];
   };