about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorUjp8LfXBJ6wCPR <github@lillecarl.com>2023-11-23 03:03:17 +0100
committerGitHub <noreply@github.com>2023-11-23 03:03:17 +0100
commitc31544b31046e9831800b583acb31ad9e9677411 (patch)
tree9e39d553ef30cc9e66579b2c2f975db562bad396 /pkgs/tools
parente3e89a0713a72f4094e1e2ee18569a26b30cc4d3 (diff)
downloadnixlib-c31544b31046e9831800b583acb31ad9e9677411.tar
nixlib-c31544b31046e9831800b583acb31ad9e9677411.tar.gz
nixlib-c31544b31046e9831800b583acb31ad9e9677411.tar.bz2
nixlib-c31544b31046e9831800b583acb31ad9e9677411.tar.lz
nixlib-c31544b31046e9831800b583acb31ad9e9677411.tar.xz
nixlib-c31544b31046e9831800b583acb31ad9e9677411.tar.zst
nixlib-c31544b31046e9831800b583acb31ad9e9677411.zip
aws2cli: fix urllib3 build (#268590)
Fixes the build by setting up the PEP517 builder to satisfy the format/pyproject requirement of python derivations.

> assert (pyproject != null) -> (format == null);

Co-authored-by: Carl Hjerpe <git@hjerpe.xyz>
Co-authored-by: P. <WolfangAukang@users.noreply.github.com>
Co-authored-by: André Vitor de Lima Matos <andre.vmatos@gmail.com>
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/awscli2/default.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/pkgs/tools/admin/awscli2/default.nix b/pkgs/tools/admin/awscli2/default.nix
index b59f702701f7..5582f63ffc0c 100644
--- a/pkgs/tools/admin/awscli2/default.nix
+++ b/pkgs/tools/admin/awscli2/default.nix
@@ -19,10 +19,14 @@ let
           hash = "sha256-i3zml6LyEnUqNcGsQURx3BbEJMlXO+SSa1b/P10jt68=";
         };
       });
-      urllib3 = prev.urllib3.overridePythonAttrs (prev: {
-        format = "setuptools";
+      urllib3 = prev.urllib3.overridePythonAttrs (prev: rec {
+        pyproject = true;
+        version = "1.26.18";
+        nativeBuildInputs = with final; [
+          setuptools
+        ];
         src = prev.src.override {
-          version = "1.26.18";
+          inherit version;
           hash = "sha256-+OzBu6VmdBNFfFKauVW/jGe0XbeZ0VkGYmFxnjKFgKA=";
         };
       });