about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPascal Wittmann <PascalWittmann@gmx.net>2015-05-20 23:45:35 +0200
committerPascal Wittmann <PascalWittmann@gmx.net>2015-05-20 23:45:35 +0200
commitc2dd7622c5bc8c74ee87bf58152c23531e749161 (patch)
treedc317e7cc35ce4e7ef06a9880f622b4a2f0d14f0 /pkgs/tools
parent98ad87fb4de1fddc91fdbce6e0138a1420d8d66f (diff)
parent05a6c34e04c0f16f02f8045ce567dec4b43ca082 (diff)
downloadnixlib-c2dd7622c5bc8c74ee87bf58152c23531e749161.tar
nixlib-c2dd7622c5bc8c74ee87bf58152c23531e749161.tar.gz
nixlib-c2dd7622c5bc8c74ee87bf58152c23531e749161.tar.bz2
nixlib-c2dd7622c5bc8c74ee87bf58152c23531e749161.tar.lz
nixlib-c2dd7622c5bc8c74ee87bf58152c23531e749161.tar.xz
nixlib-c2dd7622c5bc8c74ee87bf58152c23531e749161.tar.zst
nixlib-c2dd7622c5bc8c74ee87bf58152c23531e749161.zip
Merge pull request #7914 from pjones/pkg/mpdris2
New package: mpDris2, MPRIS 2 support for mpd
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/audio/mpdris2/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/tools/audio/mpdris2/default.nix b/pkgs/tools/audio/mpdris2/default.nix
new file mode 100644
index 000000000000..82ddc85fd880
--- /dev/null
+++ b/pkgs/tools/audio/mpdris2/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, fetchurl, autoreconfHook, intltool
+, python, wrapPython, mpd, pygtk, dbus, pynotify
+}:
+
+stdenv.mkDerivation rec {
+  name = "mpDris2";
+  version = "0.6";
+
+  src = fetchurl {
+    url = "https://github.com/eonpatapon/${name}/archive/${version}.tar.gz";
+    sha256 = "0zdmamj2ldhr6y3s464w8y2x3yizda784jnlrg3j3myfabssisvz";
+  };
+
+  buildInputs = [ intltool autoreconfHook ];
+  propagatedBuildInputs = [ python wrapPython ];
+  pythonPath = [ mpd pygtk dbus pynotify ];
+  postInstall = "wrapPythonPrograms";
+
+  meta = with stdenv.lib; {
+    description = "MPRIS 2 support for mpd";
+    homepage = https://github.com/eonpatapon/mpDris2/;
+    license = licenses.gpl3;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ pjones ];
+  };
+}