about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFlorian Klink <flokli@flokli.de>2020-06-16 00:23:47 +0200
committerGitHub <noreply@github.com>2020-06-16 00:23:47 +0200
commitc09eb57e38e2ee6fb3fd5735012ceab12ea9e08f (patch)
treecd79d24f30cf03bba03ae12e77225b99ff19b641 /pkgs/tools
parent6270712773c7918c117fe8b33db536ea6ef8b69b (diff)
parentfcecf15dc4105663f1dec7d954249824d3e555e8 (diff)
downloadnixlib-c09eb57e38e2ee6fb3fd5735012ceab12ea9e08f.tar
nixlib-c09eb57e38e2ee6fb3fd5735012ceab12ea9e08f.tar.gz
nixlib-c09eb57e38e2ee6fb3fd5735012ceab12ea9e08f.tar.bz2
nixlib-c09eb57e38e2ee6fb3fd5735012ceab12ea9e08f.tar.lz
nixlib-c09eb57e38e2ee6fb3fd5735012ceab12ea9e08f.tar.xz
nixlib-c09eb57e38e2ee6fb3fd5735012ceab12ea9e08f.tar.zst
nixlib-c09eb57e38e2ee6fb3fd5735012ceab12ea9e08f.zip
Merge pull request #90537 from maralorn/fix-system-config-printer
system-config-printer: Fix ABRT: free(): invalid pointer
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/system-config-printer/default.nix17
1 files changed, 15 insertions, 2 deletions
diff --git a/pkgs/tools/misc/system-config-printer/default.nix b/pkgs/tools/misc/system-config-printer/default.nix
index e9ee91de6776..8a0c881a277b 100644
--- a/pkgs/tools/misc/system-config-printer/default.nix
+++ b/pkgs/tools/misc/system-config-printer/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, udev, intltool, pkgconfig, glib, xmlto, wrapGAppsHook
+{ stdenv, fetchFromGitHub, fetchpatch, udev, intltool, pkgconfig, glib, xmlto, wrapGAppsHook
 , docbook_xml_dtd_412, docbook_xsl
 , libxml2, desktop-file-utils, libusb1, cups, gdk-pixbuf, pango, atk, libnotify
 , gobject-introspection, libsecret, packagekit
@@ -24,7 +24,20 @@ stdenv.mkDerivation rec {
     substituteInPlace Makefile.am --replace /bin/bash ${bash}/bin/bash
   '';
 
-  patches = [ ./detect_serverbindir.patch ];
+  patches = [
+    ./detect_serverbindir.patch
+
+    # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=958104
+    # (Fixes will be included in next upstream release.)
+    (fetchpatch {
+      url = "https://github.com/OpenPrinting/system-config-printer/commit/cf9903466c1a2d18a701f3b5e8c7e03483e1244d.patch";
+      sha256 = "03gpav618w50q90m2kdkgwclc7fv17m493fgjd633zfavb5kqr3n";
+    })
+    (fetchpatch {
+      url = "https://github.com/OpenPrinting/system-config-printer/commit/b9289dfe105bdb502f183f0afe7a115ecae5f2af.patch";
+      sha256 = "12w47hy3ly4phh8jcqxvdnd5sgbnbp8dnscjd7d5y2i43kxj7b23";
+    })
+  ];
 
   buildInputs = [
     glib udev libusb1 cups