about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSandro Jäckel <sandro.jaeckel@gmail.com>2021-02-13 00:43:13 +0100
committerSandro Jäckel <sandro.jaeckel@gmail.com>2021-02-13 02:37:08 +0100
commitbe844a34b7a55f6ee4f38072422882ea7b592409 (patch)
tree0afd7cacbff38c8b001bce68cbf960b9f72e6345 /pkgs/tools
parent5852a21819542e6809f68ba5a798600e69874e76 (diff)
downloadnixlib-be844a34b7a55f6ee4f38072422882ea7b592409.tar
nixlib-be844a34b7a55f6ee4f38072422882ea7b592409.tar.gz
nixlib-be844a34b7a55f6ee4f38072422882ea7b592409.tar.bz2
nixlib-be844a34b7a55f6ee4f38072422882ea7b592409.tar.lz
nixlib-be844a34b7a55f6ee4f38072422882ea7b592409.tar.xz
nixlib-be844a34b7a55f6ee4f38072422882ea7b592409.tar.zst
nixlib-be844a34b7a55f6ee4f38072422882ea7b592409.zip
xh: 0.5.0 -> 0.7.0, rename from ht-rust
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/ht-rust/default.nix34
-rw-r--r--pkgs/tools/networking/xh/default.nix31
2 files changed, 31 insertions, 34 deletions
diff --git a/pkgs/tools/networking/ht-rust/default.nix b/pkgs/tools/networking/ht-rust/default.nix
deleted file mode 100644
index 629cf4ed11e1..000000000000
--- a/pkgs/tools/networking/ht-rust/default.nix
+++ /dev/null
@@ -1,34 +0,0 @@
-{ stdenv, lib, rustPlatform, fetchFromGitHub, Security }:
-
-rustPlatform.buildRustPackage rec {
-  pname = "ht-rust";
-  version = "0.5.0";
-
-  src = fetchFromGitHub {
-    owner = "ducaale";
-    repo = "ht";
-    rev = "v${version}";
-    sha256 = "cr/iavCRdFYwVR6Iemm1hLKqd0OFG1iDmxpQ9fiwOmU=";
-  };
-
-  cargoSha256 = "uB23/9AjPwCwf9ljE8ai7zJQZqE0SoBPzRqqBOXa9QA=";
-
-  buildInputs = [ ] ++ lib.optional stdenv.isDarwin Security;
-
-  # Symlink to avoid conflict with pre-existing ht package
-  postInstall = ''
-    ln -s $out/bin/ht $out/bin/ht-rust
-  '';
-
-  doInstallCheck = true;
-  postInstallCheck = ''
-    $out/bin/ht-rust --help > /dev/null
-  '';
-
-  meta = with lib; {
-    description = "Yet another HTTPie clone in Rust";
-    homepage = "https://github.com/ducaale/ht";
-    license = licenses.mit;
-    maintainers = [ maintainers.payas ];
-  };
-}
diff --git a/pkgs/tools/networking/xh/default.nix b/pkgs/tools/networking/xh/default.nix
new file mode 100644
index 000000000000..b7246959017a
--- /dev/null
+++ b/pkgs/tools/networking/xh/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, lib, rustPlatform, fetchFromGitHub, Security }:
+
+rustPlatform.buildRustPackage rec {
+  pname = "xh";
+  version = "0.7.0";
+
+  src = fetchFromGitHub {
+    owner = "ducaale";
+    repo = "xh";
+    rev = "v${version}";
+    sha256 = "0b7q0xbfbrhvpnxbm9bd1ncdza9k2kcmcir3qhqzb2pgsb5b5njx";
+  };
+
+  cargoSha256 = "02fgqys9qf0jzs2n230pyj151v6xbm6wm2rd9qm5gsib6zaq7gfa";
+
+  buildInputs = lib.optional stdenv.isDarwin Security;
+
+  checkFlagsArray = [ "--skip=basic_options" ];
+
+  doInstallCheck = true;
+  postInstallCheck = ''
+    $out/bin/xh --help > /dev/null
+  '';
+
+  meta = with lib; {
+    description = "Yet another HTTPie clone in Rust";
+    homepage = "https://github.com/ducaale/xh";
+    license = licenses.mit;
+    maintainers = with maintainers; [ payas SuperSandro2000 ];
+  };
+}