about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2014-03-22 21:53:07 -0400
committerShea Levy <shea@shealevy.com>2014-03-22 21:53:07 -0400
commitbe821ba0bfc8068d9d9de1117963ef1295626a12 (patch)
treeff08e88bc03c6566fa265e6d91e4f5ab54ac9508 /pkgs/tools
parent5fca5a44355bbf896847d15a8ba44fbeb3a44c95 (diff)
parentd30644136001176b2f6ee94bb8ec947b02841461 (diff)
downloadnixlib-be821ba0bfc8068d9d9de1117963ef1295626a12.tar
nixlib-be821ba0bfc8068d9d9de1117963ef1295626a12.tar.gz
nixlib-be821ba0bfc8068d9d9de1117963ef1295626a12.tar.bz2
nixlib-be821ba0bfc8068d9d9de1117963ef1295626a12.tar.lz
nixlib-be821ba0bfc8068d9d9de1117963ef1295626a12.tar.xz
nixlib-be821ba0bfc8068d9d9de1117963ef1295626a12.tar.zst
nixlib-be821ba0bfc8068d9d9de1117963ef1295626a12.zip
Merge branch 'f2fs-tools' of git://github.com/ehmry/nixpkgs
f2fs-tools: initial expression
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/f2fs-tools/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/tools/filesystems/f2fs-tools/default.nix b/pkgs/tools/filesystems/f2fs-tools/default.nix
new file mode 100644
index 000000000000..72f417ff10ba
--- /dev/null
+++ b/pkgs/tools/filesystems/f2fs-tools/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchgit, autoconf, automake, libtool, pkgconfig, libuuid }:
+
+stdenv.mkDerivation rec {
+  name = "f2fs-tools-${version}";
+  version = "1.3.0";
+
+  src = fetchgit {
+    url = git://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/f2fs-tools.git;
+    rev = "refs/tags/v${version}";
+    sha256 = "1r97k91qaf42jz623jqy0wm97yjq1ym034q4fdhfirq27s46sn6i";
+  };
+
+  buildInputs = [ autoconf automake libtool pkgconfig libuuid ];
+
+  preConfigure = ''
+    sed -i '/AC_SUBST/d' configure.ac
+    autoreconf --install
+  '';
+
+  meta = {
+    homepage = "http://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/";
+    description = "Userland tools for the f2fs filesystem";
+    license = stdenv.lib.licenses.gpl2;
+  };
+}