about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPhilipp Gesang <phg@phi-gamma.net>2017-02-14 22:20:52 +0100
committerPhilipp Gesang <phg@phi-gamma.net>2017-02-17 15:29:03 +0100
commitb4e9bcfc12cba74f8fb4804c170658db634e5d0a (patch)
treef38e483114e188dacbf434f0e0d11ee9857a5893 /pkgs/tools
parent048c04654dfcb48c8d8e6ddbb011c752eaa88e61 (diff)
downloadnixlib-b4e9bcfc12cba74f8fb4804c170658db634e5d0a.tar
nixlib-b4e9bcfc12cba74f8fb4804c170658db634e5d0a.tar.gz
nixlib-b4e9bcfc12cba74f8fb4804c170658db634e5d0a.tar.bz2
nixlib-b4e9bcfc12cba74f8fb4804c170658db634e5d0a.tar.lz
nixlib-b4e9bcfc12cba74f8fb4804c170658db634e5d0a.tar.xz
nixlib-b4e9bcfc12cba74f8fb4804c170658db634e5d0a.tar.zst
nixlib-b4e9bcfc12cba74f8fb4804c170658db634e5d0a.zip
afio: init at 2.5.1
Signed-off-by: Philipp Gesang <phg@phi-gamma.net>
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/archivers/afio/afio-2.5.1-install.patch48
-rw-r--r--pkgs/tools/archivers/afio/default.nix31
2 files changed, 79 insertions, 0 deletions
diff --git a/pkgs/tools/archivers/afio/afio-2.5.1-install.patch b/pkgs/tools/archivers/afio/afio-2.5.1-install.patch
new file mode 100644
index 000000000000..9fa7aacfa887
--- /dev/null
+++ b/pkgs/tools/archivers/afio/afio-2.5.1-install.patch
@@ -0,0 +1,48 @@
+--- p1/Makefile.orig	2017-02-14 21:40:20.404249126 +0100
++++ p1/Makefile	2017-02-19 23:38:43.880414077 +0100
+@@ -66,37 +66,42 @@
+ # systems the large file compile environment itself might be buggy or beta.
+ #LARGEFILEFLAGS=
+ LARGEFILEFLAGS=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+ 
+ # even more warnings flags..
+ MW=
+ #MW=-Wtraditional -Wcast-qual -Wcast-align -Wconversion -pedantic -Wlong-long -Wimplicit -Wuninitialized -W -Wshadow -Wsign-compare -Wstrict-prototypes -Wmissing-declarations
+ 
+ CFLAGS1 = -Wall -Wstrict-prototypes -s -O2 -fomit-frame-pointer ${LARGEFILEFLAGS} ${MW}
+ 
+-CC=gcc
++#CC=gcc
+ 
+ CFLAGS = ${CFLAGS1} $1 $2 $3 $4 $5 $6 $7 $8 $9 $a $b $c $d $e ${e2} $f $g $I
+ LDFLAGS =
+ 
+ afio : afio.o compfile.o exten.o match.o $M
+ 	${CC} ${LDFLAGS} afio.o compfile.o exten.o match.o $M -o afio
+ 
+ clean:
+ 	rm -f *.o afio 
+ 	rm -f regtest/cmpstat regtest/makesparse
+ 	rm -f regtest/statsize regtest/statsize64
+ 	cd regtest; /bin/sh regtest.clean
+ 
++ifndef DESTDIR
++install:
++	$(error Please specify install prefix as $$DESTDIR)
++else
+ install: afio
+-	cp afio /usr/local/bin
+-	cp afio.1 /usr/share/man/man1
++	install -Dm755 afio $(DESTDIR)/bin/afio
++	install -Dm644 afio.1 $(DESTDIR)/share/man/man1/afio.1
++endif
+ 
+ # generate default list of -E extensions from manpage
+ # note: on sun, I had to change awk command below to nawk or gawk
+ # to get it to work.
+ exten_default.h : afio.1
+ 		awk -f exten_make.awk afio.1 >exten_default.h
+ 
+ 
+ afio.o : afio.h patchlevel.h
+ compfile.o : afio.h
diff --git a/pkgs/tools/archivers/afio/default.nix b/pkgs/tools/archivers/afio/default.nix
new file mode 100644
index 000000000000..551e38a7869d
--- /dev/null
+++ b/pkgs/tools/archivers/afio/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchurl } :
+
+stdenv.mkDerivation rec {
+  version = "2.5.1";
+  name = "afio-${version}";
+
+  src = fetchurl {
+    url = "http://members.chello.nl/~k.holtman/${name}.tgz";
+    sha256 = "363457a5d6ee422d9b704ef56d26369ca5ee671d7209cfe799cab6e30bf2b99a";
+  };
+
+  /*
+   * A patch to simplify the installation and for removing the
+   * hard coded dependency on GCC.
+   */
+  patches = [ ./afio-2.5.1-install.patch ];
+
+  installFlags = "DESTDIR=$(out)";
+
+  meta = {
+    homepage = http://members.chello.nl/~k.holtman/afio.html;
+    description = "Fault tolerant cpio archiver targeting backups";
+    platforms = stdenv.lib.platforms.all;
+    /*
+     * Licensing is complicated due to the age of the code base, but
+     * generally free. See the file ``afio_license_issues_v5.txt`` for
+     * a comprehensive discussion.
+     */
+    license = stdenv.lib.licenses.free;
+  };
+}