about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFranz Pletz <fpletz@fnordicwalking.de>2017-05-20 22:45:48 +0200
committerFranz Pletz <fpletz@fnordicwalking.de>2017-05-21 01:16:42 +0200
commitb41196877436ac249077fdcc7e419cb056a53de0 (patch)
tree195e8ecb5091a54e6139c3b1e21b6c8f02ef6eeb /pkgs/tools
parent458895db332d394bfadc05404a020ea0b4b1ee7f (diff)
downloadnixlib-b41196877436ac249077fdcc7e419cb056a53de0.tar
nixlib-b41196877436ac249077fdcc7e419cb056a53de0.tar.gz
nixlib-b41196877436ac249077fdcc7e419cb056a53de0.tar.bz2
nixlib-b41196877436ac249077fdcc7e419cb056a53de0.tar.lz
nixlib-b41196877436ac249077fdcc7e419cb056a53de0.tar.xz
nixlib-b41196877436ac249077fdcc7e419cb056a53de0.tar.zst
nixlib-b41196877436ac249077fdcc7e419cb056a53de0.zip
lldpd: init at 0.9.7
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/lldpd/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/tools/networking/lldpd/default.nix b/pkgs/tools/networking/lldpd/default.nix
new file mode 100644
index 000000000000..8e3bd7a82bf3
--- /dev/null
+++ b/pkgs/tools/networking/lldpd/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, lib, fetchurl, pkgconfig
+, libevent, readline, net_snmp }:
+
+stdenv.mkDerivation rec {
+  name = "lldpd-${version}";
+  version = "0.9.7";
+
+  src = fetchurl {
+    url = "https://media.luffy.cx/files/lldpd/${name}.tar.gz";
+    sha256 = "1f0d5s4643pjmgycc5ssgl1pggyq5a7navhabkyhcg0aqdah6dmr";
+  };
+
+  configureFlags = [
+    "--localstatedir=/var"
+    "--enable-pie"
+    "--with-snmp"
+  ];
+
+  nativeBuildInputs = [ pkgconfig ];
+  buildInputs = [ libevent readline net_snmp ];
+
+  enableParallelBuilding = true;
+
+  outputs = [ "out" "dev" "man" "doc" ];
+
+  meta = with lib; {
+    description = "802.1ab implementation (LLDP) to help you locate neighbors of all your equipments";
+    homepage = "https://vincentbernat.github.io/lldpd/";
+    license = licenses.isc;
+    maintainers = with maintainers; [ fpletz ];
+    platforms = platforms.linux;
+  };
+}