about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-05-27 21:56:04 +0200
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-05-27 22:00:06 +0200
commitb2d7f4b1ba937951fefdd026314512ab0be91508 (patch)
treed1f7fc189bac34f376069294d67abfa3c8551693 /pkgs/tools
parent87fd373aac3a1aaa84ddb328d43074aeebc1b133 (diff)
downloadnixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.gz
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.bz2
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.lz
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.xz
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.tar.zst
nixlib-b2d7f4b1ba937951fefdd026314512ab0be91508.zip
Use common licence attributes from lib/licenses.nix
Many (less easily automatically converted) old-style strings
remain.

Where there was any possible ambiguity about the exact version or
variant intended, nothing was changed. IANAL, nor a search robot.

Use `with stdenv.lib` wherever it makes sense.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/backup/bacula/default.nix4
-rw-r--r--pkgs/tools/compression/xz/default.nix8
-rw-r--r--pkgs/tools/filesystems/nixpart/0.4/blivet.nix6
-rw-r--r--pkgs/tools/filesystems/s3fs/default.nix4
-rw-r--r--pkgs/tools/networking/isync/default.nix8
-rw-r--r--pkgs/tools/networking/maildrop/default.nix4
-rw-r--r--pkgs/tools/networking/mailutils/default.nix9
-rw-r--r--pkgs/tools/networking/nss-pam-ldapd/default.nix4
-rw-r--r--pkgs/tools/networking/wicd/default.nix6
-rw-r--r--pkgs/tools/system/bootchart/default.nix4
-rw-r--r--pkgs/tools/system/dog/default.nix10
-rw-r--r--pkgs/tools/system/tm/default.nix8
-rw-r--r--pkgs/tools/system/ts/default.nix8
13 files changed, 43 insertions, 40 deletions
diff --git a/pkgs/tools/backup/bacula/default.nix b/pkgs/tools/backup/bacula/default.nix
index 4882097c91a7..fdc52eabd4b5 100644
--- a/pkgs/tools/backup/bacula/default.nix
+++ b/pkgs/tools/backup/bacula/default.nix
@@ -25,8 +25,8 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "Enterprise ready, Network Backup Tool";
     homepage    = http://bacula.org/;
-    license     = "GPLv2";
+    license     = with licenses; gpl2;
     maintainers = with maintainers; [ iElectric lovek323 ];
-    platforms   = stdenv.lib.platforms.all;
+    platforms   = platforms.all;
   };
 }
diff --git a/pkgs/tools/compression/xz/default.nix b/pkgs/tools/compression/xz/default.nix
index 69c14023701b..6a9d4582dff2 100644
--- a/pkgs/tools/compression/xz/default.nix
+++ b/pkgs/tools/compression/xz/default.nix
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
 
   postInstall = "rm -rf $out/share/doc";
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://tukaani.org/xz/;
     description = "XZ, general-purpose data compression software, successor of LZMA";
 
@@ -33,8 +33,8 @@ stdenv.mkDerivation rec {
          bzip2.
       '';
 
-    license = [ "GPLv2+" "LGPLv2.1+" ];
-    maintainers = with stdenv.lib.maintainers; [ sander ];
-    platforms = stdenv.lib.platforms.all;
+    license = with licenses; [ gpl2Plus lgpl21Plus ];
+    maintainers = with maintainers; [ sander ];
+    platforms = platforms.all;
   };
 }
diff --git a/pkgs/tools/filesystems/nixpart/0.4/blivet.nix b/pkgs/tools/filesystems/nixpart/0.4/blivet.nix
index 44333b519cbe..fd7d59774b26 100644
--- a/pkgs/tools/filesystems/nixpart/0.4/blivet.nix
+++ b/pkgs/tools/filesystems/nixpart/0.4/blivet.nix
@@ -45,10 +45,10 @@ buildPythonPackage rec {
   # tests are currently _heavily_ broken upstream
   doCheck = false;
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = "https://fedoraproject.org/wiki/Blivet";
     description = "Module for management of a system's storage configuration";
-    license = [ "GPLv2+" "LGPLv2.1+" ];
-    platforms = stdenv.lib.platforms.linux;
+    license = with licenses; [ gpl2Plus lgpl21Plus ];
+    platforms = platforms.linux;
   };
 }
diff --git a/pkgs/tools/filesystems/s3fs/default.nix b/pkgs/tools/filesystems/s3fs/default.nix
index c39f5cba775b..f081f8121699 100644
--- a/pkgs/tools/filesystems/s3fs/default.nix
+++ b/pkgs/tools/filesystems/s3fs/default.nix
@@ -9,8 +9,8 @@ stdenv.mkDerivation {
   preConfigure = "./autogen.sh";
   buildInputs = [ autoconf automake pkgconfig curl openssl libxml2 fuse ];
   
-  meta = {
+  meta = with stdenv.lib; {
     description = "Mount an S3 bucket as filesystem through FUSE";
-    license = "GPLv2";
+    license = with licenses; gpl2;
   };
 }
diff --git a/pkgs/tools/networking/isync/default.nix b/pkgs/tools/networking/isync/default.nix
index 47efe53c0a97..f16698ef3cd9 100644
--- a/pkgs/tools/networking/isync/default.nix
+++ b/pkgs/tools/networking/isync/default.nix
@@ -10,12 +10,12 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ openssl pkgconfig db cyrus_sasl ];
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://isync.sourceforge.net/;
     description = "Free IMAP and MailDir mailbox synchronizer";
-    license = [ "GPLv2+" ];
+    license = with licenses; [ gpl2Plus ];
 
-    maintainers = with stdenv.lib.maintainers; [ the-kenny viric ];
-    platforms = stdenv.lib.platforms.unix;
+    maintainers = with maintainers; [ the-kenny viric ];
+    platforms = platforms.unix;
   };
 }
diff --git a/pkgs/tools/networking/maildrop/default.nix b/pkgs/tools/networking/maildrop/default.nix
index 991d75c66ae4..cf9c3a4fa4e0 100644
--- a/pkgs/tools/networking/maildrop/default.nix
+++ b/pkgs/tools/networking/maildrop/default.nix
@@ -12,9 +12,9 @@ stdenv.mkDerivation rec {
 
   patches = [ ./maildrop.configure.hack.patch ]; # for building in chroot
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://www.courier-mta.org/maildrop/;
     description = "Mail filter/mail delivery agent that is used by the Courier Mail Server";
-    license = [ "GPLv3" ];
+    license = with licenses; gpl3;
   };
 }
diff --git a/pkgs/tools/networking/mailutils/default.nix b/pkgs/tools/networking/mailutils/default.nix
index 0b57a752a375..cbca408f0842 100644
--- a/pkgs/tools/networking/mailutils/default.nix
+++ b/pkgs/tools/networking/mailutils/default.nix
@@ -23,7 +23,7 @@ stdenv.mkDerivation rec {
   # Tests fail since gcc 4.8
   doCheck = false;
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "Rich and powerful protocol-independent mail framework";
 
     longDescription = ''
@@ -46,13 +46,16 @@ stdenv.mkDerivation rec {
       message handling system.
     '';
 
-    license = [ "LGPLv3+" /* libraries */  "GPLv3+" /* tools */ ];
+    license = with licenses; [
+      lgpl3Plus /* libraries */
+      gpl3Plus /* tools */
+    ];
 
     maintainers = [ ];
 
     homepage = http://www.gnu.org/software/mailutils/;
 
     # Some of the dependencies fail to build on {cyg,dar}win.
-    platforms = stdenv.lib.platforms.gnu;
+    platforms = platforms.gnu;
   };
 }
diff --git a/pkgs/tools/networking/nss-pam-ldapd/default.nix b/pkgs/tools/networking/nss-pam-ldapd/default.nix
index a63ec2a3d680..2368470b84d7 100644
--- a/pkgs/tools/networking/nss-pam-ldapd/default.nix
+++ b/pkgs/tools/networking/nss-pam-ldapd/default.nix
@@ -26,9 +26,9 @@ stdenv.mkDerivation rec {
     wrapProgram $out/sbin/nslcd --prefix LD_LIBRARY_PATH ":" $out/lib
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "LDAP identity and authentication for NSS/PAM";
     homepage = http://arthurdejong.org/nss-pam-ldapd/;
-    license = [ "GPLv21" ];
+    license = with licenses; [ lgpl21 ];
   };
 }
diff --git a/pkgs/tools/networking/wicd/default.nix b/pkgs/tools/networking/wicd/default.nix
index 55a99dd2729a..7f6addc86294 100644
--- a/pkgs/tools/networking/wicd/default.nix
+++ b/pkgs/tools/networking/wicd/default.nix
@@ -100,7 +100,7 @@ stdenv.mkDerivation rec {
     echo "wpa2-ttls" >> "$out/etc/encryption/templates/active"
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://wicd.net/;
     description = "A wiredless and wired network manager";
     longDescription=''
@@ -112,7 +112,7 @@ stdenv.mkDerivation rec {
       encryption types, such as WPA and WEP. Wicd will automatically
       connect at startup to any preferred network within range.
     '';
-    maintainers = [ stdenv.lib.maintainers.roconnor ];
-    license="GPLv2";
+    maintainers = [ maintainers.roconnor ];
+    license = with licenses; gpl2;
   };
 }
diff --git a/pkgs/tools/system/bootchart/default.nix b/pkgs/tools/system/bootchart/default.nix
index bb3f9d72e828..1e2f74e1b0a2 100644
--- a/pkgs/tools/system/bootchart/default.nix
+++ b/pkgs/tools/system/bootchart/default.nix
@@ -28,10 +28,10 @@ stdenv.mkDerivation rec {
     chmod +x $out/sbin/bootchartd
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://www.bootchart.org/;
     description = "Performance analysis and visualization of the GNU/Linux boot process";
-    license="GPLv2+";
+    license = with licenses; gpl2Plus;
   };
 
 }
diff --git a/pkgs/tools/system/dog/default.nix b/pkgs/tools/system/dog/default.nix
index 9c98da6ac85b..fd911142c219 100644
--- a/pkgs/tools/system/dog/default.nix
+++ b/pkgs/tools/system/dog/default.nix
@@ -15,11 +15,11 @@ stdenv.mkDerivation rec {
     cp dog $out/bin
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = "http://lwn.net/Articles/421072/";
-    description = "a cat replacement";
-    license="GPLv2+";
-    maintainers = with stdenv.lib.maintainers; [qknight];
-    platforms = with stdenv.lib.platforms; all;
+    description = "cat replacement";
+    license = with licenses; gpl2Plus;
+    maintainers = with maintainers; [ qknight ];
+    platforms = with platforms; all;
   };
 }
diff --git a/pkgs/tools/system/tm/default.nix b/pkgs/tools/system/tm/default.nix
index 0a4c1e58fc54..a1397cb6214f 100644
--- a/pkgs/tools/system/tm/default.nix
+++ b/pkgs/tools/system/tm/default.nix
@@ -17,12 +17,12 @@ stdenv.mkDerivation {
     sha256 = "3b389bc03b6964ad5ffa57a344b891fdbcf7c9b2604adda723a863f83657c4a0";
   };
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = "http://vicerveza.homeunix.net/~viric/soft/tm";
     description = "terminal mixer - multiplexer for the i/o of terminal applications";
-    license="GPLv2";
-    maintainers = with stdenv.lib.maintainers; [viric];
-    platforms = with stdenv.lib.platforms; all;
+    license = with licenses; gpl2;
+    maintainers = with maintainers; [ viric ];
+    platforms = with platforms; all;
   };
 
 }
diff --git a/pkgs/tools/system/ts/default.nix b/pkgs/tools/system/ts/default.nix
index 6d1c6ad5e1ff..6cd69a746f0e 100644
--- a/pkgs/tools/system/ts/default.nix
+++ b/pkgs/tools/system/ts/default.nix
@@ -20,11 +20,11 @@ stdenv.mkDerivation rec {
     sha256 = "042r9a09300v4fdrw4r60g5xi25v5m6g12kvvr6pcsm9qnfqyqqs";
   };
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = "http://vicerveza.homeunix.net/~viric/soft/ts";
     description = "task spooler - batch queue";
-    license="GPLv2";
-    maintainers = with stdenv.lib.maintainers; [viric];
-    platforms = with stdenv.lib.platforms; all;
+    license = with licenses; gpl2;
+    maintainers = with maintainers; [ viric ];
+    platforms = with platforms; all;
   };
 }