about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorxeji <36407913+xeji@users.noreply.github.com>2018-06-30 00:42:21 +0200
committerGitHub <noreply@github.com>2018-06-30 00:42:21 +0200
commitad112ca0a48a25ba760a616a5eb18b85e0a82559 (patch)
tree560ce485c175f0e8f0dbdfcf00a46359cfa45653 /pkgs/tools
parent1ebc85bf606c7a21188b4c389566b5e1317b3be0 (diff)
parentaa11e10977fafbcd1a1cbaa75e0aea33f8cba7c8 (diff)
downloadnixlib-ad112ca0a48a25ba760a616a5eb18b85e0a82559.tar
nixlib-ad112ca0a48a25ba760a616a5eb18b85e0a82559.tar.gz
nixlib-ad112ca0a48a25ba760a616a5eb18b85e0a82559.tar.bz2
nixlib-ad112ca0a48a25ba760a616a5eb18b85e0a82559.tar.lz
nixlib-ad112ca0a48a25ba760a616a5eb18b85e0a82559.tar.xz
nixlib-ad112ca0a48a25ba760a616a5eb18b85e0a82559.tar.zst
nixlib-ad112ca0a48a25ba760a616a5eb18b85e0a82559.zip
Merge pull request #42782 from dotlambda/dateutil-2.7-fixes
Fix packages broken by python-dateutil bump
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/papis/default.nix28
1 files changed, 20 insertions, 8 deletions
diff --git a/pkgs/tools/misc/papis/default.nix b/pkgs/tools/misc/papis/default.nix
index 49c57ab8dc90..20fafff587c5 100644
--- a/pkgs/tools/misc/papis/default.nix
+++ b/pkgs/tools/misc/papis/default.nix
@@ -1,12 +1,24 @@
 { buildPythonApplication, lib, fetchFromGitHub, bashInteractive
-, argcomplete, arxiv2bib, beautifulsoup4, bibtexparser
-, configparser, dmenu-python, habanero, papis-python-rofi
-, pylibgen, prompt_toolkit, pyparser, pytest, python_magic
-, pyyaml, requests, unidecode, urwid, vobject, tkinter
-, vim
+, python3, vim
 }:
 
-buildPythonApplication rec {
+let
+  python = python3.override {
+    packageOverrides = self: super: {
+
+      # https://github.com/eventable/vobject/issues/112
+      python-dateutil = super.python-dateutil.overridePythonAttrs (oldAttrs: rec {
+        version = "2.6.1";
+        src = oldAttrs.src.override {
+          inherit version;
+          sha256 = "891c38b2a02f5bb1be3e4793866c8df49c7d19baabf9c1bad62547e0b4866aca";
+        };
+      });
+
+    };
+  };
+
+in python.pkgs.buildPythonApplication rec {
   pname = "papis";
   version = "0.5.3";
 
@@ -23,7 +35,7 @@ buildPythonApplication rec {
     patchShebangs tests
   '';
 
-  propagatedBuildInputs = [
+  propagatedBuildInputs = with python.pkgs; [
     argcomplete arxiv2bib beautifulsoup4 bibtexparser
     configparser dmenu-python habanero papis-python-rofi
     pylibgen prompt_toolkit pyparser python_magic pyyaml
@@ -31,7 +43,7 @@ buildPythonApplication rec {
     vim
   ];
 
-  checkInputs = [ pytest ];
+  checkInputs = with python.pkgs; [ pytest ];
 
   # Papis tries to create the config folder under $HOME during the tests
   checkPhase = ''