about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMatthew Bauer <mjbauer95@gmail.com>2018-09-29 00:50:37 -0500
committerGitHub <noreply@github.com>2018-09-29 00:50:37 -0500
commita87c16bab014e832b647f0b411d6e2f7fcff5a1b (patch)
treeedbcc6b67917bcbf56da9b49fc14ede49eda8813 /pkgs/tools
parenteaf843e0efbb4ea531964bcd6778ba7146624b8e (diff)
parent525f4250739361892a30edb5aed6a8499d624d6e (diff)
downloadnixlib-a87c16bab014e832b647f0b411d6e2f7fcff5a1b.tar
nixlib-a87c16bab014e832b647f0b411d6e2f7fcff5a1b.tar.gz
nixlib-a87c16bab014e832b647f0b411d6e2f7fcff5a1b.tar.bz2
nixlib-a87c16bab014e832b647f0b411d6e2f7fcff5a1b.tar.lz
nixlib-a87c16bab014e832b647f0b411d6e2f7fcff5a1b.tar.xz
nixlib-a87c16bab014e832b647f0b411d6e2f7fcff5a1b.tar.zst
nixlib-a87c16bab014e832b647f0b411d6e2f7fcff5a1b.zip
Merge pull request #46528 from markuskowa/pdsh-fix
pdsh: set default module to ssh, remove obsolete fixes
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/pdsh/default.nix11
1 files changed, 3 insertions, 8 deletions
diff --git a/pkgs/tools/networking/pdsh/default.nix b/pkgs/tools/networking/pdsh/default.nix
index 9239b9e118dc..812d335e8087 100644
--- a/pkgs/tools/networking/pdsh/default.nix
+++ b/pkgs/tools/networking/pdsh/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, perl, readline, rsh, ssh, pam }:
+{ stdenv, fetchurl, perl, readline, rsh, ssh }:
 
 stdenv.mkDerivation rec {
   name = "pdsh-2.33";
@@ -8,12 +8,7 @@ stdenv.mkDerivation rec {
     sha256 = "0bwlkl9inj66iwvafg00pi3sk9n673phdi0kcc59y9nn55s0hs3k";
   };
 
-  buildInputs = [perl readline ssh pam];
-
-  /* pdsh uses pthread_cancel(), which requires libgcc_s.so.1 to be
-     loadable at run-time. Adding the flag below ensures that the
-     library can be found. Obviously, though, this is a hack. */
-  NIX_LDFLAGS="-lgcc_s";
+  buildInputs = [ perl readline ssh ];
 
   preConfigure = ''
     configureFlagsArray=(
@@ -22,11 +17,11 @@ stdenv.mkDerivation rec {
       "--with-machines=/etc/pdsh/machines"
       ${if readline == null then "--without-readline" else "--with-readline"}
       ${if ssh == null then "--without-ssh" else "--with-ssh"}
-      ${if pam == null then "--without-pam" else "--with-pam"}
       ${if rsh == false then "--without-rsh" else "--with-rsh"}
       "--with-dshgroups"
       "--with-xcpu"
       "--disable-debug"
+      '--with-rcmd-rank-list=ssh,krb4,exec,xcpu,rsh'
     )
   '';