about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2017-12-21 22:45:40 +0100
committerVladimír Čunát <vcunat@gmail.com>2017-12-21 22:45:40 +0100
commita7d4fb8e1d53ac41bad98903781117db3241f345 (patch)
tree424da03a2478d80d1fa626c03abc365657d306f2 /pkgs/tools
parent31e5662785cd319959b77b3622ea33aa28c63ba7 (diff)
parentfc99ee5cebec0305d6f2407dc61a090eef60967a (diff)
downloadnixlib-a7d4fb8e1d53ac41bad98903781117db3241f345.tar
nixlib-a7d4fb8e1d53ac41bad98903781117db3241f345.tar.gz
nixlib-a7d4fb8e1d53ac41bad98903781117db3241f345.tar.bz2
nixlib-a7d4fb8e1d53ac41bad98903781117db3241f345.tar.lz
nixlib-a7d4fb8e1d53ac41bad98903781117db3241f345.tar.xz
nixlib-a7d4fb8e1d53ac41bad98903781117db3241f345.tar.zst
nixlib-a7d4fb8e1d53ac41bad98903781117db3241f345.zip
Merge branch 'master' into staging
Hydra: ?compare=1420346
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/audio/abcm2ps/default.nix4
-rw-r--r--pkgs/tools/misc/bepasty/default.nix5
-rw-r--r--pkgs/tools/misc/blsd/default.nix27
-rw-r--r--pkgs/tools/misc/blsd/deps.nix11
-rw-r--r--pkgs/tools/misc/libbitcoin/libbitcoin-client.nix23
-rw-r--r--pkgs/tools/misc/libbitcoin/libbitcoin-explorer.nix24
-rw-r--r--pkgs/tools/misc/libbitcoin/libbitcoin-network.nix38
-rw-r--r--pkgs/tools/misc/libbitcoin/libbitcoin-protocol.nix39
-rw-r--r--pkgs/tools/misc/libbitcoin/libbitcoin.nix21
-rw-r--r--pkgs/tools/misc/osinfo-db-tools/default.nix23
-rw-r--r--pkgs/tools/networking/ccnet/default.nix29
-rw-r--r--pkgs/tools/networking/http-prompt/default.nix4
-rw-r--r--pkgs/tools/networking/mosh/default.nix6
-rw-r--r--pkgs/tools/networking/zssh/default.nix38
-rwxr-xr-xpkgs/tools/nix/info/info.sh2
-rw-r--r--pkgs/tools/package-management/disnix/dysnomia/default.nix8
-rw-r--r--pkgs/tools/security/gencfsm/default.nix4
-rw-r--r--pkgs/tools/security/gopass/default.nix45
-rw-r--r--pkgs/tools/typesetting/odpdown/default.nix4
-rw-r--r--pkgs/tools/virtualization/google-compute-engine/default.nix2
20 files changed, 295 insertions, 62 deletions
diff --git a/pkgs/tools/audio/abcm2ps/default.nix b/pkgs/tools/audio/abcm2ps/default.nix
index dd91c874736e..b750f40ab405 100644
--- a/pkgs/tools/audio/abcm2ps/default.nix
+++ b/pkgs/tools/audio/abcm2ps/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "abcm2ps-${version}";
-  version = "8.13.17";
+  version = "8.13.18";
 
   src = fetchFromGitHub {
     owner = "leesavide";
     repo = "abcm2ps";
     rev = "v${version}";
-    sha256 = "1niafqn3kzd3fpx2c7m0by8il52ird2hbhvr7l03l290vlpjw6zc";
+    sha256 = "0fzhk43fidyflqj8wd7m3m4pibzrbr1c120xi9wskzb3627pgyh1";
   };
 
   prePatch = ''
diff --git a/pkgs/tools/misc/bepasty/default.nix b/pkgs/tools/misc/bepasty/default.nix
index be1df0510d7b..ee2680da0066 100644
--- a/pkgs/tools/misc/bepasty/default.nix
+++ b/pkgs/tools/misc/bepasty/default.nix
@@ -25,6 +25,11 @@ buildPythonApplication rec {
     sha256 = "0bs79pgrjlnkmjfyj2hllbx3rw757va5w2g2aghi9cydmsl7gyi4";
   };
 
+  checkInputs = [
+    pytest
+    selenium
+  ];
+
   meta = {
     homepage = https://github.com/bepasty/bepasty-server;
     description = "Binary pastebin server";
diff --git a/pkgs/tools/misc/blsd/default.nix b/pkgs/tools/misc/blsd/default.nix
new file mode 100644
index 000000000000..c44967d36204
--- /dev/null
+++ b/pkgs/tools/misc/blsd/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, buildGoPackage, fetchFromGitHub, pkgconfig, libgit2 }:
+
+buildGoPackage rec {
+  name = "blsd-${version}";
+  version = "2017-07-27";
+
+  goPackagePath = "github.com/junegunn/blsd";
+
+  src = fetchFromGitHub {
+    owner = "junegunn";
+    repo = "blsd";
+    rev = "a2ac619821e502452abdeae9ebab45026893b9e8";
+    sha256 = "0b0q6i4i28cjqgxqmwxbps22gp9rcd3jz562q5wvxrwlpbzlls2h";
+  };
+
+  goDeps = ./deps.nix;
+
+  nativeBuildInputs = [ pkgconfig libgit2 ];
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/junegunn/blsd;
+    description = "List directories in breadth-first order";
+    license = licenses.mit;
+    maintainers = [ maintainers.magnetophon ];
+    platforms = platforms.unix;
+  };
+}
diff --git a/pkgs/tools/misc/blsd/deps.nix b/pkgs/tools/misc/blsd/deps.nix
new file mode 100644
index 000000000000..55e6daea5e21
--- /dev/null
+++ b/pkgs/tools/misc/blsd/deps.nix
@@ -0,0 +1,11 @@
+[
+{
+  goPackagePath = "github.com/libgit2/git2go";
+  fetch = {
+    type = "git";
+    url = "https://github.com/libgit2/git2go";
+    rev = "334260d743d713a55ff3c097ec6707f2bb39e9d5";
+    sha256 = "0hfya9z2pg29zbc0s92hj241rnbk7d90jzj34q0dp8b7akz6r1rc";
+  };
+}
+]
diff --git a/pkgs/tools/misc/libbitcoin/libbitcoin-client.nix b/pkgs/tools/misc/libbitcoin/libbitcoin-client.nix
index 989c1f57b6ef..d2f988396ca7 100644
--- a/pkgs/tools/misc/libbitcoin/libbitcoin-client.nix
+++ b/pkgs/tools/misc/libbitcoin/libbitcoin-client.nix
@@ -1,27 +1,29 @@
-{ stdenv, lib, fetchurl, pkgconfig, autoreconfHook
-, boost, libsodium, czmqpp, libbitcoin }:
+{ stdenv, lib, fetchFromGitHub, pkgconfig, autoreconfHook
+, boost, libbitcoin, libbitcoin-protocol }:
 
 let
   pname = "libbitcoin-client";
-  version = "2.2.0";
+  version = "3.4.0";
 
 in stdenv.mkDerivation {
   name = "${pname}-${version}";
 
-  src = fetchurl {
-    url = "https://github.com/libbitcoin/libbitcoin-client/archive/v${version}.tar.gz";
-    sha256 = "1g79hl6jmf5dam7vq19h4dgdj7gcn19fa7q78vn573mg2rdyal53";
+  src = fetchFromGitHub {
+    owner = "libbitcoin";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1vdp6qgpxshh6nhdvr81z3nvh42wgmsm4prli4ajigwp970y8p56";
   };
 
   nativeBuildInputs = [ autoreconfHook pkgconfig ];
-  buildInputs = [ ];
+  propagatedBuildInputs = [ libbitcoin libbitcoin-protocol ];
 
-  propagatedBuildInputs = [ libsodium czmqpp libbitcoin ];
+  enableParallelBuilding = true;
 
   configureFlags = [
+    "--with-tests=no"
     "--with-boost=${boost.dev}"
     "--with-boost-libdir=${boost.out}/lib"
-    "--with-bash-completiondir=$out/share/bash-completion/completions"
   ];
 
   meta = with stdenv.lib; {
@@ -30,8 +32,7 @@ in stdenv.mkDerivation {
     platforms = platforms.linux ++ platforms.darwin;
     maintainers = with maintainers; [ chris-martin ];
 
-    # https://wiki.unsystem.net/en/index.php/Libbitcoin/License
-    # AGPL with an additional clause
+    # AGPL with a lesser clause
     license = licenses.agpl3;
   };
 }
diff --git a/pkgs/tools/misc/libbitcoin/libbitcoin-explorer.nix b/pkgs/tools/misc/libbitcoin/libbitcoin-explorer.nix
index 7b6da9bdd3ed..e9f4c977779f 100644
--- a/pkgs/tools/misc/libbitcoin/libbitcoin-explorer.nix
+++ b/pkgs/tools/misc/libbitcoin/libbitcoin-explorer.nix
@@ -1,24 +1,27 @@
-{ stdenv, lib, fetchurl, pkgconfig, autoreconfHook
-, boost, libbitcoin-client }:
+{ stdenv, lib, fetchFromGitHub, pkgconfig, autoreconfHook
+, boost, libbitcoin-client, libbitcoin-network }:
 
 let
   pname = "libbitcoin-explorer";
-  version = "2.2.0";
+  version = "3.4.0";
 
 in stdenv.mkDerivation {
   name = "${pname}-${version}";
 
-  src = fetchurl {
-    url = "https://github.com/libbitcoin/libbitcoin-explorer/archive/v${version}.tar.gz";
-    sha256 = "00123vw7rxk0ypdfzk0xwk8q55ll31000mkjqdzl915krsbkbfvp";
+  src = fetchFromGitHub {
+    owner = "libbitcoin";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "0rxiimklzqyp9vswznz9aia71dn6jxm2pxx5ljlhzs5rs583cj00";
   };
 
   nativeBuildInputs = [ autoreconfHook pkgconfig ];
-  buildInputs = [ ];
+  buildInputs = [ libbitcoin-client libbitcoin-network ];
 
-  propagatedBuildInputs = [ libbitcoin-client ];
+  enableParallelBuilding = true;
 
   configureFlags = [
+    "--with-tests=no"
     "--with-boost=${boost.dev}"
     "--with-boost-libdir=${boost.out}/lib"
     "--with-bash-completiondir=$out/share/bash-completion/completions"
@@ -28,10 +31,9 @@ in stdenv.mkDerivation {
     description = "Bitcoin command line tool";
     homepage = https://github.com/libbitcoin/libbitcoin-explorer;
     platforms = platforms.linux ++ platforms.darwin;
-    maintainers = with maintainers; [ chris-martin ];
+    maintainers = with maintainers; [ chris-martin asymmetric ];
 
-    # https://wiki.unsystem.net/en/index.php/Libbitcoin/License
-    # AGPL with an additional clause
+    # AGPL with a lesser clause
     license = licenses.agpl3;
   };
 }
diff --git a/pkgs/tools/misc/libbitcoin/libbitcoin-network.nix b/pkgs/tools/misc/libbitcoin/libbitcoin-network.nix
new file mode 100644
index 000000000000..11657c03615d
--- /dev/null
+++ b/pkgs/tools/misc/libbitcoin/libbitcoin-network.nix
@@ -0,0 +1,38 @@
+{ stdenv, lib, fetchFromGitHub, pkgconfig, autoreconfHook
+, boost, libbitcoin, zeromq }:
+
+let
+  pname = "libbitcoin-network";
+  version = "3.4.0";
+
+in stdenv.mkDerivation {
+  name = "${pname}-${version}";
+
+  src = fetchFromGitHub {
+    owner = "libbitcoin";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1zlhyh5z0fla1yc6kwkx65ycwgmrcrkvzj8119wbkxy3xhzpwxpv";
+  };
+
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
+  buildInputs = [ libbitcoin zeromq ];
+
+  enableParallelBuilding = true;
+
+  configureFlags = [
+    "--with-tests=no"
+    "--with-boost=${boost.dev}"
+    "--with-boost-libdir=${boost.out}/lib"
+  ];
+
+  meta = with stdenv.lib; {
+    description = "Bitcoin P2P Network Library";
+    homepage = https://libbitcoin.org/;
+    platforms = platforms.linux ++ platforms.darwin;
+    maintainers = with maintainers; [ asymmetric ];
+
+    # AGPL with a lesser clause
+    license = licenses.agpl3;
+  };
+}
diff --git a/pkgs/tools/misc/libbitcoin/libbitcoin-protocol.nix b/pkgs/tools/misc/libbitcoin/libbitcoin-protocol.nix
new file mode 100644
index 000000000000..5fbc2f403087
--- /dev/null
+++ b/pkgs/tools/misc/libbitcoin/libbitcoin-protocol.nix
@@ -0,0 +1,39 @@
+{ stdenv, lib, fetchFromGitHub, pkgconfig, autoreconfHook
+, boost, libbitcoin, secp256k1, zeromq }:
+
+let
+  pname = "libbitcoin-protocol";
+  version = "3.4.0";
+
+in stdenv.mkDerivation {
+  name = "${pname}-${version}";
+
+  src = fetchFromGitHub {
+    owner = "libbitcoin";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1wrlzani3wdjkmxqwjh30i8lg3clrzwcx2di7c9sdpnsbda985gb";
+  };
+
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
+  buildInputs = [ libbitcoin secp256k1 ];
+  propagatedBuildInputs = [ zeromq ];
+
+  enableParallelBuilding = true;
+
+  configureFlags = [
+    "--with-tests=no"
+    "--with-boost=${boost.dev}"
+    "--with-boost-libdir=${boost.out}/lib"
+  ];
+
+  meta = with stdenv.lib; {
+    description = "Bitcoin Blockchain Query Protocol";
+    homepage = https://libbitcoin.org/;
+    platforms = platforms.linux ++ platforms.darwin;
+    maintainers = with maintainers; [ asymmetric ];
+
+    # AGPL with a lesser clause
+    license = licenses.agpl3;
+  };
+}
diff --git a/pkgs/tools/misc/libbitcoin/libbitcoin.nix b/pkgs/tools/misc/libbitcoin/libbitcoin.nix
index 6d0c7b4e9c95..623f34e8b615 100644
--- a/pkgs/tools/misc/libbitcoin/libbitcoin.nix
+++ b/pkgs/tools/misc/libbitcoin/libbitcoin.nix
@@ -1,24 +1,28 @@
-{ stdenv, lib, fetchurl, pkgconfig, autoreconfHook
-, boost, libsodium, czmqpp, secp256k1 }:
+{ stdenv, lib, fetchFromGitHub, pkgconfig, autoreconfHook
+, boost, secp256k1 }:
 
 let
   pname = "libbitcoin";
-  version = "2.11.0";
+  version = "3.4.0";
 
 in stdenv.mkDerivation {
   name = "${pname}-${version}";
 
-  src = fetchurl {
-    url = "https://github.com/libbitcoin/libbitcoin/archive/v${version}.tar.gz";
-    sha256 = "1lpdjm13kgs4fbp579bwfvws8yf9mnr5dw3ph8zxg2gf110h85sy";
+  src = fetchFromGitHub {
+    owner = pname;
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1h6h7cxbwkdk8bzbkfvnrrdzajw1d4lr8wqs66is735bksh6gk1y";
   };
 
   nativeBuildInputs = [ autoreconfHook pkgconfig ];
-  buildInputs = [ ];
 
   propagatedBuildInputs = [ secp256k1 ];
 
+  enableParallelBuilding = true;
+
   configureFlags = [
+    "--with-tests=no"
     "--with-boost=${boost.dev}"
     "--with-boost-libdir=${boost.out}/lib"
   ];
@@ -29,8 +33,7 @@ in stdenv.mkDerivation {
     platforms = platforms.linux ++ platforms.darwin;
     maintainers = with maintainers; [ chris-martin ];
 
-    # https://wiki.unsystem.net/en/index.php/Libbitcoin/License
-    # AGPL with an additional clause
+    # AGPL with a lesser clause
     license = licenses.agpl3;
   };
 }
diff --git a/pkgs/tools/misc/osinfo-db-tools/default.nix b/pkgs/tools/misc/osinfo-db-tools/default.nix
new file mode 100644
index 000000000000..3464a92fa110
--- /dev/null
+++ b/pkgs/tools/misc/osinfo-db-tools/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchurl, pkgconfig, intltool, glib, libxml2
+, libxslt, libarchive, bzip2, lzma
+}:
+
+stdenv.mkDerivation rec {
+  name = "osinfo-db-tools-1.1.0";
+
+  src = fetchurl {
+    url = "https://releases.pagure.org/libosinfo/${name}.tar.gz";
+    sha256 = "0sslzrbhpb2js1vn48c11s5p0bic3yqzdnxm054dhc3wq0pwshd1";
+  };
+
+  nativeBuildInputs = [ pkgconfig intltool ];
+  buildInputs = [ glib libxml2 libxslt libarchive bzip2 lzma ];
+
+  meta = with stdenv.lib; {
+    description = "Tools for managing the osinfo database";
+    homepage = https://libosinfo.org/;
+    license = licenses.lgpl2Plus;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.bjornfor ];
+  };
+}
diff --git a/pkgs/tools/networking/ccnet/default.nix b/pkgs/tools/networking/ccnet/default.nix
index 24c86f4fa9a6..036819ea76e1 100644
--- a/pkgs/tools/networking/ccnet/default.nix
+++ b/pkgs/tools/networking/ccnet/default.nix
@@ -1,36 +1,25 @@
-{stdenv, fetchurl, which, automake, autoconf, pkgconfig, libtool, vala_0_23, python, libsearpc, libzdb, libuuid, libevent, sqlite, openssl}:
+{stdenv, fetchurl, which, autoreconfHook, pkgconfig, vala, python, libsearpc, libzdb, libuuid, libevent, sqlite, openssl}:
 
-stdenv.mkDerivation rec
-{
+stdenv.mkDerivation rec {
   version = "6.1.0";
   seafileVersion = "6.1.0";
   name = "ccnet-${version}";
 
-  src = fetchurl
-  {
+  src = fetchurl {
     url = "https://github.com/haiwen/ccnet/archive/v${version}.tar.gz";
     sha256 = "0q4a102xlcsxlr53h4jr4w8qzkbzvm2f3nk9fsha48h6l2hw34bb";
   };
 
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ which automake autoconf libtool vala_0_23 python ];
+  nativeBuildInputs = [ pkgconfig which autoreconfHook vala python ];
   propagatedBuildInputs = [ libsearpc libzdb libuuid libevent sqlite openssl ];
 
-  preConfigure = ''
-  sed -ie 's|/bin/bash|${stdenv.shell}|g' ./autogen.sh
-  ./autogen.sh
-  '';
+  configureFlags = [ "--enable-server" ];
 
-  configureFlags = "--enable-server";
-
-  buildPhase = "make -j1";
-
-  meta =
-  {
+  meta = with stdenv.lib; {
     homepage = https://github.com/haiwen/ccnet;
     description = "A framework for writing networked applications in C";
-    license = stdenv.lib.licenses.gpl3Plus;
-    platforms = stdenv.lib.platforms.linux;
-    maintainers = [ stdenv.lib.maintainers.calrama ];
+    license = licenses.gpl3Plus;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.calrama ];
   };
 }
diff --git a/pkgs/tools/networking/http-prompt/default.nix b/pkgs/tools/networking/http-prompt/default.nix
index 83ad64a66a4a..fd7caf927653 100644
--- a/pkgs/tools/networking/http-prompt/default.nix
+++ b/pkgs/tools/networking/http-prompt/default.nix
@@ -20,6 +20,10 @@ pythonPackages.buildPythonApplication rec {
     six
   ];
 
+  checkPhase = ''
+    $out/bin/${name} --version | grep -q "${version}"
+  '';
+
   meta = with stdenv.lib; {
     description = "An interactive command-line HTTP client featuring autocomplete and syntax highlighting";
     homepage = https://github.com/eliangcs/http-prompt;
diff --git a/pkgs/tools/networking/mosh/default.nix b/pkgs/tools/networking/mosh/default.nix
index e66209c7ce95..fb94b750e1d8 100644
--- a/pkgs/tools/networking/mosh/default.nix
+++ b/pkgs/tools/networking/mosh/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, zlib, protobuf, ncurses, pkgconfig, IOTty
-, makeWrapper, perl, openssl, autoreconfHook, openssh }:
+, makeWrapper, perl, openssl, autoreconfHook, openssh, bash-completion }:
 
 stdenv.mkDerivation rec {
   name = "mosh-1.3.2";
@@ -10,7 +10,7 @@ stdenv.mkDerivation rec {
   };
 
   nativeBuildInputs = [ autoreconfHook pkgconfig ];
-  buildInputs = [ protobuf ncurses zlib IOTty makeWrapper perl openssl ];
+  buildInputs = [ protobuf ncurses zlib IOTty makeWrapper perl openssl bash-completion ];
 
   patches = [ ./ssh_path.patch ];
   postPatch = ''
@@ -18,6 +18,8 @@ stdenv.mkDerivation rec {
         --subst-var-by ssh "${openssh}/bin/ssh"
   '';
 
+  configureFlags = [ "--enable-completion" ];
+
   postInstall = ''
       wrapProgram $out/bin/mosh --prefix PERL5LIB : $PERL5LIB
   '';
diff --git a/pkgs/tools/networking/zssh/default.nix b/pkgs/tools/networking/zssh/default.nix
new file mode 100644
index 000000000000..16c0034e46fc
--- /dev/null
+++ b/pkgs/tools/networking/zssh/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, fetchurl, readline, deepin-terminal }:
+
+let
+  version = "1.5c";
+in stdenv.mkDerivation rec {
+  name = "zssh-${version}";
+
+  src = fetchurl {
+    url = "mirror://sourceforge/zssh/${name}.tgz";
+    sha256 = "06z73iq59lz8ibjrgs7d3xl39vh9yld1988yx8khssch4pw41s52";
+  };
+
+  buildInputs = [ readline ];
+
+  patches = [
+    # Cargo-culted from Arch, returns “out of pty's” without it
+    (fetchurl {
+      name = "fix_use_ptmx_on_arch.patch";
+      url = https://git.archlinux.org/svntogit/community.git/plain/trunk/fix_use_ptmx_on_arch.patch?h=packages/zssh&id=0a7c92543f9309856d02e31196f06d7c3eaa8b67;
+      sha256 = "12daw9wpy58ql882zww945wk9cg2adwp8qsr5rvazx0xq0qawgbr";
+    })
+  ];
+
+  patchFlags = [ "-p0" ];
+
+  # The makefile does not create the directories
+  postBuild = ''
+    install -dm755 "$out"/{bin,man/man1}
+  '';
+
+  meta = {
+    description = "SSH and Telnet client with ZMODEM file transfer capability";
+    homepage = http://zssh.sourceforge.net/;
+    license = stdenv.lib.licenses.gpl2;
+    maintainers = deepin-terminal.meta.maintainers; # required by deepin-terminal
+    platforms = stdenv.lib.platforms.linux;
+  };
+}
diff --git a/pkgs/tools/nix/info/info.sh b/pkgs/tools/nix/info/info.sh
index 473e035b8e0a..f108962b3bad 100755
--- a/pkgs/tools/nix/info/info.sh
+++ b/pkgs/tools/nix/info/info.sh
@@ -143,7 +143,7 @@ fact() {
             printf ", "
         fi
     else
-        printf " - %s: \`%s\`\n" "$name" "$value"
+        printf " - %s: \`%s\`\\n" "$name" "$value"
     fi
 
     if [ "$last" -eq 0 ]; then
diff --git a/pkgs/tools/package-management/disnix/dysnomia/default.nix b/pkgs/tools/package-management/disnix/dysnomia/default.nix
index e33776eaa2b7..042d2c314b19 100644
--- a/pkgs/tools/package-management/disnix/dysnomia/default.nix
+++ b/pkgs/tools/package-management/disnix/dysnomia/default.nix
@@ -20,12 +20,12 @@ assert enableEjabberdDump -> ejabberd != null;
 assert enableMongoDatabase -> (mongodb != null && mongodb-tools != null);
 
 stdenv.mkDerivation {
-  name = "dysnomia-0.7";
+  name = "dysnomia-0.7.1";
   src = fetchurl {
-    url = https://github.com/svanderburg/dysnomia/files/842819/dysnomia-0.7.tar.gz;
-    sha256 = "0nlb7fvndnxs878aah30cac4gqf2w9qq4bdpqj4m0j3d9nhpak2j";
+    url = https://github.com/svanderburg/dysnomia/files/1576949/dysnomia-0.7.1.tar.gz;
+    sha256 = "0fyyn6654p10mrm2rlgv017d74wjb8z9h2xzv8gwdly34kifj9dh";
   };
-  
+
   preConfigure = if enableEjabberdDump then "export PATH=$PATH:${ejabberd}/sbin" else "";
   
   configureFlags = [
diff --git a/pkgs/tools/security/gencfsm/default.nix b/pkgs/tools/security/gencfsm/default.nix
index aade96ed3899..51fff4c59ec1 100644
--- a/pkgs/tools/security/gencfsm/default.nix
+++ b/pkgs/tools/security/gencfsm/default.nix
@@ -3,12 +3,12 @@
 }:
 
 stdenv.mkDerivation rec {
-  version = "1.8.18";
+  version = "1.8.19";
   name = "gnome-encfs-manager-${version}";
 
   src = fetchurl {
     url = "https://launchpad.net/gencfsm/trunk/1.8/+download/gnome-encfs-manager_${version}.tar.xz";
-    sha256 = "1rpf683lxa78fmxxb0hnq7vdh3yn7qid2gqq67q9mk65sp9vdhdj";
+    sha256 = "1h6x8dyp1fvxvr8fwki98ppf4sa20qf7g59jc9797b2vrgm60h1i";
   };
 
   nativeBuildInputs = [ pkgconfig ];
diff --git a/pkgs/tools/security/gopass/default.nix b/pkgs/tools/security/gopass/default.nix
new file mode 100644
index 000000000000..d03c08211c2b
--- /dev/null
+++ b/pkgs/tools/security/gopass/default.nix
@@ -0,0 +1,45 @@
+{ stdenv, buildGoPackage, fetchFromGitHub, git, gnupg, makeWrapper }:
+
+buildGoPackage rec {
+  version = "1.6.6";
+  name = "gopass-${version}";
+
+  goPackagePath = "github.com/justwatchcom/gopass";
+
+  nativeBuildInputs = [ makeWrapper ];
+
+  src = fetchFromGitHub {
+    owner = "justwatchcom";
+    repo = "gopass";
+    rev = "v${version}";
+    sha256 = "0n3isjrjpn2cnlwfdkjdcz5j8n16dhyaw4zyjpmis51nl0bqd3jw";
+  };
+
+  wrapperPath = with stdenv.lib; makeBinPath ([
+    git
+    gnupg
+  ]);
+
+  postFixup = ''
+    wrapProgram $bin/bin/gopass \
+      --prefix PATH : "${wrapperPath}"
+  '';
+
+  meta = with stdenv.lib; {
+    description     = "The slightly more awesome Standard Unix Password Manager for Teams. Written in Go.";
+    homepage        = https://github.com/justwatchcom/gopass;
+    license         = licenses.mit;
+    maintainers     = with maintainers; [ andir ];
+    platforms       = platforms.unix;
+
+    longDescription = ''
+      gopass is a rewrite of the pass password manager in Go with the aim of
+      making it cross-platform and adding additional features. Our target
+      audience are professional developers and sysadmins (and especially teams
+      of those) who are well versed with a command line interface. One explicit
+      goal for this project is to make it more approachable to non-technical
+      users. We go by the UNIX philosophy and try to do one thing and do it
+      well, providing a stellar user experience and a sane, simple interface.
+    '';
+  };
+}
diff --git a/pkgs/tools/typesetting/odpdown/default.nix b/pkgs/tools/typesetting/odpdown/default.nix
index 140784fa9369..c53e8573c90f 100644
--- a/pkgs/tools/typesetting/odpdown/default.nix
+++ b/pkgs/tools/typesetting/odpdown/default.nix
@@ -12,6 +12,10 @@ pythonPackages.buildPythonApplication rec {
 
   propagatedBuildInputs = with pythonPackages; [ libreoffice lpod lxml mistune pillow pygments ];
 
+  checkInputs = with pythonPackages; [
+    nose
+  ];
+
   meta = with stdenv.lib; {
     homepage = https://github.com/thorstenb/odpdown;
     repositories.git = https://github.com/thorstenb/odpdown.git;
diff --git a/pkgs/tools/virtualization/google-compute-engine/default.nix b/pkgs/tools/virtualization/google-compute-engine/default.nix
index bd766d7c5a9f..a923d73c03e4 100644
--- a/pkgs/tools/virtualization/google-compute-engine/default.nix
+++ b/pkgs/tools/virtualization/google-compute-engine/default.nix
@@ -45,6 +45,8 @@ buildPythonApplication rec {
 
   propagatedBuildInputs = [ boto setuptools ];
 
+  doCheck = false;
+
   meta = with lib; {
     description = "Google Compute Engine tools and services";
     homepage = "https://github.com/GoogleCloudPlatform/compute-image-packages";