about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2008-05-06 07:03:09 +0000
committerMichael Raskin <7c6f434c@mail.ru>2008-05-06 07:03:09 +0000
commit9b2cc890ebfba7712c297968f04f1f0ecc8a54a1 (patch)
tree158d55f2ba96ad520e8f994242002ef1f7d1fe2e /pkgs/tools
parent2e1be8618b4ad2e75ad71dcf161c47b1f4c4acef (diff)
downloadnixlib-9b2cc890ebfba7712c297968f04f1f0ecc8a54a1.tar
nixlib-9b2cc890ebfba7712c297968f04f1f0ecc8a54a1.tar.gz
nixlib-9b2cc890ebfba7712c297968f04f1f0ecc8a54a1.tar.bz2
nixlib-9b2cc890ebfba7712c297968f04f1f0ecc8a54a1.tar.lz
nixlib-9b2cc890ebfba7712c297968f04f1f0ecc8a54a1.tar.xz
nixlib-9b2cc890ebfba7712c297968f04f1f0ecc8a54a1.tar.zst
nixlib-9b2cc890ebfba7712c297968f04f1f0ecc8a54a1.zip
Updated customisable Nix expression
svn path=/nixpkgs/trunk/; revision=11757
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/package-management/nix/custom.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/tools/package-management/nix/custom.nix b/pkgs/tools/package-management/nix/custom.nix
index 2cff9f53d877..fdbfb2d7bec0 100644
--- a/pkgs/tools/package-management/nix/custom.nix
+++ b/pkgs/tools/package-management/nix/custom.nix
@@ -10,6 +10,8 @@
 , docbook5_xsl ? null, libxslt ? null
 , docbook5 ? null, docbook_xml_dtd_43 ? null 
 , configureFlags ? []
+, lib
+, enableScripts ? []
 }:
 
 stdenv.mkDerivation {
@@ -30,7 +32,12 @@ stdenv.mkDerivation {
   	++ (if w3m != null then [w3m] else [])
   ;
 
-  inherit preConfigure;
+  preConfigure = 
+  (lib.concatMapStrings (script: ''sed -e '/bin_SCRIPTS/a${script} \\' -i scripts/Makefile.am
+  '') enableScripts)
+  + preConfigure
+  + "\n./bootstrap.sh"
+  ;
 
   configureFlags = ["
     --with-store-dir=${storeDir} --localstatedir=${stateDir}