about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2023-11-21 23:35:38 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2023-11-21 23:35:38 -0500
commit98bdc2b3bb7ac42173cbe2033b91f849307a4737 (patch)
tree33308c04d374327bc6f6fb5ea7a1de7b52be2c42 /pkgs/tools
parentb2b9257186c568bae937c09b36067cd6b3448f2a (diff)
downloadnixlib-98bdc2b3bb7ac42173cbe2033b91f849307a4737.tar
nixlib-98bdc2b3bb7ac42173cbe2033b91f849307a4737.tar.gz
nixlib-98bdc2b3bb7ac42173cbe2033b91f849307a4737.tar.bz2
nixlib-98bdc2b3bb7ac42173cbe2033b91f849307a4737.tar.lz
nixlib-98bdc2b3bb7ac42173cbe2033b91f849307a4737.tar.xz
nixlib-98bdc2b3bb7ac42173cbe2033b91f849307a4737.tar.zst
nixlib-98bdc2b3bb7ac42173cbe2033b91f849307a4737.zip
nix: Fix build now that rapidcheck is a shared library
Backporting https://github.com/NixOS/nix/pull/9431
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/package-management/nix/default.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/tools/package-management/nix/default.nix b/pkgs/tools/package-management/nix/default.nix
index dd5d35375e30..aeb2a182336e 100644
--- a/pkgs/tools/package-management/nix/default.nix
+++ b/pkgs/tools/package-management/nix/default.nix
@@ -113,6 +113,13 @@ let
     hash = "sha256-s1ybRFCjQaSGj7LKu0Z5g7UiHqdJGeD+iPoQL0vaiS0=";
   };
 
+  patch-rapidcheck-shared = fetchpatch2 {
+    # https://github.com/NixOS/nix/pull/9431
+    name = "fix-requires-non-existing-output.patch";
+    url = "https://github.com/NixOS/nix/commit/46131567da96ffac298b9ec54016b37114b0dfd5.patch";
+    hash = "sha256-lShYxYKRDWwBqCysAFmFBudhhAL1eendWcL8sEFLCGg=";
+  };
+
   # Intentionally does not support overrideAttrs etc
   # Use only for tests that are about the package relation to `pkgs` and/or NixOS.
   addTestsShallowly = tests: pkg: pkg // {
@@ -194,26 +201,41 @@ in lib.makeExtensible (self: ({
   nix_2_14 = common {
     version = "2.14.1";
     hash = "sha256-5aCmGZbsFcLIckCDfvnPD4clGPQI7qYAqHYlttN/Wkg=";
+    patches = [
+      patch-rapidcheck-shared
+    ];
   };
 
   nix_2_15 = common {
     version = "2.15.3";
     hash = "sha256-sfFXbjC5iIdSAbctZIuFozxX0uux/KFBNr9oh33xINs=";
+    patches = [
+      patch-rapidcheck-shared
+    ];
   };
 
   nix_2_16 = common {
     version = "2.16.2";
     hash = "sha256-VXIYCDkvAWeMoU0W2ZI0TeOszCZA1o8trz6YCPFD5ac=";
+    patches = [
+      patch-rapidcheck-shared
+    ];
   };
 
   nix_2_17 = common {
     version = "2.17.1";
     hash = "sha256-Q5L+rHzjp0bYuR2ogg+YPCn6isjmlQ4CJVT0zpn/hFc=";
+    patches = [
+      patch-rapidcheck-shared
+    ];
   };
 
   nix_2_18 = common {
     version = "2.18.1";
     hash = "sha256-WNmifcTsN9aG1ONkv+l2BC4sHZZxtNKy0keqBHXXQ7w=";
+    patches = [
+      patch-rapidcheck-shared
+    ];
   };
 
   # The minimum Nix version supported by Nixpkgs