about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorhsloan <ishaqsloan@gmail.com>2017-06-28 16:56:12 -0400
committerJohn Ericson <John.Ericson@Obsidian.Systems>2017-06-28 21:29:08 -0400
commit936196129d0cf8500106bbd66c25d18b19dae3ec (patch)
tree7fc052e103b4ded4e1ad193a8df169445ed81f0e /pkgs/tools
parent60ce1e3b901013f5e5715c51a799940efc6cc2a4 (diff)
downloadnixlib-936196129d0cf8500106bbd66c25d18b19dae3ec.tar
nixlib-936196129d0cf8500106bbd66c25d18b19dae3ec.tar.gz
nixlib-936196129d0cf8500106bbd66c25d18b19dae3ec.tar.bz2
nixlib-936196129d0cf8500106bbd66c25d18b19dae3ec.tar.lz
nixlib-936196129d0cf8500106bbd66c25d18b19dae3ec.tar.xz
nixlib-936196129d0cf8500106bbd66c25d18b19dae3ec.tar.zst
nixlib-936196129d0cf8500106bbd66c25d18b19dae3ec.zip
html-tidy: Don't use stdenv.cross
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/text/html-tidy/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/tools/text/html-tidy/default.nix b/pkgs/tools/text/html-tidy/default.nix
index 1a264885b485..cc3283cf8541 100644
--- a/pkgs/tools/text/html-tidy/default.nix
+++ b/pkgs/tools/text/html-tidy/default.nix
@@ -1,4 +1,6 @@
-{ stdenv, fetchFromGitHub, cmake, libxslt }:
+{ stdenv, fetchFromGitHub, cmake, libxslt
+, hostPlatform
+}:
 
 stdenv.mkDerivation rec {
   name = "html-tidy-${version}";
@@ -14,7 +16,7 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ cmake libxslt/*manpage*/ ];
 
   cmakeFlags = stdenv.lib.optional
-    (stdenv.cross.libc or null == "msvcrt") "-DCMAKE_SYSTEM_NAME=Windows";
+    (hostPlatform.libc or null == "msvcrt") "-DCMAKE_SYSTEM_NAME=Windows";
 
   # ATM bin/tidy is statically linked, as upstream provides no other option yet.
   # https://github.com/htacg/tidy-html5/issues/326#issuecomment-160322107