about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2015-11-13 15:54:10 -0800
committerWilliam A. Kennington III <william@wkennington.com>2015-11-13 15:54:10 -0800
commit8f45d18a71fec8f2585c01b94a8b653a8894da69 (patch)
treec85648d156b63779c38a743a9824534a23a06f47 /pkgs/tools
parent0ba740d26b3e851a181034d8650ece94163d0fae (diff)
parent9579c9ec7f53be31efba3803bd86661b59b0bb81 (diff)
downloadnixlib-8f45d18a71fec8f2585c01b94a8b653a8894da69.tar
nixlib-8f45d18a71fec8f2585c01b94a8b653a8894da69.tar.gz
nixlib-8f45d18a71fec8f2585c01b94a8b653a8894da69.tar.bz2
nixlib-8f45d18a71fec8f2585c01b94a8b653a8894da69.tar.lz
nixlib-8f45d18a71fec8f2585c01b94a8b653a8894da69.tar.xz
nixlib-8f45d18a71fec8f2585c01b94a8b653a8894da69.tar.zst
nixlib-8f45d18a71fec8f2585c01b94a8b653a8894da69.zip
Merge branch 'master.upstream' into staging.upstream
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/archivers/innoextract/default.nix31
-rw-r--r--pkgs/tools/filesystems/fuse-7z-ng/default.nix6
-rw-r--r--pkgs/tools/filesystems/snapraid/default.nix18
-rw-r--r--pkgs/tools/misc/hdf5/default.nix34
-rw-r--r--pkgs/tools/networking/whois/default.nix40
-rw-r--r--pkgs/tools/security/mkpasswd/default.nix23
-rw-r--r--pkgs/tools/security/pcsclite/default.nix4
-rw-r--r--pkgs/tools/security/pcsctools/default.nix34
-rw-r--r--pkgs/tools/system/bootchart/default.nix30
-rw-r--r--pkgs/tools/system/fio/default.nix4
10 files changed, 150 insertions, 74 deletions
diff --git a/pkgs/tools/archivers/innoextract/default.nix b/pkgs/tools/archivers/innoextract/default.nix
index d8c88b6ee657..6b442e7bf660 100644
--- a/pkgs/tools/archivers/innoextract/default.nix
+++ b/pkgs/tools/archivers/innoextract/default.nix
@@ -1,10 +1,21 @@
-{stdenv, fetchurl, cmake, python, doxygen, lzma, boost}:

-stdenv.mkDerivation rec {

-  name = "innoextract-1.4";

-  src = fetchurl {

-    url = "http://constexpr.org/innoextract/files/${name}.tar.gz";

-    sha256 = "1j8wj0ijdnfh0r9qjr7ykp9v3n2yd4qisxln81bl6474w5d4njas";

-  };

-  buildInputs = [ python doxygen lzma boost ];

-  nativeBuildInputs = [ cmake ];

-}
\ No newline at end of file
+{stdenv, fetchurl, cmake, python, doxygen, lzma, boost}:
+
+stdenv.mkDerivation rec {
+  name = "innoextract-1.5";
+
+  src = fetchurl {
+    url = "http://constexpr.org/innoextract/files/${name}.tar.gz";
+    sha256 = "1ks8z8glak63xvqlv7dnmlzkjrwsn81lhybmai2mja6g5jclwngj";
+  };
+
+  buildInputs = [ python doxygen lzma boost ];
+  nativeBuildInputs = [ cmake ];
+
+  meta = with stdenv.lib; {
+    description = "A tool to unpack installers created by Inno Setup";
+    homepage = "http://constexpr.org/innoextract/";
+    platforms = platforms.linux;
+    license = licenses.zlib;
+    maintainers = with maintainers; [ abbradar ];
+  };
+}
diff --git a/pkgs/tools/filesystems/fuse-7z-ng/default.nix b/pkgs/tools/filesystems/fuse-7z-ng/default.nix
index 4e8df9cacbe2..8b3df52bcb74 100644
--- a/pkgs/tools/filesystems/fuse-7z-ng/default.nix
+++ b/pkgs/tools/filesystems/fuse-7z-ng/default.nix
@@ -28,6 +28,12 @@ stdenv.mkDerivation rec {
     inherit version;
     inherit (src.homepage);
     description = "A FUSE-based filesystem that uses the p7zip library";
+    longDescription = ''
+      fuse-7z-ng is a FUSE file system that uses the p7zip
+      library to access all archive formats supported by 7-zip.
+
+      This project is a fork of fuse-7z ( https://gitorious.org/fuse-7z/fuse-7z ).
+    '';
     platforms = platforms.linux;
     license = licenses.gpl3Plus;
   };
diff --git a/pkgs/tools/filesystems/snapraid/default.nix b/pkgs/tools/filesystems/snapraid/default.nix
new file mode 100644
index 000000000000..bbddedf5077b
--- /dev/null
+++ b/pkgs/tools/filesystems/snapraid/default.nix
@@ -0,0 +1,18 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "snapraid";
+  version = "8.1";
+
+  src = fetchurl {
+    url = "https://github.com/amadvance/snapraid/releases/download/v${version}/snapraid-${version}.tar.gz";
+    sha256 = "0pafqn9ismn4j3fsx8fgf008qwh2c6f8mjfjijah6d5c349rmy3b";
+  };
+
+  meta = {
+    homepage = http://www.snapraid.it/;
+    description = "A backup program for disk arrays";
+    license = stdenv.lib.licenses.gpl3;
+    maintainers = [ stdenv.lib.maintainers.makefu ];
+  };
+}
diff --git a/pkgs/tools/misc/hdf5/default.nix b/pkgs/tools/misc/hdf5/default.nix
index bcfca5fddb5d..0655fddeb87a 100644
--- a/pkgs/tools/misc/hdf5/default.nix
+++ b/pkgs/tools/misc/hdf5/default.nix
@@ -1,17 +1,21 @@
-
 { stdenv
 , fetchurl
+, cpp ? false
+, gfortran ? null
 , zlib ? null
 , szip ? null
 , mpi ? null
 , enableShared ? true
 }:
+
+with { inherit (stdenv.lib) optional; };
+
 stdenv.mkDerivation rec {
-  version = "1.8.14";
+  version = "1.8.15-patch1";
   name = "hdf5-${version}";
   src = fetchurl {
     url = "http://www.hdfgroup.org/ftp/HDF5/releases/hdf5-${version}/src/hdf5-${version}.tar.gz";
-    sha256 = "0f86gv32pjrrphvamgims1dd7f3bp46hjarbcdy8k4gmyzpgxghx";
+    sha256 = "19k39da6zzxyr0fnffn4iqlls9v1fsih877rznq8ypqy8mzf5dci";
  };
 
   passthru = {
@@ -20,20 +24,22 @@ stdenv.mkDerivation rec {
   };
 
   buildInputs = []
-    ++ stdenv.lib.optional (zlib != null) zlib
-    ++ stdenv.lib.optional (szip != null) szip;
+    ++ optional (gfortran != null) gfortran
+    ++ optional (zlib != null) zlib
+    ++ optional (szip != null) szip;
 
   propagatedBuildInputs = []
-    ++ stdenv.lib.optional (mpi != null) mpi;
-
-  configureFlags = "
-    ${if szip != null then "--with-szlib=${szip}" else ""}
-    ${if mpi != null then "--enable-parallel" else ""}
-    ${if enableShared then "--enable-shared" else ""}
-  ";
-  
+    ++ optional (mpi != null) mpi;
+
+  configureFlags = []
+    ++ optional cpp "--enable-cxx"
+    ++ optional (gfortran != null) "--enable-fortran"
+    ++ optional (szip != null) "--with-szlib=${szip}"
+    ++ optional (mpi != null) "--enable-parallel"
+    ++ optional enableShared "--enable-shared";
+
   patches = [./bin-mv.patch];
-  
+
   meta = {
     description = "Data model, library, and file format for storing and managing data";
     longDescription = ''
diff --git a/pkgs/tools/networking/whois/default.nix b/pkgs/tools/networking/whois/default.nix
new file mode 100644
index 000000000000..bab487f5fab8
--- /dev/null
+++ b/pkgs/tools/networking/whois/default.nix
@@ -0,0 +1,40 @@
+{ stdenv, fetchFromGitHub, perl, gettext }:
+
+stdenv.mkDerivation rec {
+  version = "5.2.10";
+  name = "whois-${version}";
+
+  src = fetchFromGitHub {
+    owner = "rfc1036";
+    repo = "whois";
+    rev = "v${version}";
+    sha256 = "0fqxbys3ssyplh70wjs83jsljqhmrnjic02ayaznw9m9l6fzhkkr";
+  };
+
+  buildInputs = [ perl gettext ];
+
+  preConfigure = ''
+    for i in Makefile po/Makefile; do
+      substituteInPlace $i --replace "prefix = /usr" "prefix = $out"
+    done
+  '';
+
+  buildPhase = "make whois";
+
+  installPhase = "make install-whois";
+
+  meta = with stdenv.lib; {
+    description = "Intelligent WHOIS client from Debian";
+    longDescription = ''
+      This package provides a commandline client for the WHOIS (RFC 3912)
+      protocol, which queries online servers for information such as contact
+      details for domains and IP address assignments. It can intelligently
+      select the appropriate WHOIS server for most queries.
+    '';
+
+    homepage = http://packages.qa.debian.org/w/whois.html;
+    license = licenses.gpl2;
+    maintainers = with maintainers; [ fpletz ];
+    platforms = platforms.linux;
+  };
+}
diff --git a/pkgs/tools/security/mkpasswd/default.nix b/pkgs/tools/security/mkpasswd/default.nix
index 8975ca4324d1..88aa71810dcf 100644
--- a/pkgs/tools/security/mkpasswd/default.nix
+++ b/pkgs/tools/security/mkpasswd/default.nix
@@ -1,30 +1,21 @@
-{ stdenv, fetchFromGitHub }:
+{ stdenv, whois, perl }:
 
-stdenv.mkDerivation rec {
-  name = "mkpasswd-${version}";
+stdenv.mkDerivation {
+  name = "mkpasswd-${whois.version}";
 
-  version = "5.1.1";
+  src = whois.src;
 
-  src = fetchFromGitHub {
-    owner = "rfc1036";
-    repo = "whois";
-    rev = "v${version}";
-    sha256 = "026x8byx8pcpkdxca64368p0nlspk4phw18jg4p04di6cg6nc1m5";
-  };
-
-  preConfigure = ''
-    substituteInPlace Makefile --replace "prefix = /usr" "prefix = $out"
-  '';
+  buildInputs = [ perl ];
 
+  preConfigure = whois.preConfigure;
   buildPhase = "make mkpasswd";
-
   installPhase = "make install-mkpasswd";
 
   meta = with stdenv.lib; {
     homepage = http://packages.qa.debian.org/w/whois.html;
     description = "Overfeatured front-end to crypt, from the Debian whois package";
     license = licenses.gpl2;
-    maintainers = [ maintainers.cstrahan ];
+    maintainers = with maintainers; [ cstrahan fpletz ];
     platforms = platforms.linux;
   };
 }
diff --git a/pkgs/tools/security/pcsclite/default.nix b/pkgs/tools/security/pcsclite/default.nix
index 6ec0cb238641..dd33e68c1526 100644
--- a/pkgs/tools/security/pcsclite/default.nix
+++ b/pkgs/tools/security/pcsclite/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, udev, dbus_libs, perl }:
+{ stdenv, fetchurl, pkgconfig, udev, dbus_libs, perl, python2 }:
 
 stdenv.mkDerivation rec {
   name = "pcsclite-1.8.14";
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
     "--enable-confdir=/etc"
   ];
 
-  nativeBuildInputs = [ pkgconfig perl ];
+  nativeBuildInputs = [ pkgconfig perl python2 ];
   buildInputs = [ udev dbus_libs ];
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/security/pcsctools/default.nix b/pkgs/tools/security/pcsctools/default.nix
index 72e43f15fe62..59db6889a578 100644
--- a/pkgs/tools/security/pcsctools/default.nix
+++ b/pkgs/tools/security/pcsctools/default.nix
@@ -1,22 +1,36 @@
-{ stdenv, fetchurl, pkgconfig, udev, dbus_libs, perl, pcsclite }:
+{ stdenv, lib, fetchurl, makeWrapper, pkgconfig, udev, dbus_libs, pcsclite
+, wget, coreutils
+, perl, pcscperl, Glib, Gtk2, Pango
+}:
 
-stdenv.mkDerivation rec {
-  name = "pcsc-tools-1.4.23";
+let deps = lib.makeSearchPath "bin" [ wget coreutils ];
+
+in stdenv.mkDerivation rec {
+  name = "pcsc-tools-1.4.25";
 
   src = fetchurl {
-    url = "http://ludovic.rousseau.free.fr/softwares/pcsc-tools/pcsc-tools-1.4.23.tar.gz";
-    sha256 = "1qjgvvvwhykmzn4js9s3rjnp9pbjc3sz4lb4d7i9kvr3xsv7pjk9";
+    url = "http://ludovic.rousseau.free.fr/softwares/pcsc-tools/${name}.tar.gz";
+    sha256 = "0iqcy28pb963ds4pjrpi37577vm6nkgf3i0b3rr978jy9qi1bix9";
   };
 
   buildInputs = [ udev dbus_libs perl pcsclite ];
 
-  preBuild = ''
-    makeFlags=DESTDIR=$out
-  '';
+  makeFlags = [ "DESTDIR=$(out)" ];
 
-  nativeBuildInputs = [ pkgconfig ];
+  nativeBuildInputs = [ makeWrapper pkgconfig ];
+
+  postInstall = ''
+    wrapProgram $out/bin/scriptor \
+      --set PERL5LIB "${lib.makePerlPath [ pcscperl ]}"
+    wrapProgram $out/bin/gscriptor \
+      --set PERL5LIB "${lib.makePerlPath [ pcscperl Glib Gtk2 Pango ]}"
+    wrapProgram $out/bin/ATR_analysis \
+      --set PERL5LIB "${lib.makePerlPath [ pcscperl ]}"
+    wrapProgram $out/bin/pcsc_scan \
+      --set PATH "$out/bin:${deps}"
+  '';
 
-  meta = with stdenv.lib; {
+  meta = with lib; {
     description = "Tools used to test a PC/SC driver, card or reader";
     homepage = http://ludovic.rousseau.free.fr/softwares/pcsc-tools/;
     license = licenses.gpl2Plus;
diff --git a/pkgs/tools/system/bootchart/default.nix b/pkgs/tools/system/bootchart/default.nix
index ef0a6d251a39..dacb143a480b 100644
--- a/pkgs/tools/system/bootchart/default.nix
+++ b/pkgs/tools/system/bootchart/default.nix
@@ -1,31 +1,21 @@
-{stdenv, fetchurl, gnutar, gzip, coreutils, utillinux, gnugrep, gnused, psmisc, nettools}:
+{stdenv, fetchurl, lib, pkgconfig, glib, gtk, python27, pythonPackages }:
 
 stdenv.mkDerivation rec {
-  name = "bootchart-0.9";
+  version = "0.14.7";
+  name = "bootchart-${version}";
 
   src = fetchurl {
-    url = "mirror://sourceforge/bootchart/${name}.tar.bz2";
-    sha256 = "0z9jvi7cyp3hpx6hf1fyaa8fhnaz7aqid8wrkwp29cngryg3jf3p";
+    url = "https://github.com/mmeeks/bootchart/archive/${version}.tar.gz";
+    sha256 = "1abn4amsyys6vwn7csxsxny94n24ycca3xhqxqcmdc4j0dzn3kmb";
   };
 
-  buildInputs = [ gnutar gzip coreutils utillinux gnugrep gnused psmisc nettools ];
-
-  patchPhase = ''
-    export MYPATH=
-    for i in $buildInputs; do
-       export MYPATH=''${MYPATH}''${MYPATH:+:}$i/bin:$i/sbin
-    done
-
-    sed -i -e 's,PATH.*,PATH='$MYPATH, \
-       -e 's,^CONF.*,CONF='$out/etc/bootchartd.conf, \
-      script/bootchartd
-  '';
+  buildInputs = [ pkgconfig glib gtk python27 pythonPackages.wrapPython pythonPackages.pygtk ];
+  pythonPath = with pythonPackages; [ pygtk pycairo ];
 
   installPhase = ''
-    mkdir -p $out/sbin $out/etc
-    cp script/bootchartd $out/sbin
-    cp script/bootchartd.conf $out/etc
-    chmod +x $out/sbin/bootchartd
+    make install DESTDIR=$out BINDIR=/bin PY_LIBDIR=/lib/python2.7
+    wrapProgram $out/bin/pybootchartgui \
+      --prefix PYTHONPATH : "$PYTHONPATH:$(toPythonPath $out)"
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/system/fio/default.nix b/pkgs/tools/system/fio/default.nix
index 8589cbe92363..dccfbbcf747f 100644
--- a/pkgs/tools/system/fio/default.nix
+++ b/pkgs/tools/system/fio/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchFromGitHub, libaio, python, zlib }:
 
-let version = "2.2.10"; in
+let version = "2.2.11"; in
 
 stdenv.mkDerivation rec {
   name = "fio-${version}";
@@ -9,7 +9,7 @@ stdenv.mkDerivation rec {
     owner = "axboe";
     repo = "fio";
     rev = "fio-${version}";
-    sha256 = "0hg72k8cifw6lc46kyiic7ai4gqn2819d6g998vmx01jnlcixp8q";
+    sha256 = "0g26xvbb60f96ks8q7jpap0xc2grb5j5w4m4glz910ndgf0s45wm";
   };
 
   buildInputs = [ libaio python zlib ];