about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-09-06 10:21:43 +0200
committerVladimír Čunát <vcunat@gmail.com>2015-09-06 10:26:30 +0200
commit8f33b8cc93006c97a8f6b7ede20214992ed31fa8 (patch)
tree319163313cd55a160bbd9376151da1c96e124fd2 /pkgs/tools
parentf67ddbaa6f049cdd2a5e2333e3679c4f5f4b638f (diff)
downloadnixlib-8f33b8cc93006c97a8f6b7ede20214992ed31fa8.tar
nixlib-8f33b8cc93006c97a8f6b7ede20214992ed31fa8.tar.gz
nixlib-8f33b8cc93006c97a8f6b7ede20214992ed31fa8.tar.bz2
nixlib-8f33b8cc93006c97a8f6b7ede20214992ed31fa8.tar.lz
nixlib-8f33b8cc93006c97a8f6b7ede20214992ed31fa8.tar.xz
nixlib-8f33b8cc93006c97a8f6b7ede20214992ed31fa8.tar.zst
nixlib-8f33b8cc93006c97a8f6b7ede20214992ed31fa8.zip
mass rewrite of find parameters to cross-platform style
Fixes #9044, close #9667. Thanks to @taku0 for suggesting this solution.
Now we have no modes starting with `/` or `+`.

Rewrite the `-perm` parameters of find:
 - completely safe: rewrite `/0100` and `+100` to `-0100`,
 - slightly semantics-changing: rewrite `+111` to `-0100`.
I cross-verified the `find` manual pages for Linux, Darwin, FreeBSD.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/quirc/default.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/pkgs/tools/graphics/quirc/default.nix b/pkgs/tools/graphics/quirc/default.nix
index cab02f6573d1..d84989d4372b 100644
--- a/pkgs/tools/graphics/quirc/default.nix
+++ b/pkgs/tools/graphics/quirc/default.nix
@@ -26,7 +26,7 @@ stdenv.mkDerivation {
   '';
   preInstall = ''
     mkdir -p "$out"/{bin,lib,include}
-    find . -maxdepth 1 -type f -perm +111 -exec cp '{}' "$out"/bin ';'
+    find . -maxdepth 1 -type f -perm -0100 -exec cp '{}' "$out"/bin ';'
   '';
   makeFlags = "PREFIX=$(out)";
   meta = {