about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFabian Affolter <mail@fabian-affolter.ch>2023-03-22 21:09:13 +0100
committerFabian Affolter <mail@fabian-affolter.ch>2023-03-22 21:09:13 +0100
commit8d231244fd9712f702dea6c21461826f8eea2a57 (patch)
treeb9a8d9b758ca651eddf4c662902eafa44e16c4bd /pkgs/tools
parent656709bceb2d9f86c5b971f0ec53bbfbac0de543 (diff)
downloadnixlib-8d231244fd9712f702dea6c21461826f8eea2a57.tar
nixlib-8d231244fd9712f702dea6c21461826f8eea2a57.tar.gz
nixlib-8d231244fd9712f702dea6c21461826f8eea2a57.tar.bz2
nixlib-8d231244fd9712f702dea6c21461826f8eea2a57.tar.lz
nixlib-8d231244fd9712f702dea6c21461826f8eea2a57.tar.xz
nixlib-8d231244fd9712f702dea6c21461826f8eea2a57.tar.zst
nixlib-8d231244fd9712f702dea6c21461826f8eea2a57.zip
ghauri: init at 1.1.8
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/ghauri/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/tools/security/ghauri/default.nix b/pkgs/tools/security/ghauri/default.nix
new file mode 100644
index 000000000000..92f1e9e1b0bc
--- /dev/null
+++ b/pkgs/tools/security/ghauri/default.nix
@@ -0,0 +1,39 @@
+{ lib
+, python3
+, fetchFromGitHub
+}:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "ghauri";
+  version = "1.1.8";
+  format = "setuptools";
+
+  src = fetchFromGitHub {
+    owner = "r0oth3x49";
+    repo = "ghauri";
+    rev = "refs7tags/${version}";
+    hash = "sha256-WEWiWu8U7DmRjj42BEBXA3CHTyJh2Apz59ImFrmQXEk=";
+  };
+
+  propagatedBuildInputs = with python3.pkgs; [
+    chardet
+    colorama
+    requests
+    tldextract
+  ];
+
+  # Project has no tests
+  doCheck = false;
+
+  pythonImportsCheck = [
+    "ghauri"
+  ];
+
+  meta = with lib; {
+    description = "Tool for detecting and exploiting SQL injection security flaws";
+    homepage = "https://github.com/r0oth3x49/ghauri";
+    changelog = "https://github.com/r0oth3x49/ghauri/releases/tag/${version}";
+    license = licenses.mit;
+    maintainers = with maintainers; [ fab ];
+  };
+}