about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorHugo Reeves <hugo@hugoreeves.com>2020-01-17 07:07:29 +1300
committerHugo Reeves <hugo@hugoreeves.com>2020-01-17 07:07:29 +1300
commit8bef4113cefc21ddc6c416ce5236464108644d4f (patch)
tree2e43faea943f0590ce4e1d70ffb612c7f891797b /pkgs/tools
parentece829033b7b8f4e81261fef5427144df4147bc4 (diff)
downloadnixlib-8bef4113cefc21ddc6c416ce5236464108644d4f.tar
nixlib-8bef4113cefc21ddc6c416ce5236464108644d4f.tar.gz
nixlib-8bef4113cefc21ddc6c416ce5236464108644d4f.tar.bz2
nixlib-8bef4113cefc21ddc6c416ce5236464108644d4f.tar.lz
nixlib-8bef4113cefc21ddc6c416ce5236464108644d4f.tar.xz
nixlib-8bef4113cefc21ddc6c416ce5236464108644d4f.tar.zst
nixlib-8bef4113cefc21ddc6c416ce5236464108644d4f.zip
topgrade: fix, add darwin Foundation framework
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/topgrade/default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/pkgs/tools/misc/topgrade/default.nix b/pkgs/tools/misc/topgrade/default.nix
index 060975f2002b..b36467cdff50 100644
--- a/pkgs/tools/misc/topgrade/default.nix
+++ b/pkgs/tools/misc/topgrade/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, rustPlatform }:
+{ stdenv, lib, fetchFromGitHub, rustPlatform, Foundation }:
 
 rustPlatform.buildRustPackage rec {
   pname = "topgrade";
@@ -13,7 +13,9 @@ rustPlatform.buildRustPackage rec {
 
   cargoSha256 = "1y85hl7xl60vsj3ivm6pyd6bvk39wqg25bqxfx00r9myha94iqmd";
 
-  meta = with stdenv.lib; {
+  buildInputs = lib.optional stdenv.isDarwin Foundation;
+
+  meta = with lib; {
     description = "Upgrade all the things";
     homepage = "https://github.com/r-darwish/topgrade";
     license = licenses.gpl3;