about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-05-27 18:54:19 +0100
committerGitHub <noreply@github.com>2017-05-27 18:54:19 +0100
commit801adf99c2248ef8e8928ff5b13252f48cbf0b23 (patch)
tree36a81994e21f6e98507552c1588875871f14cf99 /pkgs/tools
parent476086929af70ed022c79fdc5cced15e502ee2b8 (diff)
parent6de69a2425446035af7b589809de5fd2f3e637dd (diff)
downloadnixlib-801adf99c2248ef8e8928ff5b13252f48cbf0b23.tar
nixlib-801adf99c2248ef8e8928ff5b13252f48cbf0b23.tar.gz
nixlib-801adf99c2248ef8e8928ff5b13252f48cbf0b23.tar.bz2
nixlib-801adf99c2248ef8e8928ff5b13252f48cbf0b23.tar.lz
nixlib-801adf99c2248ef8e8928ff5b13252f48cbf0b23.tar.xz
nixlib-801adf99c2248ef8e8928ff5b13252f48cbf0b23.tar.zst
nixlib-801adf99c2248ef8e8928ff5b13252f48cbf0b23.zip
Merge pull request #26158 from montag451/simpleproxy
simpleproxy: init at 3.5
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/simpleproxy/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/tools/networking/simpleproxy/default.nix b/pkgs/tools/networking/simpleproxy/default.nix
new file mode 100644
index 000000000000..476e7dc229df
--- /dev/null
+++ b/pkgs/tools/networking/simpleproxy/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchFromGitHub }:
+
+stdenv.mkDerivation rec {
+  name = "simpleproxy-${version}";
+  version = "3.5";
+  rev = "v.${version}";
+
+  src = fetchFromGitHub {
+    inherit rev;
+    owner = "vzaliva";
+    repo = "simpleproxy";
+    sha256 = "1my9g4vp19dikx3fsbii4ichid1bs9b9in46bkg05gbljhj340f6";
+  };
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/vzaliva/simpleproxy;
+    description = "A simple TCP proxy";
+    license = licenses.gpl2;
+    maintainers = [ maintainers.montag451 ];
+  };
+}