about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMartin Schwaighofer <mschwaig@users.noreply.github.com>2023-09-27 12:38:45 +0200
committerMartin Schwaighofer <mschwaig@users.noreply.github.com>2023-09-27 13:23:41 +0200
commit7ef43e566c884c099482bba54a2712f47fc193a6 (patch)
treed6bae64256ae268bf700f885e66ec52761579812 /pkgs/tools
parentcc27cd5fdf89fb57a99316ad4938a4014570d55f (diff)
downloadnixlib-7ef43e566c884c099482bba54a2712f47fc193a6.tar
nixlib-7ef43e566c884c099482bba54a2712f47fc193a6.tar.gz
nixlib-7ef43e566c884c099482bba54a2712f47fc193a6.tar.bz2
nixlib-7ef43e566c884c099482bba54a2712f47fc193a6.tar.lz
nixlib-7ef43e566c884c099482bba54a2712f47fc193a6.tar.xz
nixlib-7ef43e566c884c099482bba54a2712f47fc193a6.tar.zst
nixlib-7ef43e566c884c099482bba54a2712f47fc193a6.zip
diffoscope: fix broken build due to cbfs tests for now
The diffoscope build broke due to failing tests related to cbfs when
coreboot-utils was updated from 4.20 to 4.21 with commit
be6408699e598ea127c6a1a6da74ed27e95b819d.
Thanks to aij on github for reporting this issue and bisecting to find
the change in nixpkgs that introduced the issue.
The tests disabled in this commit should be re-enabled when diffoscope or
coreboot fix the underlying issue.

See: https://github.com/NixOS/nixpkgs/issues/256896
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/diffoscope/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/tools/misc/diffoscope/default.nix b/pkgs/tools/misc/diffoscope/default.nix
index 7daff3641a04..2b966474346d 100644
--- a/pkgs/tools/misc/diffoscope/default.nix
+++ b/pkgs/tools/misc/diffoscope/default.nix
@@ -245,8 +245,13 @@ python3.pkgs.buildPythonApplication rec {
     "test_symlink_root"
   ];
 
+  disabledTestPaths = [
+    # fails due to https://github.com/NixOS/nixpkgs/issues/256896
+    # should be removed once that issue is resolved in coreboot or diffoscope
+    "tests/comparators/test_cbfs.py"
+  ]
   # Flaky tests on Darwin
-  disabledTestPaths = lib.optionals stdenv.isDarwin [
+  ++ lib.optionals stdenv.isDarwin [
     "tests/comparators/test_git.py"
     "tests/comparators/test_java.py"
     "tests/comparators/test_uimage.py"