about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorMario Rodas <marsam@users.noreply.github.com>2023-05-27 16:19:42 -0500
committerGitHub <noreply@github.com>2023-05-27 16:19:42 -0500
commit7bdafdd1c980733e5d1dbbe873eb9fa271d080c9 (patch)
tree0173b3b51ff8d95a8a588a102b04f340240dc022 /pkgs/tools
parent9494441e763af3a7d7594c6b3819368dbd56b5a7 (diff)
parent874d79d4757d399f8e5dc0c5b98720f9e8ac13d1 (diff)
downloadnixlib-7bdafdd1c980733e5d1dbbe873eb9fa271d080c9.tar
nixlib-7bdafdd1c980733e5d1dbbe873eb9fa271d080c9.tar.gz
nixlib-7bdafdd1c980733e5d1dbbe873eb9fa271d080c9.tar.bz2
nixlib-7bdafdd1c980733e5d1dbbe873eb9fa271d080c9.tar.lz
nixlib-7bdafdd1c980733e5d1dbbe873eb9fa271d080c9.tar.xz
nixlib-7bdafdd1c980733e5d1dbbe873eb9fa271d080c9.tar.zst
nixlib-7bdafdd1c980733e5d1dbbe873eb9fa271d080c9.zip
Merge pull request #234263 from adamcstephens/lxd/5.14
lxd: 5.13 -> 5.14
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/lxd/default.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/pkgs/tools/admin/lxd/default.nix b/pkgs/tools/admin/lxd/default.nix
index d32d35dd88a5..3048eaac33c5 100644
--- a/pkgs/tools/admin/lxd/default.nix
+++ b/pkgs/tools/admin/lxd/default.nix
@@ -28,18 +28,19 @@
 , bash
 , installShellFiles
 , nixosTests
+, gitUpdater
 }:
 
 buildGoModule rec {
   pname = "lxd";
-  version = "5.13";
+  version = "5.14";
 
   src = fetchurl {
     urls = [
       "https://linuxcontainers.org/downloads/lxd/lxd-${version}.tar.gz"
       "https://github.com/lxc/lxd/releases/download/lxd-${version}/lxd-${version}.tar.gz"
     ];
-    hash = "sha256-kys8zfqhkpJqq4ICg6dOsoJEoxJ209GwdjGRrfrZ7j0=";
+    hash = "sha256-EtVZ0g9LD6dWA70/E1Ad/RWJjbvrAzU2hF3n6CdTMBE=";
   };
 
   vendorHash = null;
@@ -98,6 +99,10 @@ buildGoModule rec {
 
   passthru.tests.lxd = nixosTests.lxd;
   passthru.tests.lxd-nftables = nixosTests.lxd-nftables;
+  passthru.updateScript = gitUpdater {
+    url = "https://github.com/lxc/lxd.git";
+    rev-prefix = "lxd-";
+  };
 
   meta = with lib; {
     description = "Daemon based on liblxc offering a REST API to manage containers";