about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2018-02-17 10:27:21 +0100
committerVladimír Čunát <vcunat@gmail.com>2018-02-17 10:27:21 +0100
commit7a1462c04a340d3e4ebef329fc9d5ec2606cb0be (patch)
treee259288064513f53fc278d8f9c568686dba352b2 /pkgs/tools
parentd74d79a7128a47c08d1add154a3122d19932eee2 (diff)
parent327a84749ed48a20736fdf20b9dd4f5723b01912 (diff)
downloadnixlib-7a1462c04a340d3e4ebef329fc9d5ec2606cb0be.tar
nixlib-7a1462c04a340d3e4ebef329fc9d5ec2606cb0be.tar.gz
nixlib-7a1462c04a340d3e4ebef329fc9d5ec2606cb0be.tar.bz2
nixlib-7a1462c04a340d3e4ebef329fc9d5ec2606cb0be.tar.lz
nixlib-7a1462c04a340d3e4ebef329fc9d5ec2606cb0be.tar.xz
nixlib-7a1462c04a340d3e4ebef329fc9d5ec2606cb0be.tar.zst
nixlib-7a1462c04a340d3e4ebef329fc9d5ec2606cb0be.zip
Merge branch 'master' into gcc-7
A few thousand rebuilds.
Hydra: ?compare=1433915
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/backup/restic/default.nix10
-rw-r--r--pkgs/tools/graphics/graph-easy/default.nix18
-rw-r--r--pkgs/tools/misc/hyperfine/default.nix25
-rw-r--r--pkgs/tools/misc/mprime/default.nix21
-rw-r--r--pkgs/tools/misc/mprime/makefile.patch47
-rw-r--r--pkgs/tools/misc/plotinus/default.nix44
-rw-r--r--pkgs/tools/package-management/nix/default.nix6
-rw-r--r--pkgs/tools/security/spectre-meltdown-checker/default.nix4
-rw-r--r--pkgs/tools/system/acpica-tools/default.nix36
-rw-r--r--pkgs/tools/system/efivar/default.nix14
-rw-r--r--pkgs/tools/text/ripgrep/default.nix21
-rw-r--r--pkgs/tools/virtualization/govc/default.nix24
12 files changed, 209 insertions, 61 deletions
diff --git a/pkgs/tools/backup/restic/default.nix b/pkgs/tools/backup/restic/default.nix
index 40d8e0a4fbc4..b7422e311b09 100644
--- a/pkgs/tools/backup/restic/default.nix
+++ b/pkgs/tools/backup/restic/default.nix
@@ -19,8 +19,16 @@ buildGoPackage rec {
   '';
 
   installPhase = ''
-    mkdir -p $bin/bin/
+    mkdir -p \
+      $bin/bin \
+      $bin/etc/bash_completion.d \
+      $bin/share/zsh/vendor-completions \
+      $bin/share/man/man1
     cp restic $bin/bin/
+    $bin/bin/restic generate \
+      --bash-completion $bin/etc/bash_completion.d/restic.sh \
+      --zsh-completion $bin/share/zsh/vendor-completions/restic.sh \
+      --man $bin/share/man/man1
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/graphics/graph-easy/default.nix b/pkgs/tools/graphics/graph-easy/default.nix
new file mode 100644
index 000000000000..e505f0bb6db5
--- /dev/null
+++ b/pkgs/tools/graphics/graph-easy/default.nix
@@ -0,0 +1,18 @@
+{ stdenv, buildPerlPackage, fetchurl }:
+
+buildPerlPackage rec {
+  name = "Graph-Easy-${version}";
+  version = "0.76";
+  src = fetchurl {
+    url = "mirror://cpan/authors/id/S/SH/SHLOMIF/${name}.tar.gz";
+    sha256 = "d4a2c10aebef663b598ea37f3aa3e3b752acf1fbbb961232c3dbe1155008d1fa";
+  };
+  
+  meta = with stdenv.lib; {
+    homepage = http://search.cpan.org/~tels/Graph-Easy/bin/graph-easy;
+    description = "Render/convert graphs in/from various formats";
+    license = licenses.gpl1;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.jensbin ];
+  };
+}
diff --git a/pkgs/tools/misc/hyperfine/default.nix b/pkgs/tools/misc/hyperfine/default.nix
new file mode 100644
index 000000000000..322151739843
--- /dev/null
+++ b/pkgs/tools/misc/hyperfine/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, rustPlatform }:
+
+with rustPlatform;
+
+buildRustPackage rec {
+  name = "hyperfine-${version}";
+  version = "0.4.0";
+
+  src = fetchFromGitHub {
+    owner  = "sharkdp";
+    repo   = "hyperfine";
+    rev    = "refs/tags/v${version}";
+    sha256 = "1ynqyacbx0x971lyd1k406asms58bc7vzl8gca3sg34rx0hx3wzi";
+  };
+
+  cargoSha256 = "109yv1618bi19vh1jjv2ki06mafhcrv35a3a1zsr34kg3gsjv0rb";
+
+  meta = with stdenv.lib; {
+    description = "Command-line benchmarking tool";
+    homepage    = https://github.com/sharkdp/hyperfine;
+    license     = with licenses; [ asl20 /* or */ mit ];
+    maintainers = [ maintainers.thoughtpolice ];
+    platforms   = platforms.all;
+  };
+}
diff --git a/pkgs/tools/misc/mprime/default.nix b/pkgs/tools/misc/mprime/default.nix
index 3ef039507d4e..556d21ee2fc7 100644
--- a/pkgs/tools/misc/mprime/default.nix
+++ b/pkgs/tools/misc/mprime/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, unzip, pkgconfig, curl }:
+{ stdenv, lib, fetchurl, unzip, curl, hwloc, gmp }:
 
 let
   srcDir =
@@ -14,25 +14,24 @@ let
     else throwSystem;
 in
 
-stdenv.mkDerivation {
-  name = "mprime-28.7";
+stdenv.mkDerivation rec {
+  name = "mprime-${version}";
+  version = "29.4b7";
 
   src = fetchurl {
-    url = http://www.mersenne.org/ftp_root/gimps/p95v287.source.zip;
-    sha256 = "1k3gxhs3g8hfghzpmidhcwpwyayj8r83v8zjai1z4xgsql4jwby1";
+    url = "http://www.mersenne.org/ftp_root/gimps/p95v${lib.replaceStrings ["."] [""] version}.source.zip";
+    sha256 = "0idaqm46m4yis7vl014scx57lpccvjbnyy79gmj8caxghyajws0m";
   };
 
-  unpackCmd = "unzip -d src -q $curSrc";
+  unpackCmd = "unzip -d src -q $curSrc || true";
 
-  nativeBuildInputs = [ pkgconfig ];
-  buildInputs = [ unzip curl ];
+  nativeBuildInputs = [ unzip ];
+  buildInputs = [ curl hwloc gmp ];
 
   patches = [ ./makefile.patch ];
 
   buildPhase = ''
     make -C gwnum -f ${gwnum}
-    echo 'override CFLAGS := $(CFLAGS)' $(pkg-config --cflags libcurl) >> ${srcDir}/makefile
-    echo 'override LIBS := $(LIBS)' $(pkg-config --libs libcurl) >> ${srcDir}/makefile
     make -C ${srcDir}
   '';
 
@@ -48,7 +47,7 @@ stdenv.mkDerivation {
       client. It is identical to Prime95 in functionality, except it lacks a
       graphical user interface.
     '';
-    homepage = http://www.mersenne.org/;
+    homepage = "http://www.mersenne.org/";
     # Unfree, because of a license requirement to share prize money if you find
     # a suitable prime. http://www.mersenne.org/legal/#EULA
     license = stdenv.lib.licenses.unfree;
diff --git a/pkgs/tools/misc/mprime/makefile.patch b/pkgs/tools/misc/mprime/makefile.patch
index 7f758af7b7c4..6ed9cf69384d 100644
--- a/pkgs/tools/misc/mprime/makefile.patch
+++ b/pkgs/tools/misc/mprime/makefile.patch
@@ -1,46 +1,41 @@
-diff -ru orig/linux/makefile patched/linux/makefile
---- orig/linux/makefile	2015-08-09 21:06:18.000000000 +0100
-+++ patched/linux/makefile	2016-02-16 16:25:45.988662423 +0000
-@@ -25,8 +25,8 @@
+diff -dur src.old/linux/makefile src.new/linux/makefile
+--- src.old/linux/makefile	2018-01-04 20:49:00.000000000 +0300
++++ src.new/linux/makefile	2018-02-15 12:32:02.913011604 +0300
+@@ -28,8 +28,8 @@
  CPP = g++
  CPPFLAGS = -I.. -I../gwnum -O2 -march=i486 -malign-double
  
 -LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
--LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl
+-LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
 +LFLAGS =
-+LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -lrt -lstdc++ -ldl
++LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -lhwloc -lcurl -lrt -lstdc++ -ldl -lgmp
  
  FACTOROBJ = factor32.o
  LINUXOBJS = prime.o menu.o
-diff -ru orig/linux64/makefile patched/linux64/makefile
---- orig/linux64/makefile	2015-08-09 21:06:20.000000000 +0100
-+++ patched/linux64/makefile	2016-02-16 16:25:57.076531585 +0000
-@@ -13,13 +13,13 @@
- #	LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
- 
- CC = gcc
--CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -O2 
-+CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -O2
- 
+diff -dur src.old/linux64/makefile src.new/linux64/makefile
+--- src.old/linux64/makefile	2018-01-04 20:49:00.000000000 +0300
++++ src.new/linux64/makefile	2018-02-15 12:32:28.836286995 +0300
+@@ -26,9 +26,9 @@
  CPP = g++
  CPPFLAGS = -I.. -I../gwnum -DX86_64 -O2
  
 -LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
--LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl
 +LFLAGS =
-+LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -lrt -lstdc++ -ldl
+ #LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
+-LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
++LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -lhwloc -lcurl -lrt -lstdc++ -ldl -lgmp
  
  FACTOROBJ = factor64.o
  LINUXOBJS = prime.o menu.o
-diff -ru orig/macosx64/makefile patched/macosx64/makefile
---- orig/macosx64/makefile	2015-08-09 21:06:22.000000000 +0100
-+++ patched/macosx64/makefile	2016-02-16 16:19:03.988415925 +0000
-@@ -10,7 +10,7 @@
+diff -dur src.old/macosx64/makefile src.new/macosx64/makefile
+--- src.old/macosx64/makefile	2018-01-04 20:49:02.000000000 +0300
++++ src.new/macosx64/makefile	2018-02-15 12:33:32.401902535 +0300
+@@ -12,7 +12,7 @@
+ CPP = g++
  CPPFLAGS = -I.. -I../gwnum -I../linux -O2 -DX86_64 -DCOMMAND_LINE_MPRIME -m64
  
- LFLAGS = -m64 -Wl,-no_pie
--LIBS   = ../gwnum/amd64/release/gwnum.a -lm -lpthread -lcurl -framework IOKit -framework CoreFoundation -lstdc++
-+LIBS   = ../gwnum/amd64/release/gwnum.a -lm -lpthread -framework IOKit -framework CoreFoundation -lstdc++
+-LFLAGS = -m64 -Wl,-no_pie -L/usr/local/lib
++LFLAGS = -m64 -Wl,-no_pie
+ LIBS   = ../gwnum/amd64/release/gwnum.a -lm -lpthread -lhwloc -lcurl -framework IOKit -framework CoreFoundation -lstdc++ -lgmp
  
  FACTOROBJ = ../prime95/macosx64/factor64.o
- OBJS = prime.o menu.o
diff --git a/pkgs/tools/misc/plotinus/default.nix b/pkgs/tools/misc/plotinus/default.nix
new file mode 100644
index 000000000000..41913f966534
--- /dev/null
+++ b/pkgs/tools/misc/plotinus/default.nix
@@ -0,0 +1,44 @@
+{ stdenv
+, fetchFromGitHub
+, gettext
+, libxml2
+, pkgconfig
+, gtk3
+, cmake
+, ninja
+, vala
+, wrapGAppsHook }:
+
+stdenv.mkDerivation rec {
+  name = "plotinus-${version}";
+  version = "0.2.0";
+
+  src = fetchFromGitHub {
+    owner = "p-e-w";
+    repo = "plotinus";
+    rev = "v${version}";
+    sha256 = "19k6f6ivg4ab57m62g6fkg85q9sv049snmzq1fyqnqijggwshxfz";
+  };
+
+  nativeBuildInputs = [
+    pkgconfig
+    wrapGAppsHook
+    vala
+    cmake
+    ninja
+    gettext
+    libxml2
+  ];
+  buildInputs = [
+    gtk3
+  ];
+
+  meta = with stdenv.lib; {
+    description = "A searchable command palette in every modern GTK+ application";
+    homepage = https://github.com/p-e-w/plotinus;
+    maintainers = with maintainers; [ samdroid-apps ];
+    platforms = platforms.linux;
+    # No COPYING file, but headers in the source code
+    license = licenses.gpl3;
+  };
+}
diff --git a/pkgs/tools/package-management/nix/default.nix b/pkgs/tools/package-management/nix/default.nix
index 31688084af5a..21b333f32316 100644
--- a/pkgs/tools/package-management/nix/default.nix
+++ b/pkgs/tools/package-management/nix/default.nix
@@ -124,12 +124,12 @@ in rec {
 
   nixUnstable = (lib.lowPrio (common rec {
     name = "nix-2.0${suffix}";
-    suffix = "pre5943_52c777a7";
+    suffix = "pre5950_3a5a241b";
     src = fetchFromGitHub {
       owner = "NixOS";
       repo = "nix";
-      rev = "52c777a79318c85c8fbd8c02174a03511de278db";
-      sha256 = "0qwmyy7l16djrlksfpjfkfkh5v9s0cyg6ca2809m1qb6swfzqqdf";
+      rev = "3a5a241b3209f14f8801b902ba20b5cb0666c9df";
+      sha256 = "0cwjyhgyfzi2dz561nj897zhkbyx6lzi49avcyia2pr4498jcl6k";
     };
     fromGit = true;
   })) // { perl-bindings = perl-bindings { nix = nixUnstable; }; };
diff --git a/pkgs/tools/security/spectre-meltdown-checker/default.nix b/pkgs/tools/security/spectre-meltdown-checker/default.nix
index d03c387a7c6c..13bebe10c623 100644
--- a/pkgs/tools/security/spectre-meltdown-checker/default.nix
+++ b/pkgs/tools/security/spectre-meltdown-checker/default.nix
@@ -2,13 +2,13 @@
 
 stdenv.mkDerivation rec {
   name = "spectre-meltdown-checker-${version}";
-  version = "0.34";
+  version = "0.35";
 
   src = fetchFromGitHub {
     owner = "speed47";
     repo = "spectre-meltdown-checker";
     rev = "v${version}";
-    sha256 = "0jlqxzii883yl5iqmywqqqjlhgswn033566a3vpspycj3sr8zrd2";
+    sha256 = "0pzs6iznrar5zkg92gsh6d0zhdi715zwqcb8hh1aaykx9igjb1xw";
   };
 
   prePatch = ''
diff --git a/pkgs/tools/system/acpica-tools/default.nix b/pkgs/tools/system/acpica-tools/default.nix
new file mode 100644
index 000000000000..1381f13fd3c5
--- /dev/null
+++ b/pkgs/tools/system/acpica-tools/default.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchurl, bison, flex }:
+
+stdenv.mkDerivation rec {
+  name = "acpica-tools-${version}";
+  version = "20180209";
+
+  src = fetchurl {
+    url = "https://acpica.org/sites/acpica/files/acpica-unix-${version}.tar.gz";
+    sha256 = "1rpdfwa4vwnvyxdp9ygqjckmabc3s8kyg3jyq4n4f0rhr1zl4zy5";
+  };
+
+  NIX_CFLAGS_COMPILE = "-O3";
+
+  enableParallelBuilding = true;
+
+  buildFlags = [
+    "acpibin"
+    "acpidump"
+    "acpiexec"
+    "acpihelp"
+    "acpinames"
+    "acpixtract"
+  ];
+
+  nativeBuildInputs = [ bison flex ];
+
+  installFlags = [ "PREFIX=$(out)" ];
+
+  meta = with stdenv.lib; {
+    description = "ACPICA Tools";
+    homepage = "https://www.acpica.org/";
+    license = with licenses; [ gpl2 bsd3 ];
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ tadfisher ];
+  };
+}
diff --git a/pkgs/tools/system/efivar/default.nix b/pkgs/tools/system/efivar/default.nix
index 6b062513483d..7f20e8135011 100644
--- a/pkgs/tools/system/efivar/default.nix
+++ b/pkgs/tools/system/efivar/default.nix
@@ -2,27 +2,21 @@
 
 stdenv.mkDerivation rec {
   name = "efivar-${version}";
-  version = "30";
+  version = "34";
 
   src = fetchFromGitHub {
     owner = "rhinstaller";
     repo = "efivar";
     rev = version;
-    sha256 = "1pghj019qr7qpqd9rxfhsr1hm3s0w1hd5cdndpl07vhys8hy4a8a";
+    sha256 = "0ycrdaz0ijkm3xb9fnwzhwi0pdj5c6s636wj4i6lbjbrijbzn4x5";
   };
 
   nativeBuildInputs = [ pkgconfig ];
   buildInputs = [ popt ];
 
-  postPatch = ''
-     substituteInPlace src/Makefile --replace "-static" ""
-  '';
-
-  installFlags = [
+  makeFlags = [
+    "prefix=$(out)"
     "libdir=$(out)/lib"
-    "mandir=$(out)/share/man"
-    "includedir=$(out)/include"
-    "bindir=$(out)/bin"
   ];
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/text/ripgrep/default.nix b/pkgs/tools/text/ripgrep/default.nix
index 9a93ec2d7674..a93ec8e4e4c9 100644
--- a/pkgs/tools/text/ripgrep/default.nix
+++ b/pkgs/tools/text/ripgrep/default.nix
@@ -1,23 +1,28 @@
-{ stdenv, fetchFromGitHub, rustPlatform, makeWrapper }:
+{ stdenv, fetchFromGitHub, rustPlatform, makeWrapper, asciidoc, docbook_xsl, libxslt  }:
 
-with rustPlatform;
-
-buildRustPackage rec {
+rustPlatform.buildRustPackage rec {
   name = "ripgrep-${version}";
-  version = "0.7.1";
+  version = "0.8.0";
 
   src = fetchFromGitHub {
     owner = "BurntSushi";
     repo = "ripgrep";
     rev = "${version}";
-    sha256 = "0z3f83vhy464k93bc55i9lr6z41163q96if938p9ndhx2q3a20ql";
+    sha256 = "0ha46vhma2diqxfgasdc9gwlkcrlhc4l65nayvdy4m2ah5bm4qp6";
   };
 
-  cargoSha256 = "1d6s01gmyfzb0vdf7flq6nvlapwcgbj0mzcprzyg4nj5gjkvznrn";
+  cargoSha256 = "0q44qa9myrzg42q0lvclpk5nypmf0q7v3xy5nnsb28j3imvcrs4p";
+
+  nativeBuildInputs = [ asciidoc docbook_xsl libxslt ];
 
   preFixup = ''
     mkdir -p "$out/man/man1"
-    cp "$src/doc/rg.1" "$out/man/man1"
+    cp target/release/build/ripgrep-*/out/rg.1 "$out/man/man1/"
+
+    mkdir -p "$out/share/"{bash-completion/completions,fish/vendor_completions.d,zsh/site-functions}
+    cp target/release/build/ripgrep-*/out/rg.bash "$out/share/bash-completion/completions/"
+    cp target/release/build/ripgrep-*/out/rg.fish "$out/share/fish/vendor_completions.d/"
+    cp "$src/complete/_rg" "$out/share/zsh/site-functions/"
   '';
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/virtualization/govc/default.nix b/pkgs/tools/virtualization/govc/default.nix
new file mode 100644
index 000000000000..527c47ffc34c
--- /dev/null
+++ b/pkgs/tools/virtualization/govc/default.nix
@@ -0,0 +1,24 @@
+{ lib, fetchFromGitHub, buildGoPackage }:
+  
+buildGoPackage rec {
+  name = "govc-${version}";
+  version = "0.16.0";
+
+  goPackagePath = "github.com/vmware/govmomi";
+
+  subPackages = [ "govc" ];
+
+  src = fetchFromGitHub {
+    rev = "v${version}";
+    owner = "vmware";
+    repo = "govmomi";
+    sha256 = "09fllx7l2hsjrv1jl7g06xngjy0xwn5n5zng6x8dspgsl6kblyqp";
+  };
+
+  meta = {
+    description = "A vSphere CLI built on top of govmomi";
+    homepage = https://github.com/vmware/govmomi/tree/master/govc;
+    license = lib.licenses.asl20;
+    maintainers = with lib.maintainers; [ nicknovitski ];
+  };
+}