about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2018-11-11 08:59:44 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2018-11-11 08:59:44 +0100
commit7863aae5b2eeb8c7af241a0f0ee0c5a15a8fabc8 (patch)
tree7061d7dc8c0e31d96e35fef2adce9999713be9f2 /pkgs/tools
parented8400bb9a59f267185d2d09b8f47d270a44ee99 (diff)
parent3c4f70996e46ed7e9c3a480f51398194d31e3e93 (diff)
downloadnixlib-7863aae5b2eeb8c7af241a0f0ee0c5a15a8fabc8.tar
nixlib-7863aae5b2eeb8c7af241a0f0ee0c5a15a8fabc8.tar.gz
nixlib-7863aae5b2eeb8c7af241a0f0ee0c5a15a8fabc8.tar.bz2
nixlib-7863aae5b2eeb8c7af241a0f0ee0c5a15a8fabc8.tar.lz
nixlib-7863aae5b2eeb8c7af241a0f0ee0c5a15a8fabc8.tar.xz
nixlib-7863aae5b2eeb8c7af241a0f0ee0c5a15a8fabc8.tar.zst
nixlib-7863aae5b2eeb8c7af241a0f0ee0c5a15a8fabc8.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/X11/wpgtk/default.nix49
-rw-r--r--pkgs/tools/archivers/cabextract/default.nix4
-rw-r--r--pkgs/tools/filesystems/android-file-transfer/default.nix4
-rw-r--r--pkgs/tools/filesystems/btrfs-progs/default.nix4
-rw-r--r--pkgs/tools/filesystems/disorderfs/default.nix4
-rw-r--r--pkgs/tools/filesystems/glusterfs/default.nix7
-rw-r--r--pkgs/tools/filesystems/glusterfs/glusterfs-python-remove-find_library.patch39
-rw-r--r--pkgs/tools/inputmethods/libinput-gestures/default.nix4
-rw-r--r--pkgs/tools/misc/bdf2psf/default.nix4
-rw-r--r--pkgs/tools/misc/debootstrap/default.nix4
-rw-r--r--pkgs/tools/misc/doitlive/default.nix4
-rw-r--r--pkgs/tools/misc/fwup/default.nix4
-rw-r--r--pkgs/tools/misc/hebcal/default.nix4
-rw-r--r--pkgs/tools/misc/noti/default.nix4
-rw-r--r--pkgs/tools/misc/up/default.nix23
-rw-r--r--pkgs/tools/misc/up/deps.nix66
-rw-r--r--pkgs/tools/networking/getmail/default.nix4
-rw-r--r--pkgs/tools/security/eid-mw/default.nix4
-rw-r--r--pkgs/tools/security/keybase/default.nix13
-rw-r--r--pkgs/tools/security/lynis/default.nix13
-rw-r--r--pkgs/tools/system/acpica-tools/default.nix4
-rw-r--r--pkgs/tools/system/facter/default.nix4
-rw-r--r--pkgs/tools/system/fio/default.nix4
-rw-r--r--pkgs/tools/text/aha/default.nix4
-rw-r--r--pkgs/tools/text/ansifilter/default.nix4
-rw-r--r--pkgs/tools/text/fanficfare/default.nix4
-rw-r--r--pkgs/tools/text/hyx/default.nix8
-rw-r--r--pkgs/tools/text/hyx/no-wall-by-default.patch11
-rw-r--r--pkgs/tools/virtualization/google-compute-engine/default.nix4
29 files changed, 235 insertions, 74 deletions
diff --git a/pkgs/tools/X11/wpgtk/default.nix b/pkgs/tools/X11/wpgtk/default.nix
new file mode 100644
index 000000000000..b6ba431da9d6
--- /dev/null
+++ b/pkgs/tools/X11/wpgtk/default.nix
@@ -0,0 +1,49 @@
+{ stdenv, python36Packages, fetchFromGitHub, pywal, feh, libxslt, imagemagick,
+  gobjectIntrospection, gtk3, wrapGAppsHook, gnome3 }:
+
+python36Packages.buildPythonApplication rec {
+  pname = "wpgtk";
+  version = "5.7.4";
+
+  src = fetchFromGitHub {
+    owner = "deviantfero";
+    repo = "wpgtk";
+    rev = "${version}";
+    sha256 = "0c0kmc18lbr7nk3hh44hai9z06lfsgwxnjdv02hpjwrxg40zh726";
+  };
+
+  pythonPath = [
+    python36Packages.pygobject3
+    python36Packages.pillow
+    pywal
+    imagemagick
+  ];
+
+  buildInputs = [
+    wrapGAppsHook
+    gtk3
+    gobjectIntrospection
+    gnome3.adwaita-icon-theme
+    libxslt
+  ];
+
+  # The $HOME variable must be set to build the package. A "permission denied" error will occur otherwise
+  preBuild = ''
+      export HOME=$(pwd)
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Template based wallpaper/colorscheme generator and manager";
+    longDescription = ''
+     In short, wpgtk is a colorscheme/wallpaper manager with a template system attached which lets you create templates from any textfile and will replace keywords on it on the fly, allowing for great styling and theming possibilities.
+
+     wpgtk uses pywal as its colorscheme generator, but builds upon it with a UI and other features, such as the abilty to mix and edit the colorschemes generated and save them with their respective wallpapers, having light and dark themes, hackable and fast GTK+ theme made specifically for wpgtk and custom keywords and values to replace in templates.
+
+     INFO: To work properly, this tool needs "programs.dconf.enable = true" on nixos or dconf installed. A reboot may be required after installing dconf.
+     '';
+    homepage = https://github.com/deviantfero/wpgtk;
+    license = licenses.gpl2;
+    platforms = platforms.linux;
+    maintainers = [ maintainers.melkor333 ];
+  };
+}
diff --git a/pkgs/tools/archivers/cabextract/default.nix b/pkgs/tools/archivers/cabextract/default.nix
index 238ee3646071..edc70e6c601b 100644
--- a/pkgs/tools/archivers/cabextract/default.nix
+++ b/pkgs/tools/archivers/cabextract/default.nix
@@ -1,11 +1,11 @@
 { stdenv, fetchurl }:
 
 stdenv.mkDerivation rec {
-  name = "cabextract-1.7";
+  name = "cabextract-1.9";
 
   src = fetchurl {
     url = "https://www.cabextract.org.uk/${name}.tar.gz";
-    sha256 = "1g86wmb8lkjiv2jarfz979ngbgg7d3si8x5il4g801604v406wi9";
+    sha256 = "1hf4zhjxfdgq9x172r5zfdnafma9q0zf7372syn8hcn7hcypkg0v";
   };
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/filesystems/android-file-transfer/default.nix b/pkgs/tools/filesystems/android-file-transfer/default.nix
index 336dc785bbfd..c3a0c46d5eca 100644
--- a/pkgs/tools/filesystems/android-file-transfer/default.nix
+++ b/pkgs/tools/filesystems/android-file-transfer/default.nix
@@ -2,12 +2,12 @@
 
 stdenv.mkDerivation rec {
   name = "android-file-transfer-${version}";
-  version = "3.5";
+  version = "3.6";
   src = fetchFromGitHub {
     owner = "whoozle";
     repo = "android-file-transfer-linux";
     rev = "v${version}";
-    sha256 = "036hca41ikgnw4maykjdp53l31rm01mgamy9y56i5qqh84cwmls2";
+    sha256 = "0gaj1shmd62ks4cjdcmiqczlr93v8ivjcg0l6s8z73cz9pf8dxmz";
   };
   buildInputs = [ cmake fuse readline pkgconfig qtbase ];
   buildPhase = ''
diff --git a/pkgs/tools/filesystems/btrfs-progs/default.nix b/pkgs/tools/filesystems/btrfs-progs/default.nix
index 42f27e69f38e..252f25ad8fa8 100644
--- a/pkgs/tools/filesystems/btrfs-progs/default.nix
+++ b/pkgs/tools/filesystems/btrfs-progs/default.nix
@@ -4,11 +4,11 @@
 
 stdenv.mkDerivation rec {
   name = "btrfs-progs-${version}";
-  version = "4.17.1";
+  version = "4.19";
 
   src = fetchurl {
     url = "mirror://kernel/linux/kernel/people/kdave/btrfs-progs/btrfs-progs-v${version}.tar.xz";
-    sha256 = "0x6d53fbrcmzvhv461575fzsv3373427p4srz646w2wcagqk82xz";
+    sha256 = "0jd3bsg3117ysr82n03w33sqw1g9z1ciixcxrwgp90yghvjzp4fm";
   };
 
   nativeBuildInputs = [
diff --git a/pkgs/tools/filesystems/disorderfs/default.nix b/pkgs/tools/filesystems/disorderfs/default.nix
index 138f727c3d30..07a9015fa28e 100644
--- a/pkgs/tools/filesystems/disorderfs/default.nix
+++ b/pkgs/tools/filesystems/disorderfs/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "disorderfs-${version}";
-  version = "0.5.4";
+  version = "0.5.5";
 
   src = fetchurl {
     url = "http://http.debian.net/debian/pool/main/d/disorderfs/disorderfs_${version}.orig.tar.gz";
-    sha256 = "0rp789qll5nmzw0jffx36ppcl9flr6hvdz84ah080mvghqkfdq8y";
+    sha256 = "1y1i7k5mx2pxr9bpijnsjyyw8qd7ak1h48gf6a6ca3dhna9ws6i1";
   };
 
   nativeBuildInputs = [ pkgconfig asciidoc ];
diff --git a/pkgs/tools/filesystems/glusterfs/default.nix b/pkgs/tools/filesystems/glusterfs/default.nix
index f4aa9a52fce3..e915cc1c132a 100644
--- a/pkgs/tools/filesystems/glusterfs/default.nix
+++ b/pkgs/tools/filesystems/glusterfs/default.nix
@@ -15,10 +15,10 @@ let
     #       The command
     #         find /nix/store/...-glusterfs-.../ -name '*.py' -executable
     #       can help with finding new Python scripts.
-    version = "3.12.12";
+    version = "4.0.0";
     name="${baseName}-${version}";
     url="https://github.com/gluster/glusterfs/archive/v${version}.tar.gz";
-    sha256 = "1q6rcf9y98w3kvgwdlbhl65phkdl0mfil6y7i3gnpf3d21gfb6nw";
+    sha256 = "0af3fwiixddds6gdwhkyq3l214mmjl2wpjc2qayp5rpz79lnclq3";
   };
   buildInputs = [
     fuse bison flex_2_5_35 openssl ncurses readline
@@ -70,10 +70,13 @@ rec {
   '';
 
   patches = [
+    # Remove when https://bugzilla.redhat.com/show_bug.cgi?id=1450546 is fixed
     ./glusterfs-use-PATH-instead-of-hardcodes.patch
+    # Remove when https://bugzilla.redhat.com/show_bug.cgi?id=1450593 is fixed
     ./glusterfs-python-remove-find_library.patch
     # Remove when https://bugzilla.redhat.com/show_bug.cgi?id=1489610 is fixed
     ./glusterfs-fix-bug-1489610-glusterfind-var-data-under-prefix.patch
+    # Remove when https://bugzilla.redhat.com/show_bug.cgi?id=1559130 is fixed
     ./glusterfs-glusterfind-log-remote-node_cmd-error.patch
   ];
 
diff --git a/pkgs/tools/filesystems/glusterfs/glusterfs-python-remove-find_library.patch b/pkgs/tools/filesystems/glusterfs/glusterfs-python-remove-find_library.patch
index 6dd1baad5dff..4757f2fce771 100644
--- a/pkgs/tools/filesystems/glusterfs/glusterfs-python-remove-find_library.patch
+++ b/pkgs/tools/filesystems/glusterfs/glusterfs-python-remove-find_library.patch
@@ -1,21 +1,23 @@
-From d321df349d10f038f0c89b9c11f8059572264f1b Mon Sep 17 00:00:00 2001
+From e6293e367f56833457291e32a4df7b21a52365a7 Mon Sep 17 00:00:00 2001
 From: =?UTF-8?q?Niklas=20Hamb=C3=BCchen?= <mail@nh2.me>
 Date: Sat, 13 May 2017 18:54:36 +0200
 Subject: [PATCH] python: Remove all uses of find_library. Fixes #1450593
 
 `find_library()` doesn't consider LD_LIBRARY_PATH on Python < 3.6.
+
+Change-Id: Iee26085cb5d14061001f19f032c2664d69a378a8
 ---
  api/examples/getvolfile.py                                     |  2 +-
  geo-replication/syncdaemon/libcxattr.py                        |  3 +--
- geo-replication/syncdaemon/libgfchangelog.py                   |  3 +--
+ geo-replication/syncdaemon/libgfchangelog.py                   |  6 ++----
  tests/features/ipctest.py                                      | 10 ++--------
  tests/utils/libcxattr.py                                       |  5 ++---
  tools/glusterfind/src/libgfchangelog.py                        |  3 +--
  .../features/changelog/lib/examples/python/libgfchangelog.py   |  3 +--
- 7 files changed, 9 insertions(+), 20 deletions(-)
+ 7 files changed, 10 insertions(+), 22 deletions(-)
 
 diff --git a/api/examples/getvolfile.py b/api/examples/getvolfile.py
-index 0c95213..32c2268 100755
+index 0c95213f0..32c2268b3 100755
 --- a/api/examples/getvolfile.py
 +++ b/api/examples/getvolfile.py
 @@ -3,7 +3,7 @@
@@ -28,7 +30,7 @@ index 0c95213..32c2268 100755
                                   ctypes.c_void_p,
                                   ctypes.c_ulong]
 diff --git a/geo-replication/syncdaemon/libcxattr.py b/geo-replication/syncdaemon/libcxattr.py
-index 3671e10..f576648 100644
+index 3671e102c..f576648b7 100644
 --- a/geo-replication/syncdaemon/libcxattr.py
 +++ b/geo-replication/syncdaemon/libcxattr.py
 @@ -10,7 +10,6 @@
@@ -49,25 +51,28 @@ index 3671e10..f576648 100644
      @classmethod
      def geterrno(cls):
 diff --git a/geo-replication/syncdaemon/libgfchangelog.py b/geo-replication/syncdaemon/libgfchangelog.py
-index d87b56c..003c28c 100644
+index 334f5e9ea..093ae157a 100644
 --- a/geo-replication/syncdaemon/libgfchangelog.py
 +++ b/geo-replication/syncdaemon/libgfchangelog.py
-@@ -10,12 +10,11 @@
+@@ -9,14 +9,12 @@
+ #
  
  import os
- from ctypes import CDLL, RTLD_GLOBAL, create_string_buffer, get_errno, byref, c_ulong
+-from ctypes import CDLL, RTLD_GLOBAL, create_string_buffer, \
+-    get_errno, byref, c_ulong
 -from ctypes.util import find_library
++from ctypes import CDLL, RTLD_GLOBAL, create_string_buffer, get_errno, byref, c_ulong
  from syncdutils import ChangelogException, ChangelogHistoryNotAvailable
  
  
  class Changes(object):
--    libgfc = CDLL(find_library("gfchangelog"), mode=RTLD_GLOBAL, use_errno=True)
-+    libgfc = CDLL("libgfchangelog.so", mode=RTLD_GLOBAL, use_errno=True)
+-    libgfc = CDLL(find_library("gfchangelog"), mode=RTLD_GLOBAL,
++    libgfc = CDLL("libgfchangelog.so", mode=RTLD_GLOBAL,
+                   use_errno=True)
  
      @classmethod
-     def geterrno(cls):
 diff --git a/tests/features/ipctest.py b/tests/features/ipctest.py
-index 5aff319..9339248 100755
+index 5aff319b8..933924861 100755
 --- a/tests/features/ipctest.py
 +++ b/tests/features/ipctest.py
 @@ -1,14 +1,8 @@
@@ -88,7 +93,7 @@ index 5aff319..9339248 100755
  api.glfs_ipc.argtypes = [ ctypes.c_void_p, ctypes.c_int, ctypes.c_void_p, ctypes.c_void_p ]
  api.glfs_ipc.restype = ctypes.c_int
 diff --git a/tests/utils/libcxattr.py b/tests/utils/libcxattr.py
-index 149db72..4e6e6c4 100644
+index 149db72e6..4e6e6c46d 100644
 --- a/tests/utils/libcxattr.py
 +++ b/tests/utils/libcxattr.py
 @@ -11,7 +11,6 @@
@@ -112,10 +117,10 @@ index 149db72..4e6e6c4 100644
      @classmethod
      def geterrno(cls):
 diff --git a/tools/glusterfind/src/libgfchangelog.py b/tools/glusterfind/src/libgfchangelog.py
-index dd8153e..da822cf 100644
+index 0f6b40d6c..9ca3f326b 100644
 --- a/tools/glusterfind/src/libgfchangelog.py
 +++ b/tools/glusterfind/src/libgfchangelog.py
-@@ -12,14 +12,13 @@
+@@ -11,14 +11,13 @@
  import os
  from ctypes import CDLL, get_errno, create_string_buffer, c_ulong, byref
  from ctypes import RTLD_GLOBAL
@@ -132,7 +137,7 @@ index dd8153e..da822cf 100644
  
  def raise_oserr():
 diff --git a/xlators/features/changelog/lib/examples/python/libgfchangelog.py b/xlators/features/changelog/lib/examples/python/libgfchangelog.py
-index 10e73c0..2cdbf11 100644
+index 10e73c02b..2cdbf1152 100644
 --- a/xlators/features/changelog/lib/examples/python/libgfchangelog.py
 +++ b/xlators/features/changelog/lib/examples/python/libgfchangelog.py
 @@ -1,9 +1,8 @@
@@ -147,5 +152,5 @@ index 10e73c0..2cdbf11 100644
      @classmethod
      def geterrno(cls):
 -- 
-2.7.4
+2.12.0
 
diff --git a/pkgs/tools/inputmethods/libinput-gestures/default.nix b/pkgs/tools/inputmethods/libinput-gestures/default.nix
index 77eae2c55e1d..75670dfe9dfb 100644
--- a/pkgs/tools/inputmethods/libinput-gestures/default.nix
+++ b/pkgs/tools/inputmethods/libinput-gestures/default.nix
@@ -5,14 +5,14 @@
 }:
 stdenv.mkDerivation rec {
   pname = "libinput-gestures";
-  version = "2.38";
+  version = "2.39";
   name = "${pname}-${version}";
 
   src = fetchFromGitHub {
     owner = "bulletmark";
     repo = "libinput-gestures";
     rev = version;
-    sha256 = "1nxvlifag04v56grdwxc3l92kmf51c4w2lq42a3w76yc6p4nxw1m";
+    sha256 = "0bzyi55yhr9wyar9mnd09cr6pi88jkkp0f9lndm0a9jwi1xr4bdf";
   };
   patches = [
     ./0001-hardcode-name.patch
diff --git a/pkgs/tools/misc/bdf2psf/default.nix b/pkgs/tools/misc/bdf2psf/default.nix
index c9775ac6ae35..ac6f8c97c7b6 100644
--- a/pkgs/tools/misc/bdf2psf/default.nix
+++ b/pkgs/tools/misc/bdf2psf/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "bdf2psf-${version}";
-  version = "1.185";
+  version = "1.187";
 
   src = fetchurl {
     url = "mirror://debian/pool/main/c/console-setup/bdf2psf_${version}_all.deb";
-    sha256 = "0i8ppqj6yhdkvjkwfl588f2zpaybj61pq64bhlnmc8c4snwpn1z6";
+    sha256 = "05r5jg7n4hbdxcy3kc7038h1r0fkipwld6kd0d49nbkmywl2k1a8";
   };
 
   buildInputs = [ dpkg ];
diff --git a/pkgs/tools/misc/debootstrap/default.nix b/pkgs/tools/misc/debootstrap/default.nix
index 9c3db47213ec..1b2cdf0402ae 100644
--- a/pkgs/tools/misc/debootstrap/default.nix
+++ b/pkgs/tools/misc/debootstrap/default.nix
@@ -15,13 +15,13 @@ let binPath = stdenv.lib.makeBinPath [
   ];
 in stdenv.mkDerivation rec {
   name = "debootstrap-${version}";
-  version = "1.0.109";
+  version = "1.0.110";
 
   src = fetchurl {
     # git clone git://git.debian.org/d-i/debootstrap.git
     # I'd like to use the source. However it's lacking the lanny script ? (still true?)
     url = "mirror://debian/pool/main/d/debootstrap/debootstrap_${version}.tar.gz";
-    sha256 = "117xgrv6mpszyndmsvkn4ynh57b2s40qc68bpmfmxggw58j42klw";
+    sha256 = "11bqy2dbqsy9fyx1i6lj0aj1pvq15y8kkwjfrp18k3nvy74y80ca";
   };
 
   nativeBuildInputs = [ makeWrapper ];
diff --git a/pkgs/tools/misc/doitlive/default.nix b/pkgs/tools/misc/doitlive/default.nix
index a8ff34af9757..d322a19c98a3 100644
--- a/pkgs/tools/misc/doitlive/default.nix
+++ b/pkgs/tools/misc/doitlive/default.nix
@@ -2,11 +2,11 @@
 
 python3Packages.buildPythonApplication rec {
   pname = "doitlive";
-  version = "4.0.1";
+  version = "4.1.0";
 
   src = python3Packages.fetchPypi {
     inherit pname version;
-    sha256 = "1icnjkczy52i3cp1fmsijqny571fz1h4b3wpdzz79cn90fr326pc";
+    sha256 = "0zkvmnv6adz0gyqiql8anpxnh8zzpqk0p2n0pf2kxy55010qs4wz";
   };
 
   propagatedBuildInputs = with python3Packages; [ click click-completion click-didyoumean ];
diff --git a/pkgs/tools/misc/fwup/default.nix b/pkgs/tools/misc/fwup/default.nix
index 97eedd9be25e..160ea2faab61 100644
--- a/pkgs/tools/misc/fwup/default.nix
+++ b/pkgs/tools/misc/fwup/default.nix
@@ -4,13 +4,13 @@
 
 stdenv.mkDerivation rec {
   name = "fwup-${version}";
-  version = "1.2.5";
+  version = "1.2.6";
 
   src = fetchFromGitHub {
     owner = "fhunleth";
     repo = "fwup";
     rev = "v${version}";
-    sha256 = "0kraip4lr3fvcxvvq1dwjw7fyzs6bcjg14xn0g52985krxxn5pdc";
+    sha256 = "1rbpa0dcm9w1anz2bhcpmj2b678807s8j43zzkbkwh71aymfwr14";
   };
 
   doCheck = true;
diff --git a/pkgs/tools/misc/hebcal/default.nix b/pkgs/tools/misc/hebcal/default.nix
index da231c16cc90..edb5973fbb70 100644
--- a/pkgs/tools/misc/hebcal/default.nix
+++ b/pkgs/tools/misc/hebcal/default.nix
@@ -1,14 +1,14 @@
 { stdenv, fetchFromGitHub, autoreconfHook }:
 
 stdenv.mkDerivation rec {
-  version = "4.14";
+  version = "4.15";
   name = "hebcal-${version}";
 
   src = fetchFromGitHub {
     owner = "hebcal";
     repo = "hebcal";
     rev = "v${version}";
-    sha256 = "1zq8f7cigh5r31p03az338sbygkx8gbday35c9acppglci3r8fvc";
+    sha256 = "1s9iardqyzn42hs0x9p4rig2m87v87jvzcrbb9arcci7nds66y3i";
   };
 
   nativeBuildInputs = [ autoreconfHook ];
diff --git a/pkgs/tools/misc/noti/default.nix b/pkgs/tools/misc/noti/default.nix
index 23646abe7875..43165b4f54bb 100644
--- a/pkgs/tools/misc/noti/default.nix
+++ b/pkgs/tools/misc/noti/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, buildGoPackage, fetchFromGitHub, Cocoa }:
+{ stdenv, buildGoPackage, fetchFromGitHub, cf-private, Cocoa }:
 
 buildGoPackage rec {
   name = "noti-${version}";
@@ -11,7 +11,7 @@ buildGoPackage rec {
     sha256 = "1chsqfqk0pnhx5k2nr4c16cpb8m6zv69l1jvv4v4903zgfzcm823";
   };
 
-  buildInputs = stdenv.lib.optionals stdenv.isDarwin [ Cocoa ];
+  buildInputs = stdenv.lib.optionals stdenv.isDarwin [ Cocoa cf-private /* For OBJC_CLASS_$_NSDate */ ];
   # TODO: Remove this when we update apple_sdk
   NIX_CFLAGS_COMPILE = stdenv.lib.optionals stdenv.isDarwin [ "-fno-objc-arc" ];
 
diff --git a/pkgs/tools/misc/up/default.nix b/pkgs/tools/misc/up/default.nix
new file mode 100644
index 000000000000..c09c5ad12f08
--- /dev/null
+++ b/pkgs/tools/misc/up/default.nix
@@ -0,0 +1,23 @@
+{ lib, buildGoPackage, fetchFromGitHub }:
+
+buildGoPackage rec {
+  name = "up-${version}";
+  version = "0.3.1";
+
+  src = fetchFromGitHub {
+    owner = "akavel";
+    repo = "up";
+    rev = "v${version}";
+    sha256 = "171bwbk2c7jbi51xdawzv7qy71492mfs9z5j0a5j52qmnr4vjjgs";
+  };
+
+  goPackagePath = "github.com/akavel/up";
+  goDeps = ./deps.nix;
+
+  meta = with lib; {
+    description = "Ultimate Plumber is a tool for writing Linux pipes with instant live preview";
+    homepage = https://github.com/akavel/up;
+    maintainers = with maintainers; [ ma27 ];
+    license = licenses.asl20;
+  };
+}
diff --git a/pkgs/tools/misc/up/deps.nix b/pkgs/tools/misc/up/deps.nix
new file mode 100644
index 000000000000..439dc5df9d4d
--- /dev/null
+++ b/pkgs/tools/misc/up/deps.nix
@@ -0,0 +1,66 @@
+# This file was generated by https://github.com/kamilchm/go2nix v1.2.1
+[
+  {
+    goPackagePath = "github.com/gdamore/encoding";
+    fetch = {
+      type = "git";
+      url = "https://github.com/gdamore/encoding";
+      rev = "b23993cbb6353f0e6aa98d0ee318a34728f628b9";
+      sha256 = "0d7irqpx2fa9vkxgkhf04yiwazsm10fxh0yk86x5crflhph5fv8a";
+    };
+  }
+  {
+    goPackagePath = "github.com/gdamore/tcell";
+    fetch = {
+      type = "git";
+      url = "https://github.com/gdamore/tcell";
+      rev = "017915a4d77dabd7af10ab539e618a735d4b9c0a";
+      sha256 = "19ymkgcvcp9sz2jrfi7h6l720w5yw9hy3wnw975w2ih45j1ypqdh";
+    };
+  }
+  {
+    goPackagePath = "github.com/lucasb-eyer/go-colorful";
+    fetch = {
+      type = "git";
+      url = "https://github.com/lucasb-eyer/go-colorful";
+      rev = "12d3b2882a08d1abc9488e34f3e1ae35165f2d07";
+      sha256 = "1w95axfn1a6rz31xrks77ingr9mdkqyr7mh0glv664kz1wg2h0gw";
+    };
+  }
+  {
+    goPackagePath = "github.com/mattn/go-isatty";
+    fetch = {
+      type = "git";
+      url = "https://github.com/mattn/go-isatty";
+      rev = "3fb116b820352b7f0c281308a4d6250c22d94e27";
+      sha256 = "084hplr4n4g5nvp70clljk428hc963460xz0ggcj3xdi4w7hhsvv";
+    };
+  }
+  {
+    goPackagePath = "github.com/mattn/go-runewidth";
+    fetch = {
+      type = "git";
+      url = "https://github.com/mattn/go-runewidth";
+      rev = "b20a3daf6a39840c202fd42cc23d53607162b045";
+      sha256 = "0crivpncmh22696d5cy7k15ll5yqfjcigk0xy73wb6g1q6vnfxs7";
+    };
+  }
+  {
+    goPackagePath = "github.com/spf13/pflag";
+    fetch = {
+      type = "git";
+      url = "https://github.com/spf13/pflag";
+      rev = "aea12ed6721610dc6ed40141676d7ab0a1dac9e9";
+      sha256 = "17p5k37bnzj6wfh000y7xpvxyv2wsfa3db9sm8da2frjvn7jgbp2";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/text";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/text";
+      rev = "6f44c5a2ea40ee3593d98cdcc905cc1fdaa660e2";
+      sha256 = "00mwzxly5isgf0glz7k3k2dkyqkjfc4z55qxajx4lgcp3h8xn9xj";
+    };
+  }
+]
diff --git a/pkgs/tools/networking/getmail/default.nix b/pkgs/tools/networking/getmail/default.nix
index 56b7320a1b26..db1f383ac026 100644
--- a/pkgs/tools/networking/getmail/default.nix
+++ b/pkgs/tools/networking/getmail/default.nix
@@ -2,11 +2,11 @@
 
 python2Packages.buildPythonApplication rec {
   pname = "getmail";
-  version = "5.7";
+  version = "5.8";
 
   src = fetchurl {
     url = "http://pyropus.ca/software/getmail/old-versions/${pname}-${version}.tar.gz";
-    sha256 = "1ygv78ihjyrh60657bl8pc17a5dqawdkfh32h8hrd4kwwxlsd5r4";
+    sha256 = "0vl4cc733pd9d21y4pr4jc1ly657d0akxj1bdh1xfjggx33l3541";
   };
 
   doCheck = false;
diff --git a/pkgs/tools/security/eid-mw/default.nix b/pkgs/tools/security/eid-mw/default.nix
index cc61cce463ce..637d2af9ae31 100644
--- a/pkgs/tools/security/eid-mw/default.nix
+++ b/pkgs/tools/security/eid-mw/default.nix
@@ -7,10 +7,10 @@
 
 stdenv.mkDerivation rec {
   name = "eid-mw-${version}";
-  version = "4.4.8";
+  version = "4.4.9";
 
   src = fetchFromGitHub {
-    sha256 = "0khpkpfnbin46aqnb9xkhh5d89lvsshgp4kqpdgk95l73lx8kdqp"; 
+    sha256 = "019cfxgffl6z6ilz1w6b531dr8pi63ikflxmkc95glh7cxsaylax"; 
     rev = "v${version}";
     repo = "eid-mw";
     owner = "Fedict";
diff --git a/pkgs/tools/security/keybase/default.nix b/pkgs/tools/security/keybase/default.nix
index 555244bc38cd..720c382ebd67 100644
--- a/pkgs/tools/security/keybase/default.nix
+++ b/pkgs/tools/security/keybase/default.nix
@@ -1,6 +1,7 @@
-{ stdenv, lib, buildGoPackage, fetchFromGitHub
-, AVFoundation ? null, AudioToolbox ? null, ImageIO ? null, CoreMedia ? null
-, Foundation ? null, CoreGraphics ? null, MediaToolbox ? null }:
+{ stdenv, lib, buildGoPackage, fetchFromGitHub, cf-private
+, AVFoundation, AudioToolbox, ImageIO, CoreMedia
+, Foundation, CoreGraphics, MediaToolbox
+}:
 
 buildGoPackage rec {
   name = "keybase-${version}";
@@ -18,7 +19,11 @@ buildGoPackage rec {
     sha256 = "1sw6v3vf544vp8grw8p287cx078mr9v0v1wffcj6f9p9shlwj7ic";
   };
 
-  buildInputs = lib.optionals stdenv.isDarwin [ AVFoundation AudioToolbox ImageIO CoreMedia Foundation CoreGraphics MediaToolbox ];
+  buildInputs = lib.optionals stdenv.isDarwin [
+    AVFoundation AudioToolbox ImageIO CoreMedia Foundation CoreGraphics MediaToolbox
+    # Needed for OBJC_CLASS_$_NSData symbols.
+    cf-private
+  ];
   buildFlags = [ "-tags production" ];
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/security/lynis/default.nix b/pkgs/tools/security/lynis/default.nix
index ad345afb5fcc..46c2e6f03b0d 100644
--- a/pkgs/tools/security/lynis/default.nix
+++ b/pkgs/tools/security/lynis/default.nix
@@ -1,29 +1,26 @@
-{ stdenv, makeWrapper, fetchFromGitHub, gawk, perl }:
+{ stdenv, makeWrapper, fetchFromGitHub, gawk }:
 
 stdenv.mkDerivation rec {
   pname = "lynis";
-  version = "2.6.9";
+  version = "2.7.0";
   name = "${pname}-${version}";
 
   src = fetchFromGitHub {
     owner = "CISOfy";
     repo = "${pname}";
     rev = "${version}";
-    sha256 = "125p5vpc2ksn0nab8y4ckfgx13rlv3w95amgighiqkh15ccji5kq";
+    sha256 = "0rzc0y8lk22bymf56249jzmllki2lh0rz5in4lkrc5fkmp29c2wv";
   };
 
-  nativeBuildInputs = [ makeWrapper perl ];
+  nativeBuildInputs = [ makeWrapper ];
 
   postPatch = ''
     grep -rl '/usr/local/lynis' ./ | xargs sed -i "s@/usr/local/lynis@$out/share/lynis@g"
-    # Don't use predefined binary paths. See https://github.com/CISOfy/lynis/issues/468
-    perl -i -p0e 's/BIN_PATHS="[^"]*"/BIN_PATHS=\$\(echo \$PATH\ | sed "s\/:\/ \/g")/sm;' include/consts
   '';
 
   installPhase = ''
-    mkdir -p $out/share/lynis
+    install -d $out/bin $out/share/lynis/plugins
     cp -r include db default.prf $out/share/lynis/
-    mkdir -p $out/bin
     cp -a lynis $out/bin
     wrapProgram "$out/bin/lynis" --prefix PATH : ${stdenv.lib.makeBinPath [ gawk ]}
   '';
diff --git a/pkgs/tools/system/acpica-tools/default.nix b/pkgs/tools/system/acpica-tools/default.nix
index 54303d0c177d..5bc8c7d945bd 100644
--- a/pkgs/tools/system/acpica-tools/default.nix
+++ b/pkgs/tools/system/acpica-tools/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "acpica-tools-${version}";
-  version = "20180927";
+  version = "20181031";
 
   src = fetchurl {
     url = "https://acpica.org/sites/acpica/files/acpica-unix-${version}.tar.gz";
-    sha256 = "1c9d505mw1wyga65y4nmiz55gs357z97wnycx77yvjwvi08qsh6w";
+    sha256 = "1zz1lfrl1rihs47a0cirdp32p53297kjm0l27b4kvibb5b7pa3h9";
   };
 
   NIX_CFLAGS_COMPILE = "-O3";
diff --git a/pkgs/tools/system/facter/default.nix b/pkgs/tools/system/facter/default.nix
index ba21fabe4350..dd2340668c49 100644
--- a/pkgs/tools/system/facter/default.nix
+++ b/pkgs/tools/system/facter/default.nix
@@ -2,10 +2,10 @@
 
 stdenv.mkDerivation rec {
   name = "facter-${version}";
-  version = "3.12.0";
+  version = "3.12.1";
 
   src = fetchFromGitHub {
-    sha256 = "1bg044j3dv6kcksy3cyda650ara8s4awdf665k10gaaxa0gwn0jj";
+    sha256 = "08mhsf9q9mhjfdzn8qkm12i1k5l7fnm6hqx6rqr8ni5iprl73b3d";
     rev = version;
     repo = "facter";
     owner = "puppetlabs";
diff --git a/pkgs/tools/system/fio/default.nix b/pkgs/tools/system/fio/default.nix
index c0210127d9f2..8e9fb6da5400 100644
--- a/pkgs/tools/system/fio/default.nix
+++ b/pkgs/tools/system/fio/default.nix
@@ -4,13 +4,13 @@
 
 stdenv.mkDerivation rec {
   name = "fio-${version}";
-  version = "3.11";
+  version = "3.12";
 
   src = fetchFromGitHub {
     owner  = "axboe";
     repo   = "fio";
     rev    = "fio-${version}";
-    sha256 = "0k5hja50qmz6qwm8h7z00zdgxhf1vg1g168jinqzn1521fihvlvz";
+    sha256 = "18awz03mdzdbja1n9nm6jyvv7ic2dabh6c7ip5vwpam8c6mj4yjq";
   };
 
   buildInputs = [ python zlib ]
diff --git a/pkgs/tools/text/aha/default.nix b/pkgs/tools/text/aha/default.nix
index 89319ac492f4..f53a649cd771 100644
--- a/pkgs/tools/text/aha/default.nix
+++ b/pkgs/tools/text/aha/default.nix
@@ -2,10 +2,10 @@
 
 stdenv.mkDerivation rec {
   name = "aha-${version}";
-  version = "0.4.10.6";
+  version = "0.5";
 
   src = fetchFromGitHub {
-    sha256 = "18mz3f5aqw4vbdrxf8wblqm6nca73ppq9hb2z2ppw6k0557i71kz";
+    sha256 = "0byml4rmpiaalwx69jcixl3yvpvwmwiss1jzgsqwshilb2p4qnmz";
     rev = version;
     repo = "aha";
     owner = "theZiz";
diff --git a/pkgs/tools/text/ansifilter/default.nix b/pkgs/tools/text/ansifilter/default.nix
index 3e9511fefdaa..54591bf24424 100644
--- a/pkgs/tools/text/ansifilter/default.nix
+++ b/pkgs/tools/text/ansifilter/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "ansifilter-${version}";
-  version = "2.10";
+  version = "2.12";
 
   src = fetchurl {
     url = "http://www.andre-simon.de/zip/ansifilter-${version}.tar.bz2";
-    sha256 = "0gzfxfpic47cs2kqrbvaw166ji62c5nq5cjhh3ngpm2fkm1wzli3";
+    sha256 = "0ssvc51x90l1s9pxdxaw6ba01dcalrp0b5glrnh1j43i2pskc750";
 
   };
 
diff --git a/pkgs/tools/text/fanficfare/default.nix b/pkgs/tools/text/fanficfare/default.nix
index 1dec03e985b3..3315d435afbb 100644
--- a/pkgs/tools/text/fanficfare/default.nix
+++ b/pkgs/tools/text/fanficfare/default.nix
@@ -1,13 +1,13 @@
 { stdenv, fetchurl, python27Packages }:
 
 python27Packages.buildPythonApplication rec {
-  version = "3.0.0";
+  version = "3.1.1";
   name = "fanficfare-${version}";
   nameprefix = "";
 
   src = fetchurl {
     url = "https://github.com/JimmXinu/FanFicFare/archive/v${version}.tar.gz";
-    sha256 = "0m8p1nn4621fspcas4g4k8y6fnnlzn7kxjxw2fapdrk3cz1pgi69";
+    sha256 = "1wklii24vbvq2vi5pqgp3z4lazcplh2i7r2w4d8lkm6pzbw0s8px";
   };
 
   propagatedBuildInputs = with python27Packages; [ beautifulsoup4 chardet html5lib html2text ];
diff --git a/pkgs/tools/text/hyx/default.nix b/pkgs/tools/text/hyx/default.nix
index 1ba3534e3f8a..70745266fe55 100644
--- a/pkgs/tools/text/hyx/default.nix
+++ b/pkgs/tools/text/hyx/default.nix
@@ -1,13 +1,15 @@
 { lib, stdenv, fetchurl }:
 
 stdenv.mkDerivation rec {
-  name = "hyx-0.1.4";
+  name = "hyx-0.1.5";
 
   src = fetchurl {
     url = "https://yx7.cc/code/hyx/${name}.tar.xz";
-    sha256 = "049r610hyrrfa62vpiqyb3rh99bpy8cnqy4nd4sih01733cmdhyx";
+    sha256 = "0gd8fbdyw12jwffa5dgcql4ry22xbdhqdds1qwzk1rkcrkgnc1mg";
   };
 
+  patches = [ ./no-wall-by-default.patch ];
+
   installPhase = ''
     install -vD hyx $out/bin/hyx
   '';
@@ -17,6 +19,6 @@ stdenv.mkDerivation rec {
     homepage = https://yx7.cc/code/;
     license = licenses.mit;
     maintainers = with maintainers; [ fpletz ];
-    platforms = platforms.all;
+    platforms = platforms.linux;
   };
 }
diff --git a/pkgs/tools/text/hyx/no-wall-by-default.patch b/pkgs/tools/text/hyx/no-wall-by-default.patch
new file mode 100644
index 000000000000..48ee20eff179
--- /dev/null
+++ b/pkgs/tools/text/hyx/no-wall-by-default.patch
@@ -0,0 +1,11 @@
+--- hyx-0.1.5.org/Makefile	2018-06-02 17:14:37.000000000 +0100
++++ hyx-0.1.5/Makefile	2018-11-10 09:25:49.569961762 +0000
+@@ -1,7 +1,7 @@
+ 
+ all: CFLAGS ?= -O2 -Wl,-s \
+                -Wl,-z,relro,-z,now -fpic -pie -D_FORTIFY_SOURCE=2 -fstack-protector-all
+-all: CFLAGS += -std=c99 -pedantic -Wall -Wextra -DNDEBUG
++all: CFLAGS += -std=c99 -DNDEBUG
+ all: hyx
+ 
+ debug: CFLAGS ?= -O0 -g \
diff --git a/pkgs/tools/virtualization/google-compute-engine/default.nix b/pkgs/tools/virtualization/google-compute-engine/default.nix
index c0b9954206ad..5ddf15e09fad 100644
--- a/pkgs/tools/virtualization/google-compute-engine/default.nix
+++ b/pkgs/tools/virtualization/google-compute-engine/default.nix
@@ -11,14 +11,14 @@
 
 buildPythonApplication rec {
   name = "google-compute-engine-${version}";
-  version = "20180905";
+  version = "20181011";
   namePrefix = "";
 
   src = fetchFromGitHub {
     owner = "GoogleCloudPlatform";
     repo = "compute-image-packages";
     rev = version;
-    sha256 = "0095f000kgk2lc5p1y4080sbc0r7ly60a7i9id8hydfnkhqqz75n";
+    sha256 = "1b3wyr412qh113xvs671dqnacidil61gisfvg79wbq6wrdwswkp8";
   };
 
   postPatch = ''