about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorkashw2 <supra4keanu@hotmail.com>2023-12-01 20:04:03 +1000
committerkashw2 <supra4keanu@hotmail.com>2023-12-03 09:58:27 +1000
commit77b73675647ac03bff94068ddfa1136dbb614a67 (patch)
tree2dfc3abb1fc943528eda2e38e5d2ade67b1d433b /pkgs/tools
parentd71187cf338e837642a46e143b42559c03f835df (diff)
downloadnixlib-77b73675647ac03bff94068ddfa1136dbb614a67.tar
nixlib-77b73675647ac03bff94068ddfa1136dbb614a67.tar.gz
nixlib-77b73675647ac03bff94068ddfa1136dbb614a67.tar.bz2
nixlib-77b73675647ac03bff94068ddfa1136dbb614a67.tar.lz
nixlib-77b73675647ac03bff94068ddfa1136dbb614a67.tar.xz
nixlib-77b73675647ac03bff94068ddfa1136dbb614a67.tar.zst
nixlib-77b73675647ac03bff94068ddfa1136dbb614a67.zip
grype: 0.69.1 -> 0.73.4
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/grype/default.nix10
1 files changed, 7 insertions, 3 deletions
diff --git a/pkgs/tools/security/grype/default.nix b/pkgs/tools/security/grype/default.nix
index ff996562572b..db955a1a2086 100644
--- a/pkgs/tools/security/grype/default.nix
+++ b/pkgs/tools/security/grype/default.nix
@@ -7,13 +7,13 @@
 
 buildGoModule rec {
   pname = "grype";
-  version = "0.69.1";
+  version = "0.73.4";
 
   src = fetchFromGitHub {
     owner = "anchore";
     repo = pname;
     rev = "refs/tags/v${version}";
-    hash = "sha256-AXw2mtN4FC6EKWN8dObrU04+WSHDWLY19FSWqQlkq/Q=";
+    hash = "sha256-cYhgLMKj8fo49zr+NC7SARiyybCnqXf+DgB+6IkwkAw=";
     # populate values that require us to use git. By doing this in postFetch we
     # can delete .git afterwards and maintain better reproducibility of the src.
     leaveDotGit = true;
@@ -28,7 +28,7 @@ buildGoModule rec {
 
   proxyVendor = true;
 
-  vendorHash = "sha256-iitWThvWVfeJMLcJLgmFnVguFVF4DejObZPZ3qB5cY0=";
+  vendorHash = "sha256-Zx8gJZVkobKjrGysrqYd6Hv2bGqEgOQ+EGSKDvOM33M=";
 
   nativeBuildInputs = [
     installShellFiles
@@ -73,6 +73,8 @@ buildGoModule rec {
       --replace "TestCmd" "SkipCmd"
     substituteInPlace grype/pkg/provider_test.go \
       --replace "TestSyftLocationExcludes" "SkipSyftLocationExcludes"
+    substituteInPlace test/cli/cmd_test.go \
+      --replace "Test_descriptorNameAndVersionSet" "Skip_descriptorNameAndVersionSet"
     # remove tests that depend on git
     substituteInPlace test/cli/db_validations_test.go \
       --replace "TestDBValidations" "SkipDBValidations"
@@ -83,6 +85,8 @@ buildGoModule rec {
       --replace "TestSBOMInput_AsArgument" "SkipSBOMInput_AsArgument"
     substituteInPlace test/cli/subprocess_test.go \
       --replace "TestSubprocessStdin" "SkipSubprocessStdin"
+    substituteInPlace grype/internal/packagemetadata/names_test.go \
+      --replace "TestAllNames" "SkipAllNames"
 
     # segfault
     rm grype/db/v5/namespace/cpe/namespace_test.go