about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2020-04-22 14:50:32 +0100
committerJörg Thalheim <joerg@thalheim.io>2020-04-28 09:44:55 +0100
commit72773b9c975de70ada208d3a62c2a8e1a707e24d (patch)
tree63694d869537900396419878855b34bdfc2a51da /pkgs/tools
parent2cd07f1f187ca6cf8cba4ea23543a53b4ea391fa (diff)
downloadnixlib-72773b9c975de70ada208d3a62c2a8e1a707e24d.tar
nixlib-72773b9c975de70ada208d3a62c2a8e1a707e24d.tar.gz
nixlib-72773b9c975de70ada208d3a62c2a8e1a707e24d.tar.bz2
nixlib-72773b9c975de70ada208d3a62c2a8e1a707e24d.tar.lz
nixlib-72773b9c975de70ada208d3a62c2a8e1a707e24d.tar.xz
nixlib-72773b9c975de70ada208d3a62c2a8e1a707e24d.tar.zst
nixlib-72773b9c975de70ada208d3a62c2a8e1a707e24d.zip
prey-bash-client: remove
prey-bash-client is deprecated since 2018
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/prey/default.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/pkgs/tools/security/prey/default.nix b/pkgs/tools/security/prey/default.nix
deleted file mode 100644
index c66756012311..000000000000
--- a/pkgs/tools/security/prey/default.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-{ stdenv, fetchurl, fetchgit, curl, scrot, imagemagick, xawtv, inetutils, makeWrapper, coreutils
-, apiKey ? ""
-, deviceKey ? "" }:
-
-# TODO: this should assert keys are set, somehow if set through .override assertion fails
-#assert apiKey != "";
-#assert deviceKey != "";
-
-let
-  modulesSrc = fetchgit {
-    url = "git://github.com/prey/prey-bash-client-modules.git";
-    rev = "aba260ef110834cb2e92923a31f50c15970639ee";
-    sha256 = "9cb1ad813d052a0a3e3bbdd329a8711ae3272e340379489511f7dd578d911e30";
-  };
-in stdenv.mkDerivation rec {
-  pname = "prey-bash-client";
-  version = "0.6.0";
-
-  src = fetchurl {
-    url = "https://github.com/prey/prey-bash-client/archive/v${version}.tar.gz";
-    sha256 = "09cb15jh4jdwvix9nx048ajkw2r5jaflk68y3rkha541n8n0qwh0";
-  };
-
-  buildInputs = [ curl scrot imagemagick xawtv makeWrapper ];
-
-  phases = "unpackPhase installPhase";
-
-  installPhase = ''
-    substituteInPlace config --replace api_key=\'\' "api_key='${apiKey}'"
-    substituteInPlace config --replace device_key=\'\' "device_key='${deviceKey}'"
-
-    substituteInPlace prey.sh --replace /bin/bash $(type -Pp bash)
-    mkdir -p $out/modules
-    cp -R . $out
-    cp -R ${modulesSrc}/* $out/modules/
-    wrapProgram "$out/prey.sh" \
-      --prefix PATH ":" "${stdenv.lib.makeBinPath [ xawtv imagemagick curl scrot inetutils coreutils ]}" \
-      --set CURL_CA_BUNDLE "/etc/ssl/certs/ca-certificates.crt"
-  '';
-
-  meta = with stdenv.lib; {
-    homepage = "https://preyproject.com";
-    description = "Proven tracking software that helps you find, lock and recover your devices when stolen or missing";
-    maintainers = with maintainers; [ domenkozar ];
-    license = licenses.gpl3;
-    platforms = with platforms; linux;
-  };
-}