about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2022-03-07 15:16:41 +0000
committerAlyssa Ross <hi@alyssa.is>2022-03-07 15:16:56 +0000
commit6a5c5dc19a8c7e88618836051511d3a21068881d (patch)
tree6967b9bde26bc9ac2d60482b1751d603d3de0c0b /pkgs/tools
parentebaf33dd1ff8fc67b59629788f74d94b82db5442 (diff)
downloadnixlib-6a5c5dc19a8c7e88618836051511d3a21068881d.tar
nixlib-6a5c5dc19a8c7e88618836051511d3a21068881d.tar.gz
nixlib-6a5c5dc19a8c7e88618836051511d3a21068881d.tar.bz2
nixlib-6a5c5dc19a8c7e88618836051511d3a21068881d.tar.lz
nixlib-6a5c5dc19a8c7e88618836051511d3a21068881d.tar.xz
nixlib-6a5c5dc19a8c7e88618836051511d3a21068881d.tar.zst
nixlib-6a5c5dc19a8c7e88618836051511d3a21068881d.zip
seqouia: 0.25.0 -> 0.26.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/sequoia/default.nix15
1 files changed, 3 insertions, 12 deletions
diff --git a/pkgs/tools/security/sequoia/default.nix b/pkgs/tools/security/sequoia/default.nix
index 18db48dfb249..324af6aa4c99 100644
--- a/pkgs/tools/security/sequoia/default.nix
+++ b/pkgs/tools/security/sequoia/default.nix
@@ -25,16 +25,16 @@ rustPlatform.buildRustPackage rec {
   pname = "sequoia";
   # Upstream has separate version numbering for the library and the CLI frontend.
   # This derivation provides the CLI frontend, and thus uses its version number.
-  version = "0.25.0";
+  version = "0.26.0";
 
   src = fetchFromGitLab {
     owner = "sequoia-pgp";
     repo = "sequoia";
     rev = "sq/v${version}";
-    sha256 = "13f582g10vba0cpbdmqkkfzgd5jgagb640jaz1w425wf5nbh6q50";
+    sha256 = "1rcbv1s7wpxhrzw082q6vfrq1ja2ssfxn53c90h8fh5wrj7ns751";
   };
 
-  cargoSha256 = "sha256-qIGP48uj2iQ6MVgy5anKI9QrX9vnuKh46Fmmcczda4w=";
+  cargoSha256 = "0f3b8rh4pl03n8j9ihazaak214sv1rsksbgrb1nfcy8sq2yqfj4g";
 
   nativeBuildInputs = [
     pkg-config
@@ -77,15 +77,6 @@ rustPlatform.buildRustPackage rec {
   # Sometimes, tests fail on CI (ofborg) & hydra without this
   CARGO_TEST_ARGS = "--workspace --exclude sequoia-store";
 
-  # Without this, the examples won't build
-  postPatch = ''
-    substituteInPlace openpgp-ffi/examples/Makefile \
-      --replace '-O0 -g -Wall -Werror' '-g'
-    substituteInPlace ffi/examples/Makefile \
-      --replace '-O0 -g -Wall -Werror' '-g'
-  '';
-
-
   preInstall = lib.optionalString pythonSupport ''
     export installFlags="PYTHONPATH=$PYTHONPATH:$out/${pythonPackages.python.sitePackages}"
   '' + lib.optionalString (!pythonSupport) ''