about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorEric Seidel <github@eric.seidel.io>2015-05-14 10:09:07 -0700
committerEric Seidel <github@eric.seidel.io>2015-05-14 10:09:07 -0700
commit67fe5d46d4cd1c5383462bc136cd3c4ccc8cefc2 (patch)
tree6c8112d20949b5f77c9ede94a8019c3dc71ad7ed /pkgs/tools
parent221c45d51f3140a9c70bf465528d001da1fe1aa3 (diff)
parent662a6b1ca62b2e44115f6e29999f30896ddfa075 (diff)
downloadnixlib-67fe5d46d4cd1c5383462bc136cd3c4ccc8cefc2.tar
nixlib-67fe5d46d4cd1c5383462bc136cd3c4ccc8cefc2.tar.gz
nixlib-67fe5d46d4cd1c5383462bc136cd3c4ccc8cefc2.tar.bz2
nixlib-67fe5d46d4cd1c5383462bc136cd3c4ccc8cefc2.tar.lz
nixlib-67fe5d46d4cd1c5383462bc136cd3c4ccc8cefc2.tar.xz
nixlib-67fe5d46d4cd1c5383462bc136cd3c4ccc8cefc2.tar.zst
nixlib-67fe5d46d4cd1c5383462bc136cd3c4ccc8cefc2.zip
Merge pull request #7817 from gridaphobe/cc-wrapper-isgnu-isclang
Add isGNU and isClang attributes to cc-wrapper
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/atftp/default.nix2
-rw-r--r--pkgs/tools/security/tor/default.nix2
-rw-r--r--pkgs/tools/video/rtmpdump/default.nix2
3 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/tools/networking/atftp/default.nix b/pkgs/tools/networking/atftp/default.nix
index ad2d77f8cfef..eda7f7168760 100644
--- a/pkgs/tools/networking/atftp/default.nix
+++ b/pkgs/tools/networking/atftp/default.nix
@@ -1,6 +1,6 @@
 { lib, stdenv, fetchurl, readline, tcp_wrappers, pcre, makeWrapper }:
 assert stdenv.isLinux;
-assert stdenv.cc.cc.isGNU or false;
+assert stdenv.cc.isGNU;
 let
 version = "0.7";
 debianPatch = fetchurl {
diff --git a/pkgs/tools/security/tor/default.nix b/pkgs/tools/security/tor/default.nix
index 1237890f6214..603dd05fc659 100644
--- a/pkgs/tools/security/tor/default.nix
+++ b/pkgs/tools/security/tor/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
   # ./configure time check for any of this.
   buildInputs = [ libevent openssl zlib torsocks ];
 
-  CFLAGS = stdenv.lib.optionalString (stdenv.cc.cc.isGNU or false) "-lgcc_s";
+  CFLAGS = stdenv.lib.optionalString stdenv.cc.isGNU "-lgcc_s";
 
   # Patch 'torify' to point directly to torsocks.
   patchPhase = ''
diff --git a/pkgs/tools/video/rtmpdump/default.nix b/pkgs/tools/video/rtmpdump/default.nix
index 552023278b6a..de26cc41d744 100644
--- a/pkgs/tools/video/rtmpdump/default.nix
+++ b/pkgs/tools/video/rtmpdump/default.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
     ++ optional gnutlsSupport "CRYPTO=GNUTLS"
     ++ optional opensslSupport "CRYPTO=OPENSSL"
     ++ optional stdenv.isDarwin "SYS=darwin"
-    ++ optional (stdenv.cc.cc.isClang or false) "CC=clang";
+    ++ optional stdenv.cc.isClang "CC=clang";
 
   buildInputs = [ zlib ]
     ++ optional gnutlsSupport gnutls