about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-01-25 03:21:29 +0100
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-01-25 03:43:19 +0100
commit626c09bb46a877ad7aefa9a93467571ee3e8ed55 (patch)
tree3de40441da1195372e978a2185890ee93346191c /pkgs/tools
parent87df7fc7458edeb647770849a0dad526edbbea67 (diff)
downloadnixlib-626c09bb46a877ad7aefa9a93467571ee3e8ed55.tar
nixlib-626c09bb46a877ad7aefa9a93467571ee3e8ed55.tar.gz
nixlib-626c09bb46a877ad7aefa9a93467571ee3e8ed55.tar.bz2
nixlib-626c09bb46a877ad7aefa9a93467571ee3e8ed55.tar.lz
nixlib-626c09bb46a877ad7aefa9a93467571ee3e8ed55.tar.xz
nixlib-626c09bb46a877ad7aefa9a93467571ee3e8ed55.tar.zst
nixlib-626c09bb46a877ad7aefa9a93467571ee3e8ed55.zip
scanbd: init at 1.4.4
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/scanbd/default.nix57
1 files changed, 57 insertions, 0 deletions
diff --git a/pkgs/tools/graphics/scanbd/default.nix b/pkgs/tools/graphics/scanbd/default.nix
new file mode 100644
index 000000000000..b3fd986165a7
--- /dev/null
+++ b/pkgs/tools/graphics/scanbd/default.nix
@@ -0,0 +1,57 @@
+{ stdenv, fetchurl, pkgconfig
+, dbus, libconfuse, sane-backends, systemd }:
+
+stdenv.mkDerivation rec {
+  name = "scanbd-${version}";
+  version = "1.4.4";
+
+  src = fetchurl {
+    sha256 = "07a59jk9b2hh49v5lcpckp64f5lny9sq8h0h2p2jcs9cqazf6q9s";
+    url = "mirror://sourceforge/scanbd/${name}.tgz";
+  };
+
+  nativeBuildInputs = [ pkgconfig ];
+  buildInputs = [ dbus libconfuse sane-backends systemd ];
+
+  configureFlags = [
+    "--disable-Werror"
+    "--enable-udev"
+    "--with-scanbdconfdir=/etc/scanbd"
+    "--with-systemdsystemunitdir=$out/lib/systemd/system"
+  ];
+
+  enableParallelBuilding = true;
+
+  installFlags = [
+    "scanbdconfdir=$(out)/etc/scanbd"
+    "scannerconfdir=$(scanbdconfdir)/scanner.d"
+  ];
+
+  doCheck = true;
+
+  meta = with stdenv.lib; {
+    description = "Scanner button daemon";
+    longDescription = ''
+      scanbd polls a scanner's buttons, looking for button presses, function
+      knob changes, or other scanner events such as paper inserts and removals,
+      while at the same time allowing scan-applications to access the scanner.
+      
+      Various actions can be submitted (scan, copy, email, ...) via action
+      scripts. The function knob values are passed to the action scripts as
+      well. Scan actions are also signaled via dbus. This can be useful for
+      foreign applications. Scans can also be triggered via dbus from foreign
+      applications.
+      
+      On platforms which support signaling of dynamic device insertion/removal
+      (libudev, dbus, hal), scanbd supports this as well.
+
+      scanbd can use all sane-backends or some special backends from the (old)
+      scanbuttond project. 
+    '';
+    homepage = http://scanbd.sourceforge.net/;
+    downloadPage = http://sourceforge.net/projects/scanbd/;
+    license = licenses.gpl2Plus;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ nckx ];
+  };
+}