about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorRobert Scott <code@humanleg.org.uk>2020-05-16 22:07:46 +0100
committerRobert Scott <code@humanleg.org.uk>2020-05-16 22:07:46 +0100
commit5f19ec3bc4f93a2408c7f46c73cd0659bca604be (patch)
tree5ba81e57326af3c6ef18e66355d8832b683e3140 /pkgs/tools
parent4eb8f4ece330734c59ee985f53e188aa894c22ac (diff)
downloadnixlib-5f19ec3bc4f93a2408c7f46c73cd0659bca604be.tar
nixlib-5f19ec3bc4f93a2408c7f46c73cd0659bca604be.tar.gz
nixlib-5f19ec3bc4f93a2408c7f46c73cd0659bca604be.tar.bz2
nixlib-5f19ec3bc4f93a2408c7f46c73cd0659bca604be.tar.lz
nixlib-5f19ec3bc4f93a2408c7f46c73cd0659bca604be.tar.xz
nixlib-5f19ec3bc4f93a2408c7f46c73cd0659bca604be.tar.zst
nixlib-5f19ec3bc4f93a2408c7f46c73cd0659bca604be.zip
aflplusplus: don't run unit tests with cmocka
i don't think running the unit tests really adds anything given that we
have proper integration tests working, and it just introduces another
build dependency and possibility for spurious breakage.
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/aflplusplus/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/tools/security/aflplusplus/default.nix b/pkgs/tools/security/aflplusplus/default.nix
index ea32b6faf00e..332e79e70e1d 100644
--- a/pkgs/tools/security/aflplusplus/default.nix
+++ b/pkgs/tools/security/aflplusplus/default.nix
@@ -1,6 +1,6 @@
 { stdenv, stdenvNoCC, fetchFromGitHub, callPackage, makeWrapper
 , clang_9, llvm_9, gcc, which, libcgroup, python, perl, gmp
-, file, cmocka, wine ? null, fetchpatch
+, file, wine ? null, fetchpatch
 }:
 
 # wine fuzzing is only known to work for win32 binaries, and using a mixture of
@@ -105,7 +105,7 @@ let
         wrapPythonProgramsIn $out/bin ${python.pkgs.pefile}
     '';
 
-    installCheckInputs = [ perl file cmocka ];
+    installCheckInputs = [ perl file ];
     doInstallCheck = true;
     installCheckPhase = ''
       # replace references to tools in build directory with references to installed locations