about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2019-04-17 23:32:58 +0200
committerGitHub <noreply@github.com>2019-04-17 23:32:58 +0200
commit5b7f58701c9c3a92e8307d825580166e54a2e25d (patch)
tree5d7bb911e36e8b9a0d74bb3a6bec9b3489d408f6 /pkgs/tools
parentb26b2c1d07f54e7dd20128648831a0535a9c36c7 (diff)
parent5c1d710a6b7c137ed920288792ed1a1e95ce418a (diff)
downloadnixlib-5b7f58701c9c3a92e8307d825580166e54a2e25d.tar
nixlib-5b7f58701c9c3a92e8307d825580166e54a2e25d.tar.gz
nixlib-5b7f58701c9c3a92e8307d825580166e54a2e25d.tar.bz2
nixlib-5b7f58701c9c3a92e8307d825580166e54a2e25d.tar.lz
nixlib-5b7f58701c9c3a92e8307d825580166e54a2e25d.tar.xz
nixlib-5b7f58701c9c3a92e8307d825580166e54a2e25d.tar.zst
nixlib-5b7f58701c9c3a92e8307d825580166e54a2e25d.zip
Merge pull request #59746 from jtojnar/gtranslator
gtranslator: init at 3.32.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/text/gtranslator/default.nix68
1 files changed, 68 insertions, 0 deletions
diff --git a/pkgs/tools/text/gtranslator/default.nix b/pkgs/tools/text/gtranslator/default.nix
new file mode 100644
index 000000000000..20f1bc845cde
--- /dev/null
+++ b/pkgs/tools/text/gtranslator/default.nix
@@ -0,0 +1,68 @@
+{ stdenv
+, fetchurl
+, meson
+, ninja
+, pkgconfig
+, itstool
+, gettext
+, python3
+, wrapGAppsHook
+, libxml2
+, libgda
+, gspell
+, glib
+, gtk3
+, gtksourceview4
+, gnome3
+, gsettings-desktop-schemas
+}:
+
+stdenv.mkDerivation rec {
+  pname = "gtranslator";
+  version = "3.32.0";
+
+  src = fetchurl {
+    url = "mirror://gnome/sources/${pname}/${stdenv.lib.versions.majorMinor version}/${pname}-${version}.tar.xz";
+    sha256 = "1dqigah7x6h3afw5jcs3lw3h9y0acj72arcgxr89l6galvknr2xa";
+  };
+
+  nativeBuildInputs = [
+    meson
+    ninja
+    pkgconfig
+    itstool
+    gettext
+    python3
+    wrapGAppsHook
+  ];
+
+  buildInputs = [
+    libxml2
+    glib
+    gtk3
+    gtksourceview4
+    libgda
+    gettext
+    gspell
+    gsettings-desktop-schemas
+  ];
+
+  postPatch = ''
+    chmod +x build-aux/meson/meson_post_install.py
+    patchShebangs build-aux/meson/meson_post_install.py
+  '';
+
+  passthru = {
+    updateScript = gnome3.updateScript {
+      packageName = pname;
+    };
+  };
+
+  meta = with stdenv.lib; {
+    description = "GNOME translation making program";
+    homepage = https://wiki.gnome.org/Apps/Gtranslator;
+    license = licenses.gpl3Plus;
+    maintainers = with maintainers; [ jtojnar ];
+    platforms = platforms.linux;
+  };
+}