about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorWeijia Wang <9713184+wegank@users.noreply.github.com>2023-03-23 10:36:14 +0200
committerGitHub <noreply@github.com>2023-03-23 10:36:14 +0200
commit52ee7a6a9264787154ef8ae0e0c4feb41eb354b6 (patch)
treeba0d8aa848ad22afd34f35e3aa23910d2ba60ff5 /pkgs/tools
parentd1964e2c93dadb3740c39da3591d8a1d425e4468 (diff)
parent12db8314d734f9fbb2dc58dfe73c1b3410599b29 (diff)
downloadnixlib-52ee7a6a9264787154ef8ae0e0c4feb41eb354b6.tar
nixlib-52ee7a6a9264787154ef8ae0e0c4feb41eb354b6.tar.gz
nixlib-52ee7a6a9264787154ef8ae0e0c4feb41eb354b6.tar.bz2
nixlib-52ee7a6a9264787154ef8ae0e0c4feb41eb354b6.tar.lz
nixlib-52ee7a6a9264787154ef8ae0e0c4feb41eb354b6.tar.xz
nixlib-52ee7a6a9264787154ef8ae0e0c4feb41eb354b6.tar.zst
nixlib-52ee7a6a9264787154ef8ae0e0c4feb41eb354b6.zip
Merge pull request #203236 from Flakebi/fail2ban
fail2ban: 0.11.2 -> 1.0.2
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/fail2ban/default.nix36
1 files changed, 9 insertions, 27 deletions
diff --git a/pkgs/tools/security/fail2ban/default.nix b/pkgs/tools/security/fail2ban/default.nix
index daa0e8471158..780f1b4dfb0c 100644
--- a/pkgs/tools/security/fail2ban/default.nix
+++ b/pkgs/tools/security/fail2ban/default.nix
@@ -1,18 +1,17 @@
 { lib, stdenv, fetchFromGitHub
 , python3
-, fetchpatch
 , installShellFiles
 }:
 
 python3.pkgs.buildPythonApplication rec {
   pname = "fail2ban";
-  version = "0.11.2";
+  version = "1.0.2";
 
   src = fetchFromGitHub {
     owner = "fail2ban";
     repo = "fail2ban";
     rev = version;
-    sha256 = "q4U9iWCa1zg8sA+6pPNejt6v/41WGIKN5wITJCrCqQE=";
+    hash = "sha256-Zd8zLkFlvXTbeInEkNFyHgcAiOsX4WwF6hf5juSQvbY=";
   };
 
   outputs = [ "out" "man" ];
@@ -25,31 +24,13 @@ python3.pkgs.buildPythonApplication rec {
       pyinotify
     ];
 
-  patches = [
-    # remove references to use_2to3, for setuptools>=58
-    # has been merged into master, remove next release
-    (fetchpatch {
-      url = "https://github.com/fail2ban/fail2ban/commit/5ac303df8a171f748330d4c645ccbf1c2c7f3497.patch";
-      sha256 = "sha256-aozQJHwPcJTe/D/PLQzBk1YH3OAP6Qm7wO7cai5CVYI=";
-    })
-    # fix use of MutableMapping with Python >= 3.10
-    # https://github.com/fail2ban/fail2ban/issues/3142
-    (fetchpatch {
-      url = "https://github.com/fail2ban/fail2ban/commit/294ec73f629d0e29cece3a1eb5dd60b6fccea41f.patch";
-      sha256 = "sha256-Eimm4xjBDYNn5QdTyMqGgT5EXsZdd/txxcWJojXlsFE=";
-    })
-  ];
-
   preConfigure = ''
-    # workaround for setuptools 58+
-    # https://github.com/fail2ban/fail2ban/issues/3098
     patchShebangs fail2ban-2to3
     ./fail2ban-2to3
 
     for i in config/action.d/sendmail*.conf; do
       substituteInPlace $i \
-        --replace /usr/sbin/sendmail sendmail \
-        --replace /usr/bin/whois whois
+        --replace /usr/sbin/sendmail sendmail
     done
 
     substituteInPlace config/filter.d/dovecot.conf \
@@ -65,15 +46,17 @@ python3.pkgs.buildPythonApplication rec {
     ${python3.interpreter} setup.py install_data --install-dir=$out --root=$out
   '';
 
-  postPatch = ''
-    ${stdenv.shell} ./fail2ban-2to3
-  '';
-
   postInstall =
     let
       sitePackages = "$out/${python3.sitePackages}";
     in
     ''
+      install -m 644 -D -t "$out/lib/systemd/system" build/fail2ban.service
+      # Replace binary paths
+      sed -i "s#build/bdist.*/wheel/fail2ban.*/scripts/#$out/bin/#g" $out/lib/systemd/system/fail2ban.service
+      # Delete creating the runtime directory, systemd does that
+      sed -i "/ExecStartPre/d" $out/lib/systemd/system/fail2ban.service
+
       # see https://github.com/NixOS/nixpkgs/issues/4968
       rm -r "${sitePackages}/etc"
 
@@ -88,6 +71,5 @@ python3.pkgs.buildPythonApplication rec {
     description = "A program that scans log files for repeated failing login attempts and bans IP addresses";
     license = licenses.gpl2Plus;
     maintainers = with maintainers; [ eelco lovek323 ];
-    platforms = platforms.unix;
   };
 }