about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@higgsboson.tk>2016-10-09 11:28:31 +0200
committerGitHub <noreply@github.com>2016-10-09 11:28:31 +0200
commit5275d07fea6ea4f122a982f774226db562576248 (patch)
tree5217c88c6627e7ac33e9b13e35fd508945502168 /pkgs/tools
parent7a6e2837efee709964e731cecd3d36f8f2a2d28e (diff)
parent26f75f7d3194b8ef237268ae7488bd71ff8154fe (diff)
downloadnixlib-5275d07fea6ea4f122a982f774226db562576248.tar
nixlib-5275d07fea6ea4f122a982f774226db562576248.tar.gz
nixlib-5275d07fea6ea4f122a982f774226db562576248.tar.bz2
nixlib-5275d07fea6ea4f122a982f774226db562576248.tar.lz
nixlib-5275d07fea6ea4f122a982f774226db562576248.tar.xz
nixlib-5275d07fea6ea4f122a982f774226db562576248.tar.zst
nixlib-5275d07fea6ea4f122a982f774226db562576248.zip
Merge pull request #19357 from NeQuissimus/httpstat
httpstat: init at 1.2.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/httpstat/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/tools/networking/httpstat/default.nix b/pkgs/tools/networking/httpstat/default.nix
new file mode 100644
index 000000000000..49f71f448051
--- /dev/null
+++ b/pkgs/tools/networking/httpstat/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchFromGitHub, curl, python, pythonPackages, ... }:
+
+pythonPackages.buildPythonPackage rec {
+    name = "${pname}-${version}";
+    pname = "httpstat";
+    version = "1.2.0";
+    src = fetchFromGitHub {
+      owner = "reorx";
+      repo = pname;
+      rev = "${version}";
+      sha256 = "1zfbv3fz3g3wwvsgrcyrk2cp7pjhkpf7lmx57ry9b43c62gcd7yh";
+    };
+    doCheck = false;
+    propagatedBuildInputs = [ ];
+    runtimeDeps = [ curl ];
+
+    installPhase = ''
+      mkdir -p $out/${python.sitePackages}/
+      cp httpstat.py $out/${python.sitePackages}/
+      mkdir -p $out/bin
+      ln -s $out/${python.sitePackages}/httpstat.py $out/bin/httpstat
+      chmod +x $out/bin/httpstat
+    '';
+
+    meta = {
+      description = "curl statistics made simple";
+      homepage = https://github.com/reorx/httpstat;
+      license = stdenv.lib.licenses.mit;
+      maintainers = with stdenv.lib.maintainers; [ nequissimus ];
+    };
+  }