about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-01-04 15:59:31 +0100
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-01-04 16:09:46 +0100
commit517d8c88469bc6cd72056e7cc24c42d9ee98334e (patch)
tree8df80077ef18b81260a080034d77f522546125df /pkgs/tools
parentf93e14fa766112bdb178ecdca8b1b83c36657797 (diff)
downloadnixlib-517d8c88469bc6cd72056e7cc24c42d9ee98334e.tar
nixlib-517d8c88469bc6cd72056e7cc24c42d9ee98334e.tar.gz
nixlib-517d8c88469bc6cd72056e7cc24c42d9ee98334e.tar.bz2
nixlib-517d8c88469bc6cd72056e7cc24c42d9ee98334e.tar.lz
nixlib-517d8c88469bc6cd72056e7cc24c42d9ee98334e.tar.xz
nixlib-517d8c88469bc6cd72056e7cc24c42d9ee98334e.tar.zst
nixlib-517d8c88469bc6cd72056e7cc24c42d9ee98334e.zip
pingtcp: init at 0.0.3
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/pingtcp/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/tools/networking/pingtcp/default.nix b/pkgs/tools/networking/pingtcp/default.nix
new file mode 100644
index 000000000000..4e7c080ea7f9
--- /dev/null
+++ b/pkgs/tools/networking/pingtcp/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, fetchgit, cmake }:
+
+let version = "0.0.3"; in
+stdenv.mkDerivation {
+  name = "pingtcp-${version}";
+
+  # This project uses git submodules, which fetchFromGitHub doesn't support:
+  src = fetchgit {
+    sha256 = "0an4dbwcp2qv1n068q0s34lz88vl1z2rqfh3j9apbq7bislsrwdd";
+    rev = "refs/tags/v${version}";
+    url = "https://github.com/LanetNetwork/pingtcp.git";
+  };
+
+  nativeBuildInputs = [ cmake ];
+
+  postPatch = ''
+    substituteInPlace {.,pfcquirks}/CMakeLists.txt \
+      --replace "-march=native" ""
+  '';
+
+  enableParallelBuilding = true;
+
+  doCheck = false;
+
+  meta = with stdenv.lib; {
+    inherit version;
+    description = "Measure TCP handshake time";
+    homepage = https://github.com/LanetNetwork/pingtcp;
+    license = licenses.gpl3;
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ nckx ];
+  };
+}