about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-12-31 04:50:57 +0100
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-12-31 05:04:05 +0100
commit4ae6598c0b4a4439939c47e20317150088c61bb6 (patch)
treea7b6b8b533480bc0da73ce7d2da37169e843ce72 /pkgs/tools
parentd04e57ea6a39992cb90d59b212576b090328ae60 (diff)
downloadnixlib-4ae6598c0b4a4439939c47e20317150088c61bb6.tar
nixlib-4ae6598c0b4a4439939c47e20317150088c61bb6.tar.gz
nixlib-4ae6598c0b4a4439939c47e20317150088c61bb6.tar.bz2
nixlib-4ae6598c0b4a4439939c47e20317150088c61bb6.tar.lz
nixlib-4ae6598c0b4a4439939c47e20317150088c61bb6.tar.xz
nixlib-4ae6598c0b4a4439939c47e20317150088c61bb6.tar.zst
nixlib-4ae6598c0b4a4439939c47e20317150088c61bb6.zip
zpaq{,d}: clarify; improve description; maintain
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/archivers/zpaq/default.nix21
-rw-r--r--pkgs/tools/archivers/zpaq/zpaqd.nix21
2 files changed, 24 insertions, 18 deletions
diff --git a/pkgs/tools/archivers/zpaq/default.nix b/pkgs/tools/archivers/zpaq/default.nix
index fddb3cbfb154..2b761df3863f 100644
--- a/pkgs/tools/archivers/zpaq/default.nix
+++ b/pkgs/tools/archivers/zpaq/default.nix
@@ -9,9 +9,6 @@ let
     url="http://mattmahoney.net/dc/zpaq705.zip";
     sha256="0d1knq4f6693nvbwjx4wznb45hm4zyn4k88xvhynyk0dcbiy7ayq";
   };
-  buildInputs = [
-    unzip
-  ];
   isUnix = with stdenv; isLinux || isGNU || isDarwin || isFreeBSD || isOpenBSD;
   isx86 = stdenv.isi686 || stdenv.isx86_64;
   compileFlags = with stdenv; ""
@@ -24,15 +21,20 @@ let
 in
 stdenv.mkDerivation {
   inherit (s) name version;
-  inherit buildInputs;
+
   src = fetchurl {
     inherit (s) url sha256;
   };
+
   sourceRoot = ".";
+
+  buildInputs = [ unzip ];
+
   buildPhase = ''
     g++ ${compileFlags} -fPIC --shared libzpaq.cpp -o libzpaq.so
     g++ ${compileFlags} -L. -L"$out/lib" -lzpaq zpaq.cpp -o zpaq
   '';
+
   installPhase = ''
     mkdir -p "$out"/{bin,include,lib,share/doc/zpaq}
     cp libzpaq.so "$out/lib"
@@ -40,12 +42,13 @@ stdenv.mkDerivation {
     cp libzpaq.h "$out/include"
     cp readme.txt "$out/share/doc/zpaq"
   '';
-  meta = {
+
+  meta = with stdenv.lib; {
     inherit (s) version;
-    description = ''An archiver with backward compatibility of versions for decompression'';
-    license = stdenv.lib.licenses.gpl3Plus ;
-    maintainers = [stdenv.lib.maintainers.raskin];
-    platforms = stdenv.lib.platforms.linux;
+    description = "Incremental journaling backup utility and archiver";
+    license = licenses.gpl3Plus ;
+    maintainers = with maintainers; [ raskin nckx ];
+    platforms = platforms.linux;
     homepage = "http://mattmahoney.net/dc/zpaq.html";
   };
 }
diff --git a/pkgs/tools/archivers/zpaq/zpaqd.nix b/pkgs/tools/archivers/zpaq/zpaqd.nix
index 5518a94ba21f..7adcd3cf6e2b 100644
--- a/pkgs/tools/archivers/zpaq/zpaqd.nix
+++ b/pkgs/tools/archivers/zpaq/zpaqd.nix
@@ -9,9 +9,6 @@ let
     url="http://mattmahoney.net/dc/zpaqd633.zip";
     sha256="00zgc4mcmsd3d4afgzmrp6ymcyy8gb9kap815d5a3f9zhhzkz4dx";
   };
-  buildInputs = [
-    unzip
-  ];
   isUnix = with stdenv; isLinux || isGNU || isDarwin || isFreeBSD || isOpenBSD;
   isx86 = stdenv.isi686 || stdenv.isx86_64;
   compileFlags = with stdenv; ""
@@ -24,15 +21,20 @@ let
 in
 stdenv.mkDerivation {
   inherit (s) name version;
-  inherit buildInputs;
+
   src = fetchurl {
     inherit (s) url sha256;
   };
+
   sourceRoot = ".";
+
+  buildInputs = [ unzip ];
+
   buildPhase = ''
     g++ ${compileFlags} -fPIC --shared libzpaq.cpp -o libzpaq.so
     g++ ${compileFlags} -L. -L"$out/lib" -lzpaq zpaqd.cpp -o zpaqd
   '';
+
   installPhase = ''
     mkdir -p "$out"/{bin,include,lib,share/doc/zpaq}
     cp libzpaq.so "$out/lib"
@@ -40,11 +42,12 @@ stdenv.mkDerivation {
     cp libzpaq.h "$out/include"
     cp readme_zpaqd.txt "$out/share/doc/zpaq"
   '';
-  meta = {
+
+  meta = with stdenv.lib; {
     inherit (s) version;
-    description = ''ZPAQ archiver decompressor and algorithm development tool'';
-    license = stdenv.lib.licenses.gpl3Plus ;
-    maintainers = [stdenv.lib.maintainers.raskin];
-    platforms = stdenv.lib.platforms.linux;
+    description = "ZPAQ archive decompressor and algorithm development tool";
+    license = licenses.gpl3Plus ;
+    maintainers = with maintainers; [ raskin nckx ];
+    platforms = platforms.linux;
   };
 }