about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorAnderson Torres <torres.anderson.85@protonmail.com>2023-09-25 18:13:01 -0300
committerAnderson Torres <torres.anderson.85@protonmail.com>2023-09-27 20:49:38 -0300
commit47ffbb2df830bac739ed9427a2d6db21c304d443 (patch)
tree5a624a38ac74e435a8674827b05e502f2c870216 /pkgs/tools
parentcc3383d12b25f8e1f2b23fdb098a9cb1b22dfa58 (diff)
downloadnixlib-47ffbb2df830bac739ed9427a2d6db21c304d443.tar
nixlib-47ffbb2df830bac739ed9427a2d6db21c304d443.tar.gz
nixlib-47ffbb2df830bac739ed9427a2d6db21c304d443.tar.bz2
nixlib-47ffbb2df830bac739ed9427a2d6db21c304d443.tar.lz
nixlib-47ffbb2df830bac739ed9427a2d6db21c304d443.tar.xz
nixlib-47ffbb2df830bac739ed9427a2d6db21c304d443.tar.zst
nixlib-47ffbb2df830bac739ed9427a2d6db21c304d443.zip
gmic: use lib.cmakeBool
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/graphics/gmic/default.nix13
1 files changed, 8 insertions, 5 deletions
diff --git a/pkgs/tools/graphics/gmic/default.nix b/pkgs/tools/graphics/gmic/default.nix
index a5d3b53b5ec1..59022bcca505 100644
--- a/pkgs/tools/graphics/gmic/default.nix
+++ b/pkgs/tools/graphics/gmic/default.nix
@@ -64,10 +64,10 @@ stdenv.mkDerivation (finalAttrs: {
   ];
 
   cmakeFlags = [
-    "-DBUILD_LIB_STATIC=OFF"
-    "-DENABLE_CURL=OFF"
-    "-DENABLE_DYNAMIC_LINKING=ON"
-    "-DUSE_SYSTEM_CIMG=ON"
+    (lib.cmakeBool "BUILD_LIB_STATIC" false)
+    (lib.cmakeBool "ENABLE_CURL" false)
+    (lib.cmakeBool "ENABLE_DYNAMIC_LINKING" true)
+    (lib.cmakeBool "USE_SYSTEM_CIMG" true)
   ];
 
   postPatch = ''
@@ -115,7 +115,10 @@ stdenv.mkDerivation (finalAttrs: {
     homepage = "https://gmic.eu/";
     description = "Open and full-featured framework for image processing";
     license = lib.licenses.cecill21;
-    maintainers = [ lib.maintainers.lilyinstarlight ];
+    maintainers = [
+      lib.maintainers.AndersonTorres
+      lib.maintainers.lilyinstarlight
+    ];
     platforms = lib.platforms.unix;
   };
 })