about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorEllis Whitehead <ellis@ellisw.net>2014-03-15 20:21:30 +0100
committerEllis Whitehead <ellis@ellisw.net>2014-03-15 20:33:10 +0100
commit44b6766f5dbfb7fe3187f5bd1550f2f61e726e6c (patch)
tree8309e7e6ee79b90e3ee06609f8e833d97ca5d1c4 /pkgs/tools
parent80ed0ff85f1e24bfdc9f4db0c64568828f0c287b (diff)
downloadnixlib-44b6766f5dbfb7fe3187f5bd1550f2f61e726e6c.tar
nixlib-44b6766f5dbfb7fe3187f5bd1550f2f61e726e6c.tar.gz
nixlib-44b6766f5dbfb7fe3187f5bd1550f2f61e726e6c.tar.bz2
nixlib-44b6766f5dbfb7fe3187f5bd1550f2f61e726e6c.tar.lz
nixlib-44b6766f5dbfb7fe3187f5bd1550f2f61e726e6c.tar.xz
nixlib-44b6766f5dbfb7fe3187f5bd1550f2f61e726e6c.tar.zst
nixlib-44b6766f5dbfb7fe3187f5bd1550f2f61e726e6c.zip
Create package for 'fasd'
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/fasd/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/tools/misc/fasd/default.nix b/pkgs/tools/misc/fasd/default.nix
new file mode 100644
index 000000000000..77d1d58c30c2
--- /dev/null
+++ b/pkgs/tools/misc/fasd/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, fetchgit, pandoc, ... } :
+
+let
+  rev = "287af2b80e0829b08dc6329b4fe8d8e5594d64b0";
+in
+stdenv.mkDerivation {
+
+  name = "fasd-1.0.1";
+
+  src = fetchgit {
+    url = "https://github.com/clvv/fasd.git";
+    inherit rev;
+    sha256 = "0kv9iyfdf916x0gab9fzs4vmsnkaqmb6kh4xna485nqij89xzkgs";
+  };
+
+  installPhase = ''
+    PREFIX=$out make install
+  '';
+
+  meta = {
+    homepage = "https://github.com/clvv/fasd";
+    description = "quick command-line access to files and directories for POSIX shells";
+    license = "free";
+
+    longDescription = ''
+      Fasd is a command-line productivity booster.
+      Fasd offers quick access to files and directories for POSIX shells. It is
+      inspired by tools like autojump, z and v. Fasd keeps track of files and
+      directories you have accessed, so that you can quickly reference them in the
+      command line.
+    '';
+
+    platforms = stdenv.lib.platforms.all;
+  };
+}
+
+