about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorColin <486199+c00w@users.noreply.github.com>2020-04-28 20:16:20 -0400
committerGitHub <noreply@github.com>2020-04-28 20:16:20 -0400
commit4007ceb6afa4bee457d7248ffcbb19740d2ecd78 (patch)
treeefcaf2ec15bd80fb0aa67a0732b40f8c14115deb /pkgs/tools
parentc01ac3ed129fafeff69025882b227f8612f0aeb7 (diff)
downloadnixlib-4007ceb6afa4bee457d7248ffcbb19740d2ecd78.tar
nixlib-4007ceb6afa4bee457d7248ffcbb19740d2ecd78.tar.gz
nixlib-4007ceb6afa4bee457d7248ffcbb19740d2ecd78.tar.bz2
nixlib-4007ceb6afa4bee457d7248ffcbb19740d2ecd78.tar.lz
nixlib-4007ceb6afa4bee457d7248ffcbb19740d2ecd78.tar.xz
nixlib-4007ceb6afa4bee457d7248ffcbb19740d2ecd78.tar.zst
nixlib-4007ceb6afa4bee457d7248ffcbb19740d2ecd78.zip
treewide get rid of go 1.12 (#83253)
* treewide Drop unneeded go 1.12 overrides

* Fix packr to be go module compatible.

I updated to version 2.8.0 which is the latest on master.
Then due to the 2 different sets of go modules which are used, I split
the build into two different derivations, then merged them togethor
using symlinkJoin to have the same output structure as the existing derivation.

* Remove consul dependency on go1.12

I updated the consul version to 1.7.2 and flipped it to building using
modules.

* Remove go1.12 from perkeep.

Update the version to the latest unstable on master.

* Update scaleway-cli to not be pinned to go1.12

Switched the version to 1.20

* Update prometheus-varnish-exporter to not depend on go1.12

* Update lnd to build with go1.12

Updated the version
Forced only building subpackages with main to prevent panics over
multiple modules in one repo

* Remove go1.12 from openshift

Had to update the version to 4.1.0 and do a bit of munging to get this
to work

* Remove go1.12 completely.

These are no longer needed.

* Update bazel-watcher and make it build with go 1.14
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/admin/scaleway-cli/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/tools/admin/scaleway-cli/default.nix b/pkgs/tools/admin/scaleway-cli/default.nix
index 68c20493d195..f9b608ebc4c6 100644
--- a/pkgs/tools/admin/scaleway-cli/default.nix
+++ b/pkgs/tools/admin/scaleway-cli/default.nix
@@ -2,7 +2,7 @@
 
 buildGoPackage rec{
   pname = "scaleway-cli";
-  version = "1.17";
+  version = "1.20";
 
   goPackagePath = "github.com/scaleway/scaleway-cli";
 
@@ -10,7 +10,7 @@ buildGoPackage rec{
     owner = "scaleway";
     repo = "scaleway-cli";
     rev = "v${version}";
-    sha256 = "0v50wk6q8537880whi6w83dia9y934v0s2xr1z52cn3mrsjghsnd";
+    sha256 = "14likzp3hl04nq9nmpmh9m5zqjyspy5cyk20dkh03c1nhkd4vcnx";
   };
 
   meta = with stdenv.lib; {