about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@users.noreply.github.com>2018-12-02 03:15:50 -0500
committerGitHub <noreply@github.com>2018-12-02 03:15:50 -0500
commit3f4cbd47af04b6156a53671930d418b615b1711d (patch)
tree23255bc4f3f62437ae43ccd28f68a1736604fce7 /pkgs/tools
parent007dafc9a089e201838c6929933c6adfa06862b9 (diff)
parentc154ecfc3841fb6693b6e1585da2afb16bf8e8cd (diff)
downloadnixlib-3f4cbd47af04b6156a53671930d418b615b1711d.tar
nixlib-3f4cbd47af04b6156a53671930d418b615b1711d.tar.gz
nixlib-3f4cbd47af04b6156a53671930d418b615b1711d.tar.bz2
nixlib-3f4cbd47af04b6156a53671930d418b615b1711d.tar.lz
nixlib-3f4cbd47af04b6156a53671930d418b615b1711d.tar.xz
nixlib-3f4cbd47af04b6156a53671930d418b615b1711d.tar.zst
nixlib-3f4cbd47af04b6156a53671930d418b615b1711d.zip
Merge pull request #51349 from marsam/feature/fix-vdirsyncer
vdirsyncer: fix build
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/vdirsyncer/default.nix19
1 files changed, 17 insertions, 2 deletions
diff --git a/pkgs/tools/misc/vdirsyncer/default.nix b/pkgs/tools/misc/vdirsyncer/default.nix
index c273ef879682..49583ee28902 100644
--- a/pkgs/tools/misc/vdirsyncer/default.nix
+++ b/pkgs/tools/misc/vdirsyncer/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, python3Packages, glibcLocales, rustPlatform, pkgconfig, openssl }:
+{ stdenv, python3Packages, fetchpatch, glibcLocales, rustPlatform, pkgconfig, openssl, Security }:
 
 # Packaging documentation at:
 # https://github.com/untitaker/vdirsyncer/blob/master/docs/packaging.rst
@@ -16,7 +16,7 @@ let
     inherit src;
     sourceRoot = name + "/rust";
     cargoSha256 = "08xq9q5fx37azzkqqgwcnds1yd8687gh26dsl3ivql5h13fa2w3q";
-    buildInputs = [ pkgconfig openssl ];
+    buildInputs = [ pkgconfig openssl ] ++ stdenv.lib.optional stdenv.isDarwin Security;
   };
 in pythonPackages.buildPythonApplication rec {
   inherit version pname src native;
@@ -35,6 +35,21 @@ in pythonPackages.buildPythonApplication rec {
 
   checkInputs = with pythonPackages; [ hypothesis pytest pytest-localserver pytest-subtesthack ] ++ [ glibcLocales ];
 
+  patches = [
+    (fetchpatch {
+      url = https://github.com/pimutils/vdirsyncer/commit/80a42e4c6c18ca4db737bc6700c50a3866832bbb.patch;
+      sha256 = "1vrhn0ma3y08w6f5abhl3r5rq30g60h1bp3wmyszw909hyvyzp5l";
+    })
+    (fetchpatch {
+      url = https://github.com/pimutils/vdirsyncer/commit/22ad88a6b18b0979c5d1f1d610c1d2f8f87f4b89.patch;
+      sha256 = "0dbzj6jlxhdidnm3i21a758z83sdiwzhpd45pbkhycfhgmqmhjpl";
+    })
+    (fetchpatch {
+      url = https://github.com/pimutils/vdirsyncer/commit/29417235321c249c65904bc7948b066ef5683aee.patch;
+      sha256 = "0zvr0y88gm3vprjcdzs4m151laa9qhkyi61rvrfdjmf42fwhbm80";
+    })
+  ];
+
   postPatch = ''
     sed -i 's/spec.add_external_build(cmd=cmd/spec.add_external_build(cmd="true"/g' setup.py
   '';