about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-09-11 22:12:24 +0200
committerTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2015-09-11 22:28:41 +0200
commit3c47829cb530bbfdcfcf1e1a71dd7cf14bdb3598 (patch)
tree51e9520fbd3272a0258c4a58d0c74dd1060f612c /pkgs/tools
parent4dbaefa2185e89eb2c1308ed230ca9fe2d7d6024 (diff)
downloadnixlib-3c47829cb530bbfdcfcf1e1a71dd7cf14bdb3598.tar
nixlib-3c47829cb530bbfdcfcf1e1a71dd7cf14bdb3598.tar.gz
nixlib-3c47829cb530bbfdcfcf1e1a71dd7cf14bdb3598.tar.bz2
nixlib-3c47829cb530bbfdcfcf1e1a71dd7cf14bdb3598.tar.lz
nixlib-3c47829cb530bbfdcfcf1e1a71dd7cf14bdb3598.tar.xz
nixlib-3c47829cb530bbfdcfcf1e1a71dd7cf14bdb3598.tar.zst
nixlib-3c47829cb530bbfdcfcf1e1a71dd7cf14bdb3598.zip
exfat-fuse: 1.1.0 -> 1.2.0
Remove underscore & use standard name (also used by upstream).

Changes: https://github.com/relan/exfat/blob/master/ChangeLog
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/filesystems/exfat-fuse/default.nix26
-rw-r--r--pkgs/tools/filesystems/fuse-exfat/default.nix32
2 files changed, 26 insertions, 32 deletions
diff --git a/pkgs/tools/filesystems/exfat-fuse/default.nix b/pkgs/tools/filesystems/exfat-fuse/default.nix
new file mode 100644
index 000000000000..d2a18e41b0e0
--- /dev/null
+++ b/pkgs/tools/filesystems/exfat-fuse/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, fuse }:
+
+let version = "1.2.0"; in
+stdenv.mkDerivation {
+  name = "exfat-fuse-${version}";
+
+  src = fetchFromGitHub {
+    sha256 = "1fsm082g8phqcdg5md6yll06jijnbvqrdy0638psa8kr159h4dv8";
+    rev = "v${version}";
+    repo = "exfat";
+    owner = "relan";
+  };
+
+  buildInputs = [ fuse ];
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
+
+  meta = with stdenv.lib; {
+    inherit version;
+    homepage = https://github.com/relan/exfat;
+    description = "A FUSE file system to read and write to exFAT devices";
+    platforms = platforms.linux;
+    license = licenses.gpl2Plus;
+    maintainers = with maintainers; [ nckx ];
+  };
+}
+
diff --git a/pkgs/tools/filesystems/fuse-exfat/default.nix b/pkgs/tools/filesystems/fuse-exfat/default.nix
deleted file mode 100644
index ef8bf5845dd6..000000000000
--- a/pkgs/tools/filesystems/fuse-exfat/default.nix
+++ /dev/null
@@ -1,32 +0,0 @@
-{ stdenv, fetchurl, pkgconfig, fuse, scons }:
-
-stdenv.mkDerivation rec {
-  name = "fuse-exfat-1.1.0";
-
-  src = fetchurl {
-    sha256 = "0glmgwrf0nv09am54i6s35ksbvrywrwc51w6q32mv5by8475530r";
-    url = "https://docs.google.com/uc?export=download&id=0B7CLI-REKbE3VTdaa0EzTkhYdU0";
-    name = "${name}.tar.gz";
-  };
-
-  buildInputs = [ fuse ];
-  nativeBuildInputs = [ pkgconfig scons ];
-
-  buildPhase = ''
-    export CCFLAGS="-O2 -Wall -std=c99 -I${fuse}/include"
-    export LDFLAGS="-L${fuse}/lib"
-    mkdir -pv $out/sbin
-    scons DESTDIR=$out/sbin install
-  '';
-
-  installPhase = ":";
-
-  meta = with stdenv.lib; {
-    homepage = http://code.google.com/p/exfat/;
-    description = "A FUSE-based filesystem that allows read and write access to exFAT devices";
-    platforms = with platforms; linux;
-    license = licenses.gpl2Plus;
-    maintainers = with maintainers; [ nckx ];
-  };
-}
-