about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorworldofpeace <worldofpeace@protonmail.ch>2019-08-01 02:22:08 -0400
committerGitHub <noreply@github.com>2019-08-01 02:22:08 -0400
commit3b37b0afc7b28aea42be4dce4299034b1eabd6f2 (patch)
tree81a1417a77da7f258a152a6ef6f70e0e8800822c /pkgs/tools
parentb5294a27c6523f68b88baa45da2e6307c89d9ab5 (diff)
parent4fa644bceca4296619ba6d3a1a18201f4ca27538 (diff)
downloadnixlib-3b37b0afc7b28aea42be4dce4299034b1eabd6f2.tar
nixlib-3b37b0afc7b28aea42be4dce4299034b1eabd6f2.tar.gz
nixlib-3b37b0afc7b28aea42be4dce4299034b1eabd6f2.tar.bz2
nixlib-3b37b0afc7b28aea42be4dce4299034b1eabd6f2.tar.lz
nixlib-3b37b0afc7b28aea42be4dce4299034b1eabd6f2.tar.xz
nixlib-3b37b0afc7b28aea42be4dce4299034b1eabd6f2.tar.zst
nixlib-3b37b0afc7b28aea42be4dce4299034b1eabd6f2.zip
Merge pull request #65622 from HugoReeves/master
croc: init at 6.1.1
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/croc/default.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/tools/networking/croc/default.nix b/pkgs/tools/networking/croc/default.nix
new file mode 100644
index 000000000000..160b5840cf53
--- /dev/null
+++ b/pkgs/tools/networking/croc/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, buildGoModule, fetchFromGitHub }:
+
+buildGoModule rec {
+  pname = "croc";
+  version = "6.1.1";
+
+  goPackagePath = "github.com/schollz/croc";
+
+  src = fetchFromGitHub {
+    owner = "schollz";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "08gkwllk3m5hpkr1iwabvs739rvl6rzdnra2v040dzdj6zgyd12r";
+  };
+
+  modSha256 = "026m3hc2imna7bf4jpqm7yq6mr4l5is2crsx1vxdpr4h0n6z0v3i";
+  subPackages = [ "." ];
+
+  meta = with stdenv.lib; {
+    description = "Easily and securely send things from one computer to another";
+    homepage = https://github.com/schollz/croc;
+    license = licenses.mit;
+    maintainers = with maintainers; [ hugoreeves ];
+
+    longDescription = ''
+      Croc is a command line tool written in Go that allows any two computers to
+      simply and securely transfer files and folders.
+
+      Croc does all of the following:
+      - Allows any two computers to transfer data (using a relay)
+      - Provides end-to-end encryption (using PAKE)
+      - Enables easy cross-platform transfers (Windows, Linux, Mac)
+      - Allows multiple file transfers
+      - Allows resuming transfers that are interrupted
+      - Does not require a server or port-forwarding
+    '';
+  };
+}