about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorTristan Helmich <tristan.helmich@gmail.com>2016-04-04 15:11:00 +0200
committerTristan Helmich <tristan.helmich@gmail.com>2016-04-04 15:14:09 +0200
commit399d2bca32b5ddb0bed74c6acb96aee0ef598183 (patch)
treed6d13f896f40b3b5851ce357053923483ad4fefe /pkgs/tools
parentc74cbb824b334ba8bb5aecb519d4a8db1dc558e3 (diff)
downloadnixlib-399d2bca32b5ddb0bed74c6acb96aee0ef598183.tar
nixlib-399d2bca32b5ddb0bed74c6acb96aee0ef598183.tar.gz
nixlib-399d2bca32b5ddb0bed74c6acb96aee0ef598183.tar.bz2
nixlib-399d2bca32b5ddb0bed74c6acb96aee0ef598183.tar.lz
nixlib-399d2bca32b5ddb0bed74c6acb96aee0ef598183.tar.xz
nixlib-399d2bca32b5ddb0bed74c6acb96aee0ef598183.tar.zst
nixlib-399d2bca32b5ddb0bed74c6acb96aee0ef598183.zip
mosh: fix segfaulting issue
Discussion on this issue at https://github.com/mobile-shell/mosh/issues/727 and https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=817929#35
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/networking/mosh/default.nix13
1 files changed, 11 insertions, 2 deletions
diff --git a/pkgs/tools/networking/mosh/default.nix b/pkgs/tools/networking/mosh/default.nix
index ec2f8d78dc67..80feeafdbca4 100644
--- a/pkgs/tools/networking/mosh/default.nix
+++ b/pkgs/tools/networking/mosh/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchurl, zlib, boost, protobuf, ncurses, pkgconfig, IOTty
-, makeWrapper, perl, openssl }:
+, makeWrapper, perl, openssl, autoreconfHook, fetchpatch }:
 
 stdenv.mkDerivation rec {
   name = "mosh-1.2.5";
@@ -9,7 +9,16 @@ stdenv.mkDerivation rec {
     sha256 = "1qsb0y882yfgwnpy6f98pi5xqm6kykdsrxzvaal37hs7szjhky0s";
   };
 
-  buildInputs = [ boost protobuf ncurses zlib pkgconfig IOTty makeWrapper perl openssl ];
+  buildInputs = [ autoreconfHook boost protobuf ncurses zlib pkgconfig IOTty makeWrapper perl openssl ];
+
+  patches = [
+    # remove automake detection macro patch on next release as it is already on mosh master
+    (fetchpatch {
+      name = "fix_automake_detection_macro.patch";
+      url = "https://github.com/mobile-shell/mosh/commit/a47917b97606a03f6bbf0cafd1fcd495b0229790.patch";
+      sha256 = "0ib200ffvbnns125xd58947fyxdx31m06rmnzqmxpxcnjza7k404";
+    })
+  ];
 
   postInstall = ''
       wrapProgram $out/bin/mosh --prefix PERL5LIB : $PERL5LIB