about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authoraszlig <aszlig@nix.build>2020-04-08 21:31:16 +0200
committeraszlig <aszlig@nix.build>2020-04-17 12:32:57 +0200
commit3679c8d2d100280faddf26316e7630e12c19d92d (patch)
tree0ce5586f510b0cf58e794a5861d1f2e0ec06a5fb /pkgs/tools
parentee6f5a32bb090ddacee9f40056a5598b2f10480a (diff)
downloadnixlib-3679c8d2d100280faddf26316e7630e12c19d92d.tar
nixlib-3679c8d2d100280faddf26316e7630e12c19d92d.tar.gz
nixlib-3679c8d2d100280faddf26316e7630e12c19d92d.tar.bz2
nixlib-3679c8d2d100280faddf26316e7630e12c19d92d.tar.lz
nixlib-3679c8d2d100280faddf26316e7630e12c19d92d.tar.xz
nixlib-3679c8d2d100280faddf26316e7630e12c19d92d.tar.zst
nixlib-3679c8d2d100280faddf26316e7630e12c19d92d.zip
pcsc-cyberjack: 3.99.5_SP12 -> 3.99.5_SP13
Unfortunately, the upstream changelog consists of just the following:

  * Update to the Reiner-SCT repository rev cyberJack@1374

This is not very helpful since I haven't found a public SVN (I assume,
since it's using integer revisions) repository, so I decided to diff the
tarball against the old one, here's what I've found:

  * No longer ship generated files from autotools
  * Add support for REINER SCT cyberJack comfort PL
  * Add support for tanJack USB
  * Allow to override secoder information
  * Lots of whitespace and coding style changes

As mentioned above, the autotools-generated files are no longer shipped,
so I've added autoreconfHook to nativeBuildInputs.

I also verified the source tarball using the upstream hashes found here:

http://downloads.reiner-sct.de/LINUX/Hashwerte/Hashwerte.txt

Signed-off-by: aszlig <aszlig@nix.build>
Merges: https://github.com/NixOS/nixpkgs/pull/84749
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/pcsc-cyberjack/default.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/tools/security/pcsc-cyberjack/default.nix b/pkgs/tools/security/pcsc-cyberjack/default.nix
index 6683caecbe9b..cb651ff7ce15 100644
--- a/pkgs/tools/security/pcsc-cyberjack/default.nix
+++ b/pkgs/tools/security/pcsc-cyberjack/default.nix
@@ -1,8 +1,8 @@
-{ stdenv, fetchurl, pkgconfig, libusb1, pcsclite }:
+{ stdenv, fetchurl, autoreconfHook, pkgconfig, libusb1, pcsclite }:
 
 stdenv.mkDerivation rec {
   pname = "pcsc-cyberjack";
-  version = "3.99.5_SP12";
+  version = "3.99.5_SP13";
 
   src = with stdenv.lib; let
     splittedVer = splitString "_" version;
@@ -11,13 +11,13 @@ stdenv.mkDerivation rec {
     tarballVersion = "${mainVer}final${spVer}";
   in fetchurl {
     url = "http://support.reiner-sct.de/downloads/LINUX/V${version}"
-        + "/pcsc-cyberjack-${tarballVersion}.tar.bz2";
-    sha256 = "04pkmybal56s5xnjld09vl1s1h6qf8mvhm41b758d6hi240kgp1j";
+        + "/pcsc-cyberjack_${tarballVersion}.tar.gz";
+    sha256 = "1lx4bfz4riz7j77sl65akyxzww0ygm63w0c1b75knr1pijlv8d3b";
   };
 
   outputs = [ "out" "tools" ];
 
-  nativeBuildInputs = [ pkgconfig ];
+  nativeBuildInputs = [ autoreconfHook pkgconfig ];
   buildInputs = [ libusb1 pcsclite ];
 
   configureFlags = [