about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorLily Ballard <lily@sb.org>2019-04-23 15:45:59 -0700
committerLily Ballard <lily@sb.org>2019-04-23 17:32:28 -0700
commit35e2c2d6ddf7f76cecfac7ea186638dfe20364e7 (patch)
tree09374e06324b07c66487c193e60ebe8e18b2b1bf /pkgs/tools
parenta36cff247cde9cfbe24733f63c61a6bafc470a88 (diff)
downloadnixlib-35e2c2d6ddf7f76cecfac7ea186638dfe20364e7.tar
nixlib-35e2c2d6ddf7f76cecfac7ea186638dfe20364e7.tar.gz
nixlib-35e2c2d6ddf7f76cecfac7ea186638dfe20364e7.tar.bz2
nixlib-35e2c2d6ddf7f76cecfac7ea186638dfe20364e7.tar.lz
nixlib-35e2c2d6ddf7f76cecfac7ea186638dfe20364e7.tar.xz
nixlib-35e2c2d6ddf7f76cecfac7ea186638dfe20364e7.tar.zst
nixlib-35e2c2d6ddf7f76cecfac7ea186638dfe20364e7.zip
xv: init at 0.1.0
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/xv/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/tools/misc/xv/default.nix b/pkgs/tools/misc/xv/default.nix
new file mode 100644
index 000000000000..2611f5670bb4
--- /dev/null
+++ b/pkgs/tools/misc/xv/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchFromGitHub, rustPlatform, ncurses }:
+
+rustPlatform.buildRustPackage rec {
+  pname   = "xv";
+  version = "0.1.0";
+
+  src = fetchFromGitHub {
+    owner  = "chrisvest";
+    repo   = pname;
+    rev    = "${version}";
+    sha256 = "1cghg3ypxx6afllvwzc6j4z4h7mylapapipqghpdndrfizk7rsxi";
+  };
+
+  cargoSha256 = "0iwx9cxnxlif135s2v2hji8xil38xk5a1h147ryb54v6nabaxvjw";
+
+  buildInputs = [ ncurses ];
+
+  meta = with stdenv.lib; {
+    description = "A visual hex viewer for the terminal";
+    longDescription = ''
+      XV is a terminal hex viewer with a text user interface, written in 100% safe Rust.
+    '';
+    homepage    = https://chrisvest.github.io/xv/;
+    license     = with licenses; [ asl20 ];
+    maintainers = with maintainers; [ lilyball ];
+    platforms   = platforms.all;
+  };
+}