about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSandro <sandro.jaeckel@gmail.com>2021-01-25 01:22:49 +0100
committerGitHub <noreply@github.com>2021-01-25 01:22:49 +0100
commit32e44ef1828a4378d0336e97ca1eb2681cec5fa3 (patch)
treebaa37fe312904f618495c5204e38cca38ef6698b /pkgs/tools
parent057017ee8673a217da3b7530b298fbd0b974000f (diff)
parentd935afe655831c56321d48a22b037ecaabaf5d06 (diff)
downloadnixlib-32e44ef1828a4378d0336e97ca1eb2681cec5fa3.tar
nixlib-32e44ef1828a4378d0336e97ca1eb2681cec5fa3.tar.gz
nixlib-32e44ef1828a4378d0336e97ca1eb2681cec5fa3.tar.bz2
nixlib-32e44ef1828a4378d0336e97ca1eb2681cec5fa3.tar.lz
nixlib-32e44ef1828a4378d0336e97ca1eb2681cec5fa3.tar.xz
nixlib-32e44ef1828a4378d0336e97ca1eb2681cec5fa3.tar.zst
nixlib-32e44ef1828a4378d0336e97ca1eb2681cec5fa3.zip
Merge pull request #110575 from nyanotech/aahjlgahldd
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/proxmark3/proxmark3-rrg.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/tools/security/proxmark3/proxmark3-rrg.nix b/pkgs/tools/security/proxmark3/proxmark3-rrg.nix
new file mode 100644
index 000000000000..bf1bcd67d11d
--- /dev/null
+++ b/pkgs/tools/security/proxmark3/proxmark3-rrg.nix
@@ -0,0 +1,38 @@
+{ stdenv, mkDerivation, fetchFromGitHub, pkg-config, gcc-arm-embedded, bluez5
+, readline
+
+, hardwarePlatform ? "PM3RDV4"
+
+, hardwarePlatformExtras ? "" }:
+
+mkDerivation rec {
+  pname = "proxmark3-rrg";
+  version = "4.9237";
+
+  src = fetchFromGitHub {
+    owner = "RfidResearchGroup";
+    repo = "proxmark3";
+    rev = "v${version}";
+    sha256 = "13xrhvrsm73rfgqpgca6a37c3jixdkxvfggmacnnx5fdfb393bfx";
+  };
+
+  nativeBuildInputs = [ pkg-config gcc-arm-embedded ];
+  buildInputs = [ bluez5 readline ];
+
+  makeFlags = [
+    "PLATFORM=${hardwarePlatform}"
+    "PLATFORM_EXTRAS=${hardwarePlatformExtras}"
+  ];
+
+  installPhase = ''
+    install -Dt $out/bin client/proxmark3
+    install -Dt $out/firmware bootrom/obj/bootrom.elf armsrc/obj/fullimage.elf
+  '';
+
+  meta = with stdenv.lib; {
+    description = "Client for proxmark3, powerful general purpose RFID tool";
+    homepage = "https://rfidresearchgroup.com/";
+    license = licenses.gpl2Plus;
+    maintainers = with maintainers; [ nyanotech ];
+  };
+}