about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2018-11-11 02:46:03 +0100
committerGitHub <noreply@github.com>2018-11-11 02:46:03 +0100
commit32cbcbf1792e4eeefe16ff74cdac7cf53b014f2d (patch)
tree6290994f53423b3d232f37bb0305330f5b8e84b4 /pkgs/tools
parent2dd37688e3e7f3faf7c893999118eab8910d333f (diff)
parent0045ea5b10edd00f00a5077fb3b0107f5b242e89 (diff)
downloadnixlib-32cbcbf1792e4eeefe16ff74cdac7cf53b014f2d.tar
nixlib-32cbcbf1792e4eeefe16ff74cdac7cf53b014f2d.tar.gz
nixlib-32cbcbf1792e4eeefe16ff74cdac7cf53b014f2d.tar.bz2
nixlib-32cbcbf1792e4eeefe16ff74cdac7cf53b014f2d.tar.lz
nixlib-32cbcbf1792e4eeefe16ff74cdac7cf53b014f2d.tar.xz
nixlib-32cbcbf1792e4eeefe16ff74cdac7cf53b014f2d.tar.zst
nixlib-32cbcbf1792e4eeefe16ff74cdac7cf53b014f2d.zip
Merge pull request #50018 from Ma27/init-up
up: init at 0.3.1
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/up/default.nix23
-rw-r--r--pkgs/tools/misc/up/deps.nix66
2 files changed, 89 insertions, 0 deletions
diff --git a/pkgs/tools/misc/up/default.nix b/pkgs/tools/misc/up/default.nix
new file mode 100644
index 000000000000..c09c5ad12f08
--- /dev/null
+++ b/pkgs/tools/misc/up/default.nix
@@ -0,0 +1,23 @@
+{ lib, buildGoPackage, fetchFromGitHub }:
+
+buildGoPackage rec {
+  name = "up-${version}";
+  version = "0.3.1";
+
+  src = fetchFromGitHub {
+    owner = "akavel";
+    repo = "up";
+    rev = "v${version}";
+    sha256 = "171bwbk2c7jbi51xdawzv7qy71492mfs9z5j0a5j52qmnr4vjjgs";
+  };
+
+  goPackagePath = "github.com/akavel/up";
+  goDeps = ./deps.nix;
+
+  meta = with lib; {
+    description = "Ultimate Plumber is a tool for writing Linux pipes with instant live preview";
+    homepage = https://github.com/akavel/up;
+    maintainers = with maintainers; [ ma27 ];
+    license = licenses.asl20;
+  };
+}
diff --git a/pkgs/tools/misc/up/deps.nix b/pkgs/tools/misc/up/deps.nix
new file mode 100644
index 000000000000..439dc5df9d4d
--- /dev/null
+++ b/pkgs/tools/misc/up/deps.nix
@@ -0,0 +1,66 @@
+# This file was generated by https://github.com/kamilchm/go2nix v1.2.1
+[
+  {
+    goPackagePath = "github.com/gdamore/encoding";
+    fetch = {
+      type = "git";
+      url = "https://github.com/gdamore/encoding";
+      rev = "b23993cbb6353f0e6aa98d0ee318a34728f628b9";
+      sha256 = "0d7irqpx2fa9vkxgkhf04yiwazsm10fxh0yk86x5crflhph5fv8a";
+    };
+  }
+  {
+    goPackagePath = "github.com/gdamore/tcell";
+    fetch = {
+      type = "git";
+      url = "https://github.com/gdamore/tcell";
+      rev = "017915a4d77dabd7af10ab539e618a735d4b9c0a";
+      sha256 = "19ymkgcvcp9sz2jrfi7h6l720w5yw9hy3wnw975w2ih45j1ypqdh";
+    };
+  }
+  {
+    goPackagePath = "github.com/lucasb-eyer/go-colorful";
+    fetch = {
+      type = "git";
+      url = "https://github.com/lucasb-eyer/go-colorful";
+      rev = "12d3b2882a08d1abc9488e34f3e1ae35165f2d07";
+      sha256 = "1w95axfn1a6rz31xrks77ingr9mdkqyr7mh0glv664kz1wg2h0gw";
+    };
+  }
+  {
+    goPackagePath = "github.com/mattn/go-isatty";
+    fetch = {
+      type = "git";
+      url = "https://github.com/mattn/go-isatty";
+      rev = "3fb116b820352b7f0c281308a4d6250c22d94e27";
+      sha256 = "084hplr4n4g5nvp70clljk428hc963460xz0ggcj3xdi4w7hhsvv";
+    };
+  }
+  {
+    goPackagePath = "github.com/mattn/go-runewidth";
+    fetch = {
+      type = "git";
+      url = "https://github.com/mattn/go-runewidth";
+      rev = "b20a3daf6a39840c202fd42cc23d53607162b045";
+      sha256 = "0crivpncmh22696d5cy7k15ll5yqfjcigk0xy73wb6g1q6vnfxs7";
+    };
+  }
+  {
+    goPackagePath = "github.com/spf13/pflag";
+    fetch = {
+      type = "git";
+      url = "https://github.com/spf13/pflag";
+      rev = "aea12ed6721610dc6ed40141676d7ab0a1dac9e9";
+      sha256 = "17p5k37bnzj6wfh000y7xpvxyv2wsfa3db9sm8da2frjvn7jgbp2";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/text";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/text";
+      rev = "6f44c5a2ea40ee3593d98cdcc905cc1fdaa660e2";
+      sha256 = "00mwzxly5isgf0glz7k3k2dkyqkjfc4z55qxajx4lgcp3h8xn9xj";
+    };
+  }
+]