about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorgithub-actions[bot] <41898282+github-actions[bot]@users.noreply.github.com>2023-09-23 12:01:04 +0000
committerGitHub <noreply@github.com>2023-09-23 12:01:04 +0000
commit3180ce092dffa6819ee172ab752c0dc5b2773654 (patch)
tree5700c9687a94b13a9d5f8539b123504d32b0515d /pkgs/tools
parent47f278a93631dfb050fca039041646d0377b36b2 (diff)
parent79e43fbfbcf05142735f4ec223d21746a710c50f (diff)
downloadnixlib-3180ce092dffa6819ee172ab752c0dc5b2773654.tar
nixlib-3180ce092dffa6819ee172ab752c0dc5b2773654.tar.gz
nixlib-3180ce092dffa6819ee172ab752c0dc5b2773654.tar.bz2
nixlib-3180ce092dffa6819ee172ab752c0dc5b2773654.tar.lz
nixlib-3180ce092dffa6819ee172ab752c0dc5b2773654.tar.xz
nixlib-3180ce092dffa6819ee172ab752c0dc5b2773654.tar.zst
nixlib-3180ce092dffa6819ee172ab752c0dc5b2773654.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/security/naabu/default.nix6
-rw-r--r--pkgs/tools/security/trufflehog/default.nix6
-rw-r--r--pkgs/tools/text/txr/default.nix1
3 files changed, 6 insertions, 7 deletions
diff --git a/pkgs/tools/security/naabu/default.nix b/pkgs/tools/security/naabu/default.nix
index 9ff500a7fb92..8ed883b8e1b3 100644
--- a/pkgs/tools/security/naabu/default.nix
+++ b/pkgs/tools/security/naabu/default.nix
@@ -6,16 +6,16 @@
 
 buildGoModule rec {
   pname = "naabu";
-  version = "2.1.7";
+  version = "2.1.8";
 
   src = fetchFromGitHub {
     owner = "projectdiscovery";
     repo = "naabu";
     rev = "refs/tags/v${version}";
-    hash = "sha256-x6TmV8c5p9Uuc9uJG3+FNNpdmzdzgQpsyO29dly7PuU=";
+    hash = "sha256-/EVlg0NhWJRowHttwYq+i/3BhO5o8w74kRLWIjSI6AQ=";
   };
 
-  vendorHash = "sha256-9LIPRiLKszfz9Gj26G03TPHOqCXi1s3CYiaadInlD84=";
+  vendorHash = "sha256-LoYArDsCJCDSI02nFSUVemYNeF+q5xAjV2QyWjMOXIY=";
 
   buildInputs = [
     libpcap
diff --git a/pkgs/tools/security/trufflehog/default.nix b/pkgs/tools/security/trufflehog/default.nix
index f40c6d86bf37..6156b0c98873 100644
--- a/pkgs/tools/security/trufflehog/default.nix
+++ b/pkgs/tools/security/trufflehog/default.nix
@@ -7,16 +7,16 @@
 
 buildGoModule rec {
   pname = "trufflehog";
-  version = "3.56.1";
+  version = "3.57.0";
 
   src = fetchFromGitHub {
     owner = "trufflesecurity";
     repo = "trufflehog";
     rev = "refs/tags/v${version}";
-    hash = "sha256-4FN3FAs6Sc2LLcqaKsSxJS9VVNwp/Zit9gZT+qDXRik=";
+    hash = "sha256-EzzjtrorfFYO6mEe8F/lYbHP96G04pFIRc6fzLa8eeY=";
   };
 
-  vendorHash = "sha256-NBwPyA+NuW9RA/dXj+FpTa6RU0WOZRrey7gosDOatG8=";
+  vendorHash = "sha256-iCCk5ngXsAyVaPeCllIrT1KjoM0KlNlgCiLeASquMco=";
 
   ldflags = [
     "-s"
diff --git a/pkgs/tools/text/txr/default.nix b/pkgs/tools/text/txr/default.nix
index dceedbdc5101..1b7062d9ddcc 100644
--- a/pkgs/tools/text/txr/default.nix
+++ b/pkgs/tools/text/txr/default.nix
@@ -69,6 +69,5 @@ stdenv.mkDerivation (finalAttrs: {
     license = lib.licenses.bsd2;
     maintainers = with lib.maintainers; [ AndersonTorres dtzWill ];
     platforms = lib.platforms.all;
-    broken = stdenv.isDarwin && stdenv.isx86_64; # ofborg fails while testing
   };
 })