about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2018-10-04 10:20:31 -0500
committerWill Dietz <w@wdtz.org>2018-10-08 19:45:01 -0500
commit2de131bfc3ca974acc7b6c03e0889527e302f60d (patch)
treed7fe3942fe75a1172ea3d064d4048fd8d512f1d4 /pkgs/tools
parent844bcbd13728fc55f5459341287e5e8943a5418f (diff)
downloadnixlib-2de131bfc3ca974acc7b6c03e0889527e302f60d.tar
nixlib-2de131bfc3ca974acc7b6c03e0889527e302f60d.tar.gz
nixlib-2de131bfc3ca974acc7b6c03e0889527e302f60d.tar.bz2
nixlib-2de131bfc3ca974acc7b6c03e0889527e302f60d.tar.lz
nixlib-2de131bfc3ca974acc7b6c03e0889527e302f60d.tar.xz
nixlib-2de131bfc3ca974acc7b6c03e0889527e302f60d.tar.zst
nixlib-2de131bfc3ca974acc7b6c03e0889527e302f60d.zip
dex: grab simple upstream patch so it reports the right version
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/X11/dex/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/tools/X11/dex/default.nix b/pkgs/tools/X11/dex/default.nix
index fd0c0503de9f..9387c62c2a51 100644
--- a/pkgs/tools/X11/dex/default.nix
+++ b/pkgs/tools/X11/dex/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, python3 }:
+{ stdenv, fetchFromGitHub, python3, fetchpatch }:
 
 stdenv.mkDerivation rec {
   program = "dex";
@@ -16,6 +16,13 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ python3.pkgs.sphinx ];
   makeFlags = [ "PREFIX=$(out)" "VERSION=$(version)" ];
 
+  patches = [
+    (fetchpatch {
+      url = https://github.com/jceb/dex/commit/107358ddf5e1ca4fa56ef1a7ab161dc3b6adc45a.patch;
+      sha256 = "06dfkfzxp8199by0jc5wim8g8qw38j09dq9p6n9w4zaasla60pjq";
+    })
+  ];
+
   meta = with stdenv.lib; {
     description = "A program to generate and execute DesktopEntry files of the Application type";
     homepage = https://github.com/jceb/dex;