about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
authorPeter Hoeg <peter@hoeg.com>2020-01-27 23:37:45 +0800
committerGitHub <noreply@github.com>2020-01-27 23:37:45 +0800
commit291dac48cf83794dc47bbf830df2457890f9bf7c (patch)
tree84e670a175762d70bdded82b4cf0f97496e7c260 /pkgs/tools
parent3946ade5513c57530ea3c9be9e13c5b1beafaa1b (diff)
parente527dc62d71cebe35c1bbd933e3317e5a7f6fd5b (diff)
downloadnixlib-291dac48cf83794dc47bbf830df2457890f9bf7c.tar
nixlib-291dac48cf83794dc47bbf830df2457890f9bf7c.tar.gz
nixlib-291dac48cf83794dc47bbf830df2457890f9bf7c.tar.bz2
nixlib-291dac48cf83794dc47bbf830df2457890f9bf7c.tar.lz
nixlib-291dac48cf83794dc47bbf830df2457890f9bf7c.tar.xz
nixlib-291dac48cf83794dc47bbf830df2457890f9bf7c.tar.zst
nixlib-291dac48cf83794dc47bbf830df2457890f9bf7c.zip
Merge pull request #78349 from peterhoeg/fix_mc
mc: /bin/rm does not exist
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/mc/default.nix47
1 files changed, 39 insertions, 8 deletions
diff --git a/pkgs/tools/misc/mc/default.nix b/pkgs/tools/misc/mc/default.nix
index b2711903ead1..168afc7efedd 100644
--- a/pkgs/tools/misc/mc/default.nix
+++ b/pkgs/tools/misc/mc/default.nix
@@ -1,5 +1,21 @@
-{ stdenv, fetchurl, pkgconfig, glib, gpm, file, e2fsprogs
-, libX11, libICE, perl, zip, unzip, gettext, slang, libssh2, openssl}:
+{ stdenv
+, fetchurl
+, pkgconfig
+, glib
+, gpm
+, file
+, e2fsprogs
+, libX11
+, libICE
+, perl
+, zip
+, unzip
+, gettext
+, slang
+, libssh2
+, openssl
+, coreutils
+}:
 
 stdenv.mkDerivation rec {
   pname = "mc";
@@ -13,26 +29,41 @@ stdenv.mkDerivation rec {
   nativeBuildInputs = [ pkgconfig ];
 
   buildInputs = [
-    perl glib slang zip unzip file gettext libX11 libICE libssh2 openssl
+    file
+    gettext
+    glib
+    libICE
+    libX11
+    libssh2
+    openssl
+    perl
+    slang
+    unzip
+    zip
   ] ++ stdenv.lib.optionals (!stdenv.isDarwin) [ e2fsprogs gpm ];
 
   enableParallelBuilding = true;
 
   configureFlags = [ "--enable-vfs-smb" ];
 
+  postPatch = ''
+    substituteInPlace src/filemanager/ext.c \
+      --replace /bin/rm ${coreutils}/bin/rm
+  '';
+
   postFixup = ''
     # remove unwanted build-dependency references
     sed -i -e "s!PKG_CONFIG_PATH=''${PKG_CONFIG_PATH}!PKG_CONFIG_PATH=$(echo "$PKG_CONFIG_PATH" | sed -e 's/./0/g')!" $out/bin/mc
   '';
 
-  meta = {
+  meta = with stdenv.lib; {
     description = "File Manager and User Shell for the GNU Project";
-    homepage = http://www.midnight-commander.org;
     downloadPage = "http://www.midnight-commander.org/downloads/";
+    homepage = "http://www.midnight-commander.org";
+    license = licenses.gpl2Plus;
+    maintainers = with maintainers; [ sander ];
+    platforms = with platforms; linux ++ darwin;
     repositories.git = git://github.com/MidnightCommander/mc.git;
-    license = stdenv.lib.licenses.gpl2Plus;
-    maintainers = [ stdenv.lib.maintainers.sander ];
-    platforms = with stdenv.lib.platforms; linux ++ darwin;
     updateWalker = true;
   };
 }